aboutsummaryrefslogtreecommitdiffstats
path: root/security/py-xmlsec
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2009-01-11 23:03:34 +0800
committerpav <pav@FreeBSD.org>2009-01-11 23:03:34 +0800
commit5b31ca78eeea92eaa30a45c636e78c3b0ebba885 (patch)
tree453c889e386e70ad482724568742a4dc8255177c /security/py-xmlsec
parentff179a5b220a58cfe4141cdb9aa6bfbb1d3461a9 (diff)
downloadfreebsd-ports-gnome-5b31ca78eeea92eaa30a45c636e78c3b0ebba885.tar.gz
freebsd-ports-gnome-5b31ca78eeea92eaa30a45c636e78c3b0ebba885.tar.zst
freebsd-ports-gnome-5b31ca78eeea92eaa30a45c636e78c3b0ebba885.zip
- Fix runtime crash on 64 bit platforms
PR: ports/127616 Submitted by: Tom Evans <tevans.uk@googlemail.com>
Diffstat (limited to 'security/py-xmlsec')
-rw-r--r--security/py-xmlsec/Makefile1
-rw-r--r--security/py-xmlsec/files/patch-setup.py12
2 files changed, 13 insertions, 0 deletions
diff --git a/security/py-xmlsec/Makefile b/security/py-xmlsec/Makefile
index b5dc715d6d41..12feccbb15b7 100644
--- a/security/py-xmlsec/Makefile
+++ b/security/py-xmlsec/Makefile
@@ -8,6 +8,7 @@
PORTNAME= xmlsec
PORTVERSION= 0.3.0
+PORTREVISION= 1
CATEGORIES= security python
MASTER_SITES= http://labs.libre-entreprise.org/frs/download.php/430/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/security/py-xmlsec/files/patch-setup.py b/security/py-xmlsec/files/patch-setup.py
index 2a58511140d6..073eab6bd794 100644
--- a/security/py-xmlsec/files/patch-setup.py
+++ b/security/py-xmlsec/files/patch-setup.py
@@ -39,3 +39,15 @@
define_macros = []
include_dirs = []
+@@ -104,7 +104,10 @@
+ if flag[2:] not in include_dirs:
+ include_dirs.append(flag[2:])
+ elif flag[:2] == "-D":
+- t = tuple(flag[2:].split('='))
++ t = flag[2:].split('=')
++ if (len(t) == 1):
++ t.append('1')
++ t = tuple(t)
+ if t not in define_macros:
+ define_macros.append(t)
+ else: