aboutsummaryrefslogtreecommitdiffstats
path: root/security/qtfw/Makefile
diff options
context:
space:
mode:
authordwcjr <dwcjr@FreeBSD.org>2001-09-15 12:47:29 +0800
committerdwcjr <dwcjr@FreeBSD.org>2001-09-15 12:47:29 +0800
commit58d4b7ce9a7c2b752751921060a478a85261bed7 (patch)
tree09dac74afd1be8657aea2a407e40769b1f231790 /security/qtfw/Makefile
parent4c1454ba67638a9a93d5935fdbe36f3ade4da214 (diff)
downloadfreebsd-ports-gnome-58d4b7ce9a7c2b752751921060a478a85261bed7.tar.gz
freebsd-ports-gnome-58d4b7ce9a7c2b752751921060a478a85261bed7.tar.zst
freebsd-ports-gnome-58d4b7ce9a7c2b752751921060a478a85261bed7.zip
Update to 0.4
PR: 30578 Submitted by: maintainer
Diffstat (limited to 'security/qtfw/Makefile')
-rw-r--r--security/qtfw/Makefile22
1 files changed, 19 insertions, 3 deletions
diff --git a/security/qtfw/Makefile b/security/qtfw/Makefile
index c457a2d19610..2136fd271969 100644
--- a/security/qtfw/Makefile
+++ b/security/qtfw/Makefile
@@ -6,18 +6,34 @@
#
PORTNAME= qtfw
-PORTVERSION= 0.3.1
+PORTVERSION= 0.4
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= pat@databits.net
-ALL_TARGET= ${PORTNAME}
+HAS_CONFIGURE= yes
+USE_GMAKE= yes
USE_QT_VER= 2
+CONFIGURE_ENV= CXXFLAGS="${CXXFLAGS}"
-post-install:
+pre-patch:
+ @${PERL} -pi.orig -e 's|^\ *CXXFLAGS=.*||' \
+ ${WRKSRC}/configure
+ @${PERL} -pi.orig -e 's|\-O2||' ${WRKSRC}/qtfw/Makefile.in
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/qtfw/qtfw ${PREFIX}/bin
+ @${MKDIR} ${DATADIR}
+.for files in gear qtfwlogo
+ @${INSTALL_DATA} ${WRKSRC}/pics/${files}.png ${DATADIR}
+.endfor
.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for docs in index.html ipfwman.html qtfwlogo.jpeg
+ @${INSTALL_DATA} ${WRKSRC}/docs/${docs} ${DOCSDIR}
+.endfor
@${MKDIR} ${PREFIX}/share/examples/${PORTNAME}
@${INSTALL_DATA} ${WRKSRC}/examples/* \
${PREFIX}/share/examples/${PORTNAME}