aboutsummaryrefslogtreecommitdiffstats
path: root/security/racoon2/Makefile
diff options
context:
space:
mode:
authorsumikawa <sumikawa@FreeBSD.org>2000-07-05 17:19:28 +0800
committersumikawa <sumikawa@FreeBSD.org>2000-07-05 17:19:28 +0800
commita89ea977148a8e5af613460931a850ec9da79b8c (patch)
treeb86e2c17ebea7a89fec259d9077e7ad147eecd43 /security/racoon2/Makefile
parentf5ec051f7741e2d5f5cb6f69ae9d66b7841b8de0 (diff)
downloadfreebsd-ports-gnome-a89ea977148a8e5af613460931a850ec9da79b8c.tar.gz
freebsd-ports-gnome-a89ea977148a8e5af613460931a850ec9da79b8c.tar.zst
freebsd-ports-gnome-a89ea977148a8e5af613460931a850ec9da79b8c.zip
racoon: KAME IKE daemon
Diffstat (limited to 'security/racoon2/Makefile')
-rw-r--r--security/racoon2/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/security/racoon2/Makefile b/security/racoon2/Makefile
new file mode 100644
index 000000000000..84a796e75126
--- /dev/null
+++ b/security/racoon2/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: racoon
+# Date created: 4 July 2000
+# Whom: sumikawa
+#
+# $FreeBSD$
+#
+
+PORTNAME= racoon
+PORTVERSION= 20000705a
+CATEGORIES= security net
+MASTER_SITES= ftp://ftp.kame.net/pub/kame/misc/
+
+MAINTAINER= sumikawa@FreeBSD.org
+
+.if !exists(/usr/lib/libipsec.so.1)
+BROKEN= "You must upgrade the OS"
+.endif
+
+USE_OPENSSL= RSA
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/racoon
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+=CPPFLAGS=-I${LOCALBASE}/include CFLAGS=-I${LOCALBASE}/include \
+ LDFLAGS="-L${LOCALBASE}/lib -L${WRKSRC}/../libipsec"
+CONFIGURE_ARGS+=--enable-debug
+CONFIGURE_ARGS+=--enable-ipv6
+CONFIGURE_ARGS+=--sysconfdir=${LOCALBASE}/etc
+
+MAN5= racoon.conf.5
+MAN8= racoon.8
+
+pre-patch:
+ ${MV} ${WRKSRC}/racoon.8 ${WRKSRC}/racoon.8.in
+
+pre-configure:
+ (cd ${WRKSRC}/../libipsec; make)
+
+.include <bsd.port.mk>