aboutsummaryrefslogtreecommitdiffstats
path: root/security/razorback-api
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-08-20 22:30:58 +0800
committeradamw <adamw@FreeBSD.org>2014-08-20 22:30:58 +0800
commit24bbad9891f75eb94dcbcbdc33f37b7d8fd58fd2 (patch)
treedcd47ca9847dde6c2d6427dd6fcf4be65af8f941 /security/razorback-api
parente637ea731a88b613bbe4e8ac44d0bc0d72c01582 (diff)
downloadfreebsd-ports-gnome-24bbad9891f75eb94dcbcbdc33f37b7d8fd58fd2.tar.gz
freebsd-ports-gnome-24bbad9891f75eb94dcbcbdc33f37b7d8fd58fd2.tar.zst
freebsd-ports-gnome-24bbad9891f75eb94dcbcbdc33f37b7d8fd58fd2.zip
Fix build, broken in the json-c 0.12 upgrade. Given the nature of the errors there
are likely other ports that will fail in similar ways. (i.e. libjson.so->libjson-c.so, and json/json.h -> json-c/json.h). While here, use OPTIONS helpers to avoid unnecessary bsd.port.options.mk inclusion.
Diffstat (limited to 'security/razorback-api')
-rw-r--r--security/razorback-api/Makefile28
-rw-r--r--security/razorback-api/files/patch-common_m4__api_deps.m411
-rw-r--r--security/razorback-api/files/patch-common_m4__compiler_options.m411
-rw-r--r--security/razorback-api/files/patch-include__razorback__json_buffer.h11
4 files changed, 39 insertions, 22 deletions
diff --git a/security/razorback-api/Makefile b/security/razorback-api/Makefile
index 66dcd8b7a63a..2dc03d19d7d2 100644
--- a/security/razorback-api/Makefile
+++ b/security/razorback-api/Makefile
@@ -17,7 +17,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libconfig.so:${PORTSDIR}/devel/libconfig \
libuuid.so:${PORTSDIR}/misc/e2fsprogs-libuuid \
libcurl.so:${PORTSDIR}/ftp/curl \
- libjson.so:${PORTSDIR}/devel/json-c
+ libjson-c.so:${PORTSDIR}/devel/json-c
OPTIONS_DEFINE= DEBUG ASSERT CNC_DEBUG STOMP_DEBUG
@@ -27,31 +27,15 @@ STOMP_DEBUG_DESC= Enable STOMP Debug
GNU_CONFIGURE= yes
USES= libtool pathfix pkgconfig
USE_LDCONFIG= yes
+USE_AUTOTOOLS= autoconf
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
BROKEN_sparc64= Does not compile on sparc64
-.include <bsd.port.options.mk>
-
-.if !empty(PORT_OPTIONS:MDEBUG)
-CONFIGURE_ARGS+=--enable-debug
-.endif
-
-.if !empty(PORT_OPTIONS:MASSERT)
-CONFIGURE_ARGS+=--enable-assert
-.endif
-
-.if !empty(PORT_OPTIONS:MCNC_DEBUG)
-CONFIGURE_ARGS+=--enable-cnc-debug
-.endif
-
-.if !empty(PORT_OPTIONS:MSTOMP_DEBUG)
-CONFIGURE_ARGS+=--enable-stomp-debug
-.endif
-
-post-patch:
- @${REINPLACE_CMD} -e "s/-Werror//g" \
- ${WRKSRC}/configure
+DEBUG_CONFIGURE_ENABLE= debug
+ASSERT_CONFIGURE_ENABLE= assert
+CNC_DEBUG_CONFIGURE_ENABLE= cnc-debug
+STOMP_DEBUG_CONFIGURE_ENABLE= stomp-debug
.include <bsd.port.mk>
diff --git a/security/razorback-api/files/patch-common_m4__api_deps.m4 b/security/razorback-api/files/patch-common_m4__api_deps.m4
new file mode 100644
index 000000000000..be6ca2f253bc
--- /dev/null
+++ b/security/razorback-api/files/patch-common_m4__api_deps.m4
@@ -0,0 +1,11 @@
+--- ./common_m4/api_deps.m4.orig 2014-08-20 10:21:22.000000000 -0400
++++ ./common_m4/api_deps.m4 2014-08-20 10:21:36.000000000 -0400
+@@ -55,7 +55,7 @@
+ # [AC_MSG_ERROR("curl header file not found")]
+ # )
+
+-PKG_CHECK_MODULES([JSON], [json >= 0.9])
++PKG_CHECK_MODULES([JSON], [json-c >= 0.9])
+
+ CFLAGS="$JSON_CFLAGS $CFLAGS"
+ LIBS="$JSON_LIBS $LIBS"
diff --git a/security/razorback-api/files/patch-common_m4__compiler_options.m4 b/security/razorback-api/files/patch-common_m4__compiler_options.m4
new file mode 100644
index 000000000000..956c64b036f7
--- /dev/null
+++ b/security/razorback-api/files/patch-common_m4__compiler_options.m4
@@ -0,0 +1,11 @@
+--- ./common_m4/compiler_options.m4.orig 2014-08-20 10:21:07.000000000 -0400
++++ ./common_m4/compiler_options.m4 2014-08-20 10:21:17.000000000 -0400
+@@ -28,7 +28,7 @@
+
+ CFLAGS="$CFLAGS -std=c99 -fno-strict-aliasing"
+ CPPFLAGS="$CPPFLAGS -fno-strict-aliasing"
+- CWARNINGS="$CWARNINGS -Wall -Werror -Wwrite-strings -Wformat -fdiagnostics-show-option -Wextra -Wformat-security -Wsign-compare -Wcast-align -Wno-unused-parameter"
++ CWARNINGS="$CWARNINGS -Wall -Wwrite-strings -Wformat -fdiagnostics-show-option -Wextra -Wformat-security -Wsign-compare -Wcast-align -Wno-unused-parameter"
+ if test "x$NOT_PEDANTIC" = "x"; then
+ CWARNINGS="$CWARNINGS -pedantic"
+ fi
diff --git a/security/razorback-api/files/patch-include__razorback__json_buffer.h b/security/razorback-api/files/patch-include__razorback__json_buffer.h
new file mode 100644
index 000000000000..52021972c1c9
--- /dev/null
+++ b/security/razorback-api/files/patch-include__razorback__json_buffer.h
@@ -0,0 +1,11 @@
+--- ./include/razorback/json_buffer.h.orig 2014-08-20 10:25:03.000000000 -0400
++++ ./include/razorback/json_buffer.h 2014-08-20 10:25:26.000000000 -0400
+@@ -9,7 +9,7 @@
+ #include <razorback/messages.h>
+ #include <razorback/ntlv.h>
+
+-#include <json/json.h>
++#include <json-c/json.h>
+
+ #ifdef __cplusplus
+ extern "C" {