aboutsummaryrefslogtreecommitdiffstats
path: root/security/razorback-fsWalk
diff options
context:
space:
mode:
authortj <tj@FreeBSD.org>2012-06-02 02:20:26 +0800
committertj <tj@FreeBSD.org>2012-06-02 02:20:26 +0800
commitb4dd9bdbbdedc3055b1096a4188b891ee548d947 (patch)
tree35613d1f867b918d065dd88aa83d8458161ed1f4 /security/razorback-fsWalk
parent69333bbb896692a5f401b80acf706d33290a42d5 (diff)
downloadfreebsd-ports-gnome-b4dd9bdbbdedc3055b1096a4188b891ee548d947.tar.gz
freebsd-ports-gnome-b4dd9bdbbdedc3055b1096a4188b891ee548d947.tar.zst
freebsd-ports-gnome-b4dd9bdbbdedc3055b1096a4188b891ee548d947.zip
Convert to OptionsNG framework.
Approved by: eadler (mentor)
Diffstat (limited to 'security/razorback-fsWalk')
-rw-r--r--security/razorback-fsWalk/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/security/razorback-fsWalk/Makefile b/security/razorback-fsWalk/Makefile
index 4650144ab0e2..666b2c20d3a9 100644
--- a/security/razorback-fsWalk/Makefile
+++ b/security/razorback-fsWalk/Makefile
@@ -20,19 +20,20 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= razorback_api.2:${PORTSDIR}/security/razorback-api
-OPTIONS= DEBUG "Enable Debug" off \
- ASSERT "Enable Asserts" off
+OPTIONS_DEFINE= DEBUG ASSERT
+
+.include <bsd.port.options.mk>
GNU_CONFIGURE= yes
USE_AUTOTOOLS= libtool
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-.if defined(WITH_DEBUG)
+.if !empty(PORT_OPTIONS:MDEBUG)
CONFIGURE_ARGS+=--enable-debug
.endif
-.if defined(WITH_ASSERT)
+.if !empty(PORT_OPTIONS:MASSERT)
CONFIGURE_ARGS+=--enable-assert
.endif