aboutsummaryrefslogtreecommitdiffstats
path: root/security/rid/Makefile
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2000-02-14 10:59:36 +0800
committerobrien <obrien@FreeBSD.org>2000-02-14 10:59:36 +0800
commit2b31e56b29741729fb62be17d9544b7f1ab51fb9 (patch)
tree11fd5df819a4ffc8a8939810a0d5c4dc389492e5 /security/rid/Makefile
parent0529c8f0e1a2fef6a48dd8ac1c876600935e7f07 (diff)
downloadfreebsd-ports-gnome-2b31e56b29741729fb62be17d9544b7f1ab51fb9.tar.gz
freebsd-ports-gnome-2b31e56b29741729fb62be17d9544b7f1ab51fb9.tar.zst
freebsd-ports-gnome-2b31e56b29741729fb62be17d9544b7f1ab51fb9.zip
RID is a configurable tool which uses intrusion fingerprints to track down
compromised hosts. RID can remotely detect Stacheldraht, TFN, Trinoo and TFN2k if the attacker did not change the default ports.
Diffstat (limited to 'security/rid/Makefile')
-rw-r--r--security/rid/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/security/rid/Makefile b/security/rid/Makefile
new file mode 100644
index 000000000000..d80be02afc82
--- /dev/null
+++ b/security/rid/Makefile
@@ -0,0 +1,34 @@
+# ex:ts=8
+# Ports collection makefile for: ddos_scan
+# Version required: 1.6
+# Date created: Sun Feb 12, 2000
+# Whom: David O'Brien (obrien@NUXI.com)
+#
+# $FreeBSD$
+#
+
+DISTNAME= rid-1_0
+PKGNAME= rid-1.0
+CATEGORIES= security
+MASTER_SITES= http://packetstorm.securify.com/distributed/ \
+ ftp://ftp.ntua.gr/pub/security/technotronic/denial/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= obrien@FreeBSD.org
+
+WRKSRC= ${WRKDIR}/${PKGNAME}
+ALL_TARGET= rid
+
+pre-configure:
+ @${PERL} -pi -e 's:config.txt:${PREFIX}/etc/rid.conf:g' \
+ ${WRKSRC}/config.h
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/rid ${PREFIX}/sbin
+ @${INSTALL_DATA} ${WRKSRC}/config.txt ${PREFIX}/etc/rid.conf
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/rid
+ @${INSTALL_MAN} ${WRKSRC}/README ${PREFIX}/share/doc/rid
+.endif
+
+.include <bsd.port.mk>