aboutsummaryrefslogtreecommitdiffstats
path: root/security/ruby-mcrypt/Makefile
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2001-06-21 19:37:30 +0800
committerknu <knu@FreeBSD.org>2001-06-21 19:37:30 +0800
commite439267b69c7dd9333092beeb3d0f7cdb250276c (patch)
treecdfdcfd356c4c14fd58a30b736ec4e243c7cc765 /security/ruby-mcrypt/Makefile
parent8bc4f5f56eaed682d718b3d1b84080ad58879780 (diff)
downloadfreebsd-ports-gnome-e439267b69c7dd9333092beeb3d0f7cdb250276c.tar.gz
freebsd-ports-gnome-e439267b69c7dd9333092beeb3d0f7cdb250276c.tar.zst
freebsd-ports-gnome-e439267b69c7dd9333092beeb3d0f7cdb250276c.zip
Add ruby-mcrypt, a Ruby interface to the mcrypt library.
Diffstat (limited to 'security/ruby-mcrypt/Makefile')
-rw-r--r--security/ruby-mcrypt/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/security/ruby-mcrypt/Makefile b/security/ruby-mcrypt/Makefile
new file mode 100644
index 000000000000..e284b92ce20d
--- /dev/null
+++ b/security/ruby-mcrypt/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: Ruby/MCrypt
+# Date created: 20 June 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mcrypt
+PORTVERSION= 0.2
+CATEGORIES= security ruby
+MASTER_SITES= http://www.rubylinks.de/download/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= knu
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+LIB_DEPENDS= mcrypt.6:${PORTSDIR}/security/libmcrypt/
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+INSTALL_TARGET= site-install
+
+DOCS_EN= ChangeLog README TODO
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/testmcrypt.rb ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}
+.for f in ${DOCS_EN}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/
+.endfor
+.endif
+
+.include <bsd.port.mk>