aboutsummaryrefslogtreecommitdiffstats
path: root/security/rubygem-net-ssh-multi/Makefile
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2011-05-03 07:28:58 +0800
committerstas <stas@FreeBSD.org>2011-05-03 07:28:58 +0800
commit62827f3a7ad20f7988ef4dfeb7ebdccf48fffb26 (patch)
tree375a2d2b228e428148200113e7d3eb5d133a468a /security/rubygem-net-ssh-multi/Makefile
parent1a1a3b6a59a5c40580bd4269b22a7fcf66c9fc7b (diff)
downloadfreebsd-ports-gnome-62827f3a7ad20f7988ef4dfeb7ebdccf48fffb26.tar.gz
freebsd-ports-gnome-62827f3a7ad20f7988ef4dfeb7ebdccf48fffb26.tar.zst
freebsd-ports-gnome-62827f3a7ad20f7988ef4dfeb7ebdccf48fffb26.zip
Add rubygem-net-ssh-multi 1.0.1, SSH connection multiplexing library for
Ruby. PR: ports/ports/156780 Submitted by: Renaud Chaput <renchap at cocoa-x.com>
Diffstat (limited to 'security/rubygem-net-ssh-multi/Makefile')
-rw-r--r--security/rubygem-net-ssh-multi/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/security/rubygem-net-ssh-multi/Makefile b/security/rubygem-net-ssh-multi/Makefile
new file mode 100644
index 000000000000..60935acf475a
--- /dev/null
+++ b/security/rubygem-net-ssh-multi/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: rubygem-net-ssh-multi
+# Date created: 02 May 2011
+# Whom: Renaud Chaput <renchap@cocoa-x.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= net-ssh-multi
+PORTVERSION= 1.0.1
+CATEGORIES= security rubygems
+MASTER_SITES= RG
+
+MAINTAINER= renchap@cocoa-x.com
+COMMENT= SSH connection multiplexing library for Ruby
+
+RUN_DEPENDS= rubygem-net-ssh>=1.99.2:${PORTSDIR}/security/rubygem-net-ssh \
+ rubygem-net-ssh-gateway>=0.99.0:${PORTSDIR}/security/rubygem-net-ssh-gateway
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>