aboutsummaryrefslogtreecommitdiffstats
path: root/security/saint/Makefile
diff options
context:
space:
mode:
authorkevlo <kevlo@FreeBSD.org>2000-09-30 23:14:26 +0800
committerkevlo <kevlo@FreeBSD.org>2000-09-30 23:14:26 +0800
commit36069ce299bcc63c3fead92093d7869846e3c2a6 (patch)
treeafcb50dfc6750a68af3c8cf44610e7a3d268e224 /security/saint/Makefile
parent27ed8a65b93b10a7e0278f8bb7c0d2c6472b0036 (diff)
downloadfreebsd-ports-gnome-36069ce299bcc63c3fead92093d7869846e3c2a6.tar.gz
freebsd-ports-gnome-36069ce299bcc63c3fead92093d7869846e3c2a6.tar.zst
freebsd-ports-gnome-36069ce299bcc63c3fead92093d7869846e3c2a6.zip
Update to 3.0b1
PR: 21652 Submitted by: MAINTAINER
Diffstat (limited to 'security/saint/Makefile')
-rw-r--r--security/saint/Makefile23
1 files changed, 14 insertions, 9 deletions
diff --git a/security/saint/Makefile b/security/saint/Makefile
index d4cc8f0f6084..ac7378f97b2f 100644
--- a/security/saint/Makefile
+++ b/security/saint/Makefile
@@ -6,26 +6,31 @@
#
PORTNAME= saint
-PORTVERSION= 2.2
+PORTVERSION= 3.0
CATEGORIES= security
MASTER_SITES= ftp://ftp.wwdsi.com/pub/saint/ \
- http://www.wwdsi.com/saint/downloads/
+ http://www.wwdsi.com/saint/downloads/
MAINTAINER= cj@vallcom.net
-RUN_DEPENDS= nmap:${PORTSDIR}/security/nmap
+DISTNAME= ${PKGNAME}.beta1
+BUILD_DEPENDS= nmap:${PORTSDIR}/security/nmap
USE_PERL5= yes
-MAKE_ENV= XFLAGS="DAUTH_GID_T=int -DSYS_ERRLIST_DECLARED -DFDSETSIZE=2048"
-ALL_TARGET= freebsd
+MANCOMPRESSED= no
+MAN1= saint.1
+WRKSRC= ${WRKDIR}/saint-3.0
+GNU_CONFIGURE= yes
+MAKE_ENV= "LIBS=-lrpcsvc" "XFLAGS=-g -O2 -DSTDC_HEADERS=1 -DGETGROUPS_T=gid_t -DSYS_ERRLIST_DECLARED=1 " "RPCGEN=/usr/bin/rpcgen"
INSTALL_TARGET= all
-pre-configure:
- @ cd ${WRKSRC}; ${SETENV} ${PERL5} ${WRKSRC}/reconfig
-
pre-install:
${MKDIR} ${PREFIX}/saint
- ${TAR} --directory ${WRKSRC} -cf - . --exclude src --exclude Makefile | \
+ ${TAR} --directory ${WRKSRC} -cf - . --exclude src --exclude Makefile --exclude Makefile.in --exclude old --exclude config --exclude config.cache --exclude config.log --exclude config.status --exclude configure --exclude configure.in --exclude install-sh --exclude saint.1 | \
${TAR} --directory ${PREFIX}/saint -xf -
+.if !defined(NOPORTDOCS)
+do-install:
+ ${INSTALL_MAN} ${WRKSRC}/saint.1 ${PREFIX}/man/man1
+.endif
.include <bsd.port.mk>