aboutsummaryrefslogtreecommitdiffstats
path: root/security/scanssh
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2003-03-04 07:37:22 +0800
committernaddy <naddy@FreeBSD.org>2003-03-04 07:37:22 +0800
commitd33d7b3aceb48a7a80abef0f3f1f45b62fc69598 (patch)
tree4e3151a080c56be3247a178971cc382f25e5586e /security/scanssh
parentdc6458cc1044f8669b3c72264d3ea233b4c1591a (diff)
downloadfreebsd-ports-gnome-d33d7b3aceb48a7a80abef0f3f1f45b62fc69598.tar.gz
freebsd-ports-gnome-d33d7b3aceb48a7a80abef0f3f1f45b62fc69598.tar.zst
freebsd-ports-gnome-d33d7b3aceb48a7a80abef0f3f1f45b62fc69598.zip
Fix -p option on 64-bit archs.
Approved by: kris Obtained from: OpenBSD
Diffstat (limited to 'security/scanssh')
-rw-r--r--security/scanssh/Makefile1
-rw-r--r--security/scanssh/files/patch-pcapu.c16
2 files changed, 17 insertions, 0 deletions
diff --git a/security/scanssh/Makefile b/security/scanssh/Makefile
index bdb372a43d47..f02f06c34222 100644
--- a/security/scanssh/Makefile
+++ b/security/scanssh/Makefile
@@ -7,6 +7,7 @@
PORTNAME= scanssh
PORTVERSION= 1.60b
+PORTREVISION= 1
CATEGORIES= security net
MASTER_SITES= http://www.monkey.org/~provos/
DISTNAME= ${PORTNAME}-1.6b
diff --git a/security/scanssh/files/patch-pcapu.c b/security/scanssh/files/patch-pcapu.c
new file mode 100644
index 000000000000..2d2de113dc46
--- /dev/null
+++ b/security/scanssh/files/patch-pcapu.c
@@ -0,0 +1,16 @@
+
+$FreeBSD$
+
+--- pcapu.c.orig Mon Mar 3 17:55:38 2003
++++ pcapu.c Mon Mar 3 17:56:03 2003
+@@ -47,8 +47,8 @@
+ #include "config.h"
+
+ struct phdr {
+- unsigned long saddr;
+- unsigned long daddr;
++ in_addr_t saddr;
++ in_addr_t daddr;
+ char zero;
+ unsigned char protocol;
+ unsigned short length;