aboutsummaryrefslogtreecommitdiffstats
path: root/security/seahorse
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2009-01-10 13:22:13 +0800
committermarcus <marcus@FreeBSD.org>2009-01-10 13:22:13 +0800
commit6d8ed8f7c7511223163de715a97ffc04bf6fada9 (patch)
tree40dc015efe383243b0880df377f73ee250da7de7 /security/seahorse
parentc7f342a8d7b82e85b9625c4403600fc20ce41da6 (diff)
downloadfreebsd-ports-gnome-6d8ed8f7c7511223163de715a97ffc04bf6fada9.tar.gz
freebsd-ports-gnome-6d8ed8f7c7511223163de715a97ffc04bf6fada9.tar.zst
freebsd-ports-gnome-6d8ed8f7c7511223163de715a97ffc04bf6fada9.zip
Presenting GNOME 2.24 for FreeBSD.
See http://library.gnome.org/misc/release-notes/2.24/ for the general release notes. On the FreeBSD front, this release introduces Fuse support in HAL, adds multi-CPU support to libgtop, WebKit updates, and fixes some long-standing seahorse and gnome-keyring bugs. The documentation updates to the website are forthcoming. This release features commits by adamw, ahze, kwm, mezz, and myself. It would not have been possible without are contributors and testers: Alexander Loginov Craig Butler [1] Dmitry Marakasov [6] Eric L. Chen Joseph S. Atkinson Kris Moore Lapo Luchini [7] Nikos Ntarmos Pawel Worach Romain Tartiere TAOKA Fumiyoshi [3] Yasuda Keisuke Zyl aZ [4] bf [2] [5] Florent Thoumie Peter Wemm pluknet PR: 125857 [1] 126993 [2] 130031 [3] 127399 [4] 127661 [5] 124302 [6] 129570 [7] 129936 123790
Diffstat (limited to 'security/seahorse')
-rw-r--r--security/seahorse/Makefile55
-rw-r--r--security/seahorse/distinfo6
-rw-r--r--security/seahorse/files/patch-agent_seahorse-agent-io.c32
-rw-r--r--security/seahorse/files/patch-common_seahorse-registry.c76
-rw-r--r--security/seahorse/files/patch-common_seahorse-registry.h21
-rw-r--r--security/seahorse/files/patch-libseahorse_seahorse-ssh-operation.c10
-rw-r--r--security/seahorse/files/patch-src_seahorse-generate-select.c14
-rw-r--r--security/seahorse/files/patch-src_seahorse-viewer.c17
-rw-r--r--security/seahorse/files/patch-ssh_seahorse-ssh-operation.c19
-rw-r--r--security/seahorse/pkg-plist121
10 files changed, 183 insertions, 188 deletions
diff --git a/security/seahorse/Makefile b/security/seahorse/Makefile
index b6aa77eb52d5..0b5e7cd21ef2 100644
--- a/security/seahorse/Makefile
+++ b/security/seahorse/Makefile
@@ -3,11 +3,11 @@
# Whom: Dave McKay <dave@mu.org>
#
# $FreeBSD$
-# $MCom: ports/security/seahorse/Makefile,v 1.61 2008/03/14 14:13:03 mezz Exp $
+# $MCom: ports/security/seahorse/Makefile,v 1.73 2008/11/24 02:44:50 marcus Exp $
#
PORTNAME= seahorse
-PORTVERSION= 2.22.3
+PORTVERSION= 2.24.1
PORTREVISION= 1
CATEGORIES= security gnome
MASTER_SITES= GNOME
@@ -26,47 +26,23 @@ USE_LDCONFIG= yes
USE_BZIP2= yes
USE_GETTEXT= yes
USE_GMAKE= yes
-USE_GECKO= firefox xulrunner firefox-devel<->firefox
-USE_GNOME= gnomehack intlhack gnomeprefix libgnomeui
+USE_GNOME= gnomehack intlhack gnomeprefix libglade2 gconf2 gnomedocutils
GNU_CONFIGURE= yes
INSTALLS_OMF= yes
INSTALLS_ICONS= yes
-CONFIGURE_ARGS= --with-gecko=${GECKO}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
GCONF_SCHEMAS= seahorse.schemas
-MAN1= seahorse-agent.1 seahorse-daemon.1 seahorse-tool.1
+MAN1= seahorse-daemon.1
OPTIONS= LDAP "Enable LDAP support" on \
HKP "Enable HKP keyserver interface" on \
NOTIFY "Enable libnotify support" on \
- APPLET "Enable clipboard encryption applet" on \
- MDNS "Enable mDNS key sharing" on \
- GEDIT "Enable GEdit plug-in support" on \
- NAUTILUS "Enable the Nautilus component" on \
- EPIPHANY "Enable Epiphany plug-in support" on
+ MDNS "Enable mDNS key sharing" on
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_GEDIT)
-BUILD_DEPENDS+= gedit:${PORTSDIR}/editors/gedit
-RUN_DEPENDS+= gedit:${PORTSDIR}/editors/gedit
-PLIST_SUB+= GEDIT=""
-GCONF_SCHEMAS+= seahorse-gedit.schemas
-.else
-PLIST_SUB+= GEDIT="@comment "
-CONFIGURE_ARGS+=--disable-gedit
-.endif
-
-.if !defined(WITHOUT_NAUTILUS)
-USE_GNOME+= nautilus2
-PLIST_SUB+= NAUTILUS=""
-.else
-PLIST_SUB+= NAUTILUS="@comment "
-CONFIGURE_ARGS+=--disable-nautilus
-.endif
-
.if !defined(WITHOUT_LDAP)
USE_OPENLDAP= yes
.else
@@ -85,23 +61,6 @@ LIB_DEPENDS+= notify.1:${PORTSDIR}/devel/libnotify
CONFIGURE_ARGS+=--disable-libnotify
.endif
-.if !defined(WITHOUT_EPIPHANY)
-BUILD_DEPENDS+= epiphany:${PORTSDIR}/www/epiphany
-RUN_DEPENDS+= epiphany:${PORTSDIR}/www/epiphany
-PLIST_SUB+= EPHY="" EPHY_VERSION="2.22"
-.else
-CONFIGURE_ARGS+=--disable-epiphany
-PLIST_SUB+= EPHY="@comment "
-.endif
-
-.if !defined(WITHOUT_APPLET)
-USE_GNOME+= gnomepanel
-PLIST_SUB+= APPLET=""
-.else
-CONFIGURE_ARGS+=--disable-applet
-PLIST_SUB+= APPLET="@comment "
-.endif
-
.if !defined(WITHOUT_MDNS)
LIB_DEPENDS+= avahi-client:${PORTSDIR}/net/avahi-app
.else
@@ -112,8 +71,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|" == "|" = "|g' \
${WRKSRC}/configure
-post-install:
- -@update-desktop-database
-
-.include "${PORTSDIR}/www/mozilla/bsd.gecko.mk"
.include <bsd.port.post.mk>
diff --git a/security/seahorse/distinfo b/security/seahorse/distinfo
index 369eb9ddb871..0ca292a08fc0 100644
--- a/security/seahorse/distinfo
+++ b/security/seahorse/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/seahorse-2.22.3.tar.bz2) = 7fdab30dbf8684881199e15246c3765a
-SHA256 (gnome2/seahorse-2.22.3.tar.bz2) = 245ff3752f72d14615937ef03d5a5e6f1a3abdf12a907af775ce31aa337e95d1
-SIZE (gnome2/seahorse-2.22.3.tar.bz2) = 2121204
+MD5 (gnome2/seahorse-2.24.1.tar.bz2) = b35076c2ae46aa58d9b1ca76fe929515
+SHA256 (gnome2/seahorse-2.24.1.tar.bz2) = b86c045fe1d8cf7a3fd56e078175e32cd94154eb77f9fe2a4a4e1f1aa13a5d04
+SIZE (gnome2/seahorse-2.24.1.tar.bz2) = 2197087
diff --git a/security/seahorse/files/patch-agent_seahorse-agent-io.c b/security/seahorse/files/patch-agent_seahorse-agent-io.c
deleted file mode 100644
index 4ecd849405c7..000000000000
--- a/security/seahorse/files/patch-agent_seahorse-agent-io.c
+++ /dev/null
@@ -1,32 +0,0 @@
---- agent/seahorse-agent-io.c.orig Sun Aug 28 15:52:02 2005
-+++ agent/seahorse-agent-io.c Fri Oct 7 21:51:25 2005
-@@ -412,12 +412,18 @@ io_handler (GIOChannel *source, GIOCondi
- gsize length;
- GError *err = NULL;
- gboolean ret = TRUE;
-+ GIOStatus status;
-
- if (condition & G_IO_IN) {
- /* Read 1 line from the io channel, including newline character */
-- g_io_channel_read_line (source, &string, &length, NULL, &err);
-+ status = g_io_channel_read_line (source, &string, &length, NULL, &err);
-
-- if (err != NULL) {
-+ if (status == G_IO_STATUS_EOF) {
-+ free_conn (cn);
-+ ret = FALSE;
-+ }
-+
-+ else if (err != NULL) {
- g_critical ("couldn't read from socket: %s", err->message);
- g_clear_error (&err);
- free_conn (cn);
-@@ -434,7 +440,7 @@ io_handler (GIOChannel *source, GIOCondi
- g_free (string);
- }
-
-- if (cn && condition & G_IO_HUP) {
-+ else if (cn && condition & G_IO_HUP) {
- free_conn (cn);
- ret = FALSE; /* removes watch */
- }
diff --git a/security/seahorse/files/patch-common_seahorse-registry.c b/security/seahorse/files/patch-common_seahorse-registry.c
new file mode 100644
index 000000000000..a9b0cc424a6e
--- /dev/null
+++ b/security/seahorse/files/patch-common_seahorse-registry.c
@@ -0,0 +1,76 @@
+--- common/seahorse-registry.c.orig 2008-11-23 18:26:38.000000000 -0500
++++ common/seahorse-registry.c 2008-11-23 19:20:08.000000000 -0500
+@@ -49,6 +49,25 @@ cleanup_registry (void *unused)
+ registry_singleton = NULL;
+ }
+
++static guint registry_hash (gconstpointer key)
++{
++ SeahorseRegistryType *rtype;
++
++ rtype = (SeahorseRegistryType *) key;
++
++ return (guint) rtype->type;
++}
++
++static gboolean registry_equal (gconstpointer a, gconstpointer b)
++{
++ SeahorseRegistryType *rta, *rtb;
++
++ rta = (SeahorseRegistryType *) a;
++ rtb = (SeahorseRegistryType *) b;
++
++ return (rta->type == rtb->type);
++}
++
+ static void
+ keys_to_list (gpointer key, gpointer value, gpointer user_data)
+ {
+@@ -61,6 +80,7 @@ register_type_for_category (SeahorseRegi
+ {
+ SeahorseRegistryPrivate *pv = SEAHORSE_REGISTRY_GET_PRIVATE (registry);
+ GHashTable *set;
++ SeahorseRegistryType *rtype;
+
+ g_return_if_fail (SEAHORSE_IS_REGISTRY (registry));
+ g_return_if_fail (category);
+@@ -68,11 +88,14 @@ register_type_for_category (SeahorseRegi
+
+ set = g_hash_table_lookup (pv->categories, category);
+ if (!set) {
+- set = g_hash_table_new_full (g_direct_hash, g_direct_equal, NULL, NULL);
++ set = g_hash_table_new_full (registry_hash, registry_equal, (GDestroyNotify) g_free, NULL);
+ g_hash_table_replace (pv->categories, g_strdup (category), set);
+ }
++
++ rtype = g_new (SeahorseRegistryType, 1);
++ rtype->type = type;
+
+- g_hash_table_replace (set, GUINT_TO_POINTER (type), NO_VALUE);
++ g_hash_table_replace (set, rtype, NO_VALUE);
+ }
+
+ static GList*
+@@ -115,6 +138,7 @@ lookup_types (SeahorseRegistry *registry
+
+ /* Go through each item in list and make sure it exists in this cat */
+ for (l = types; l; l = l ? g_list_next (l) : types) {
++ SeahorseRegistryType *rtype;
+ type = l;
+ if (!g_hash_table_lookup (set, type->data)) {
+ l = g_list_previous (l);
+@@ -224,8 +248,12 @@ seahorse_registry_find_type (SeahorseReg
+ va_end (cats);
+
+ type = 0;
+- if (types)
+- type = GPOINTER_TO_UINT (types->data);
++ if (types) {
++ SeahorseRegistryType *rtype;
++
++ rtype = (SeahorseRegistryType *) types->data;
++ type = rtype->type;
++ }
+ g_list_free (types);
+ return type;
+ }
diff --git a/security/seahorse/files/patch-common_seahorse-registry.h b/security/seahorse/files/patch-common_seahorse-registry.h
new file mode 100644
index 000000000000..f1f57de3b042
--- /dev/null
+++ b/security/seahorse/files/patch-common_seahorse-registry.h
@@ -0,0 +1,21 @@
+--- common/seahorse-registry.h.orig 2008-11-23 18:26:42.000000000 -0500
++++ common/seahorse-registry.h 2008-11-23 18:26:47.000000000 -0500
+@@ -35,6 +35,7 @@ G_BEGIN_DECLS
+
+ typedef struct _SeahorseRegistry SeahorseRegistry;
+ typedef struct _SeahorseRegistryClass SeahorseRegistryClass;
++typedef struct _SeahorseRegistryType SeahorseRegistryType;
+
+ struct _SeahorseRegistry {
+ GObject parent;
+@@ -44,6 +45,10 @@ struct _SeahorseRegistryClass {
+ GObjectClass parent_class;
+ };
+
++struct _SeahorseRegistryType {
++ GType type;
++};
++
+ /* member functions */
+ GType seahorse_registry_get_type (void) G_GNUC_CONST;
+
diff --git a/security/seahorse/files/patch-libseahorse_seahorse-ssh-operation.c b/security/seahorse/files/patch-libseahorse_seahorse-ssh-operation.c
deleted file mode 100644
index e7a7e4f605a8..000000000000
--- a/security/seahorse/files/patch-libseahorse_seahorse-ssh-operation.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- libseahorse/seahorse-ssh-operation.c.orig Sun Dec 3 23:21:01 2006
-+++ libseahorse/seahorse-ssh-operation.c Sun Dec 3 23:21:10 2006
-@@ -24,6 +24,7 @@
- #include <sys/socket.h>
- #include <gnome.h>
- #include <fcntl.h>
-+#include <signal.h>
-
- #include "seahorse-ssh-operation.h"
- #include "seahorse-util.h"
diff --git a/security/seahorse/files/patch-src_seahorse-generate-select.c b/security/seahorse/files/patch-src_seahorse-generate-select.c
new file mode 100644
index 000000000000..7de1b7ff476d
--- /dev/null
+++ b/security/seahorse/files/patch-src_seahorse-generate-select.c
@@ -0,0 +1,14 @@
+--- src/seahorse-generate-select.c.orig 2008-11-23 18:28:34.000000000 -0500
++++ src/seahorse-generate-select.c 2008-11-23 18:29:30.000000000 -0500
+@@ -197,8 +197,10 @@ static GObject * seahorse_generate_selec
+ GList* typ_it;
+ typ_collection = types;
+ for (typ_it = typ_collection; typ_it != NULL; typ_it = typ_it->next) {
++ SeahorseRegistryType *rtype;
+ GType typ;
+- typ = GPOINTER_TO_INT (typ_it->data);
++ rtype = (SeahorseRegistryType *) typ_it->data;
++ typ = rtype->type;
+ {
+ SeahorseGenerator* generator;
+ gint _tmp5;
diff --git a/security/seahorse/files/patch-src_seahorse-viewer.c b/security/seahorse/files/patch-src_seahorse-viewer.c
new file mode 100644
index 000000000000..5acb2e00d676
--- /dev/null
+++ b/security/seahorse/files/patch-src_seahorse-viewer.c
@@ -0,0 +1,17 @@
+--- src/seahorse-viewer.c.orig 2008-11-23 18:27:49.000000000 -0500
++++ src/seahorse-viewer.c 2008-11-23 18:28:27.000000000 -0500
+@@ -556,10 +556,13 @@ seahorse_viewer_constructor (GType type,
+ /* Setup the commands */
+ types = seahorse_registry_find_types (seahorse_registry_get (), "commands", NULL, NULL);
+ for (l = types; l; l = g_list_next (l)) {
+- GType typ = GPOINTER_TO_INT (l->data);
++ SeahorseRegistryType *rtype = (SeahorseRegistryType *) l->data;
++ GType typ;
+ SeahorseCommands *commands;
+ GtkActionGroup *actions;
+ const gchar *uidef;
++
++ typ = rtype->type;
+
+ /* Add each commands to our hash table */
+ commands = g_object_new (typ, "view", self, NULL);
diff --git a/security/seahorse/files/patch-ssh_seahorse-ssh-operation.c b/security/seahorse/files/patch-ssh_seahorse-ssh-operation.c
new file mode 100644
index 000000000000..d3528e2a7a64
--- /dev/null
+++ b/security/seahorse/files/patch-ssh_seahorse-ssh-operation.c
@@ -0,0 +1,19 @@
+--- ssh/seahorse-ssh-operation.c.orig 2008-07-21 18:15:51.000000000 -0400
++++ ssh/seahorse-ssh-operation.c 2008-07-22 22:49:51.000000000 -0400
+@@ -280,11 +280,14 @@ askpass_handler (GIOChannel *source, GIO
+ const gchar *result = NULL;
+
+ if (condition & G_IO_IN) {
++ GIOStatus status;
+
+ /* Read 1 line from the io channel, including newline character */
+- g_io_channel_read_line (source, &string, &length, NULL, &err);
++ status = g_io_channel_read_line (source, &string, &length, NULL, &err);
+
+- if (err != NULL) {
++ if (status == G_IO_STATUS_EOF) {
++ ret = FALSE;
++ } else if (err != NULL) {
+ g_critical ("couldn't read from seahorse-ssh-askpass: %s", err->message);
+ g_clear_error (&err);
+ ret = FALSE;
diff --git a/security/seahorse/pkg-plist b/security/seahorse/pkg-plist
index 364434aee3a8..a94f07390a6f 100644
--- a/security/seahorse/pkg-plist
+++ b/security/seahorse/pkg-plist
@@ -1,50 +1,20 @@
bin/seahorse
-bin/seahorse-agent
bin/seahorse-daemon
-bin/seahorse-preferences
-bin/seahorse-tool
include/libcryptui/cryptui-key-chooser.h
include/libcryptui/cryptui-key-combo.h
include/libcryptui/cryptui-key-list.h
include/libcryptui/cryptui-key-store.h
include/libcryptui/cryptui-keyset.h
include/libcryptui/cryptui.h
-%%EPHY%%lib/epiphany/%%EPHY_VERSION%%/extensions/libseahorseextension.a
-%%EPHY%%lib/epiphany/%%EPHY_VERSION%%/extensions/libseahorseextension.la
-%%EPHY%%lib/epiphany/%%EPHY_VERSION%%/extensions/libseahorseextension.so
-%%EPHY%%lib/epiphany/%%EPHY_VERSION%%/extensions/seahorse.ephy-extension
-%%GEDIT%%lib/gedit-2/plugins/libseahorse-pgp.a
-%%GEDIT%%lib/gedit-2/plugins/libseahorse-pgp.la
-%%GEDIT%%lib/gedit-2/plugins/libseahorse-pgp.so
-%%GEDIT%%lib/gedit-2/plugins/seahorse-pgp.gedit-plugin
lib/libcryptui.a
lib/libcryptui.la
lib/libcryptui.so
lib/libcryptui.so.0
-%%NAUTILUS%%lib/nautilus/extensions-2.0/libnautilus-seahorse.a
-%%NAUTILUS%%lib/nautilus/extensions-2.0/libnautilus-seahorse.la
-%%NAUTILUS%%lib/nautilus/extensions-2.0/libnautilus-seahorse.so
-%%APPLET%%lib/seahorse/seahorse-applet
lib/seahorse/seahorse-ssh-askpass
lib/seahorse/xloadimage
-%%APPLET%%libdata/bonobo/servers/GNOME_SeahorseApplet.server
libdata/pkgconfig/cryptui-0.0.pc
-share/applications/seahorse-pgp-encrypted.desktop
-share/applications/seahorse-pgp-keys.desktop
-share/applications/seahorse-pgp-preferences.desktop
-share/applications/seahorse-pgp-signature.desktop
share/applications/seahorse.desktop
share/dbus-1/services/org.gnome.seahorse.service
-%%APPLET%%share/gnome-2.0/ui/GNOME_SeahorseApplet.xml
-%%APPLET%%share/gnome/help/seahorse-applet/C/legal.xml
-%%APPLET%%share/gnome/help/seahorse-applet/C/seahorse-applet.xml
-%%APPLET%%share/gnome/help/seahorse-applet/es/seahorse-applet.xml
-%%APPLET%%share/gnome/help/seahorse-applet/fr/seahorse-applet.xml
-%%APPLET%%share/gnome/help/seahorse-applet/it/seahorse-applet.xml
-%%APPLET%%share/gnome/help/seahorse-applet/oc/seahorse-applet.xml
-%%APPLET%%share/gnome/help/seahorse-applet/ru/seahorse-applet.xml
-%%APPLET%%share/gnome/help/seahorse-applet/sv/seahorse-applet.xml
-%%APPLET%%share/gnome/help/seahorse-applet/vi/seahorse-applet.xml
share/gnome/help/seahorse/C/figures/export.png
share/gnome/help/seahorse/C/figures/file-manager.png
share/gnome/help/seahorse/C/figures/generate.png
@@ -59,6 +29,19 @@ share/gnome/help/seahorse/C/figures/signature.png
share/gnome/help/seahorse/C/figures/text-editor.png
share/gnome/help/seahorse/C/legal.xml
share/gnome/help/seahorse/C/seahorse.xml
+share/gnome/help/seahorse/de/figures/export.png
+share/gnome/help/seahorse/de/figures/file-manager.png
+share/gnome/help/seahorse/de/figures/generate.png
+share/gnome/help/seahorse/de/figures/import.png
+share/gnome/help/seahorse/de/figures/key-manager.png
+share/gnome/help/seahorse/de/figures/key-properties.png
+share/gnome/help/seahorse/de/figures/passphrase.png
+share/gnome/help/seahorse/de/figures/preferences.png
+share/gnome/help/seahorse/de/figures/recipients.png
+share/gnome/help/seahorse/de/figures/seahorse-window.png
+share/gnome/help/seahorse/de/figures/signature.png
+share/gnome/help/seahorse/de/figures/text-editor.png
+share/gnome/help/seahorse/de/seahorse.xml
share/gnome/help/seahorse/en_GB/figures/export.png
share/gnome/help/seahorse/en_GB/figures/file-manager.png
share/gnome/help/seahorse/en_GB/figures/generate.png
@@ -163,14 +146,16 @@ share/gnome/help/seahorse/vi/figures/seahorse-window.png
share/gnome/help/seahorse/vi/figures/signature.png
share/gnome/help/seahorse/vi/figures/text-editor.png
share/gnome/help/seahorse/vi/seahorse.xml
-share/icons/hicolor/22x22/apps/seahorse-preferences.svg
-share/icons/hicolor/22x22/apps/seahorse.svg
-share/icons/hicolor/48x48/apps/seahorse-applet.png
+share/icons/hicolor/16x16/apps/seahorse-preferences.png
+share/icons/hicolor/16x16/apps/seahorse.png
+share/icons/hicolor/22x22/apps/seahorse-preferences.png
+share/icons/hicolor/22x22/apps/seahorse.png
+share/icons/hicolor/24x24/apps/seahorse-preferences.png
+share/icons/hicolor/24x24/apps/seahorse.png
+share/icons/hicolor/32x32/apps/seahorse-preferences.png
+share/icons/hicolor/32x32/apps/seahorse.png
share/icons/hicolor/48x48/apps/seahorse-preferences.png
share/icons/hicolor/48x48/apps/seahorse.png
-share/icons/hicolor/scalable/apps/seahorse-applet.svg
-share/icons/hicolor/scalable/apps/seahorse-preferences.svg
-share/icons/hicolor/scalable/apps/seahorse.svg
share/locale/ar/LC_MESSAGES/seahorse.mo
share/locale/az/LC_MESSAGES/seahorse.mo
share/locale/be@latin/LC_MESSAGES/seahorse.mo
@@ -224,7 +209,7 @@ share/locale/sk/LC_MESSAGES/seahorse.mo
share/locale/sl/LC_MESSAGES/seahorse.mo
share/locale/sq/LC_MESSAGES/seahorse.mo
share/locale/sr/LC_MESSAGES/seahorse.mo
-share/locale/sr@Latn/LC_MESSAGES/seahorse.mo
+share/locale/sr@latin/LC_MESSAGES/seahorse.mo
share/locale/sv/LC_MESSAGES/seahorse.mo
share/locale/ta/LC_MESSAGES/seahorse.mo
share/locale/te/LC_MESSAGES/seahorse.mo
@@ -235,16 +220,8 @@ share/locale/vi/LC_MESSAGES/seahorse.mo
share/locale/zh_CN/LC_MESSAGES/seahorse.mo
share/locale/zh_HK/LC_MESSAGES/seahorse.mo
share/locale/zh_TW/LC_MESSAGES/seahorse.mo
-share/mime/packages/seahorse.xml
-%%APPLET%%share/omf/seahorse-applet/seahorse-applet-C.omf
-%%APPLET%%share/omf/seahorse-applet/seahorse-applet-es.omf
-%%APPLET%%share/omf/seahorse-applet/seahorse-applet-fr.omf
-%%APPLET%%share/omf/seahorse-applet/seahorse-applet-it.omf
-%%APPLET%%share/omf/seahorse-applet/seahorse-applet-oc.omf
-%%APPLET%%share/omf/seahorse-applet/seahorse-applet-ru.omf
-%%APPLET%%share/omf/seahorse-applet/seahorse-applet-sv.omf
-%%APPLET%%share/omf/seahorse-applet/seahorse-applet-vi.omf
share/omf/seahorse/seahorse-C.omf
+share/omf/seahorse/seahorse-de.omf
share/omf/seahorse/seahorse-en_GB.omf
share/omf/seahorse/seahorse-es.omf
share/omf/seahorse/seahorse-fr.omf
@@ -253,64 +230,36 @@ share/omf/seahorse/seahorse-oc.omf
share/omf/seahorse/seahorse-ru.omf
share/omf/seahorse/seahorse-sv.omf
share/omf/seahorse/seahorse-vi.omf
-share/pixmaps/seahorse-applet.svg
-share/pixmaps/seahorse-preferences.png
-share/pixmaps/seahorse.png
-share/pixmaps/seahorse/22x22/seahorse-applet-encrypted.png
-share/pixmaps/seahorse/22x22/seahorse-applet-key.png
-share/pixmaps/seahorse/22x22/seahorse-applet-signed.png
-share/pixmaps/seahorse/22x22/seahorse-applet-text.png
-share/pixmaps/seahorse/22x22/seahorse-applet-unknown.png
share/pixmaps/seahorse/22x22/seahorse-key-personal.png
share/pixmaps/seahorse/22x22/seahorse-key-ssh.png
share/pixmaps/seahorse/22x22/seahorse-key.png
share/pixmaps/seahorse/22x22/seahorse-person.png
-share/pixmaps/seahorse/22x22/seahorse-preferences.png
share/pixmaps/seahorse/22x22/seahorse-share-keys.png
share/pixmaps/seahorse/22x22/seahorse-sign-bad.png
share/pixmaps/seahorse/22x22/seahorse-sign-ok.png
share/pixmaps/seahorse/22x22/seahorse-sign.png
-share/pixmaps/seahorse/22x22/seahorse.png
-share/pixmaps/seahorse/48x48/seahorse-applet-encrypted.png
-share/pixmaps/seahorse/48x48/seahorse-applet-key.png
-share/pixmaps/seahorse/48x48/seahorse-applet-signed.png
-share/pixmaps/seahorse/48x48/seahorse-applet-text.png
-share/pixmaps/seahorse/48x48/seahorse-applet-unknown.png
-share/pixmaps/seahorse/48x48/seahorse-applet.png
share/pixmaps/seahorse/48x48/seahorse-key-personal.png
share/pixmaps/seahorse/48x48/seahorse-key-ssh.png
share/pixmaps/seahorse/48x48/seahorse-key.png
share/pixmaps/seahorse/48x48/seahorse-person.png
-share/pixmaps/seahorse/48x48/seahorse-preferences.png
share/pixmaps/seahorse/48x48/seahorse-share-keys.png
share/pixmaps/seahorse/48x48/seahorse-sign-bad.png
share/pixmaps/seahorse/48x48/seahorse-sign-ok.png
share/pixmaps/seahorse/48x48/seahorse-sign-unknown.png
share/pixmaps/seahorse/48x48/seahorse-sign.png
-share/pixmaps/seahorse/48x48/seahorse.png
-share/pixmaps/seahorse/scalable/seahorse-applet-encrypted.svg
-share/pixmaps/seahorse/scalable/seahorse-applet-key.svg
-share/pixmaps/seahorse/scalable/seahorse-applet-signed.svg
-share/pixmaps/seahorse/scalable/seahorse-applet-text.svg
-share/pixmaps/seahorse/scalable/seahorse-applet-unknown.svg
-share/pixmaps/seahorse/scalable/seahorse-applet.svg
share/pixmaps/seahorse/scalable/seahorse-key-personal.svg
share/pixmaps/seahorse/scalable/seahorse-key-ssh.svg
share/pixmaps/seahorse/scalable/seahorse-key.svg
share/pixmaps/seahorse/scalable/seahorse-person.svg
-share/pixmaps/seahorse/scalable/seahorse-preferences.svg
share/pixmaps/seahorse/scalable/seahorse-share-keys.svg
share/pixmaps/seahorse/scalable/seahorse-sign-bad.svg
share/pixmaps/seahorse/scalable/seahorse-sign-ok.svg
share/pixmaps/seahorse/scalable/seahorse-sign-unknown.svg
share/pixmaps/seahorse/scalable/seahorse-sign.svg
-share/pixmaps/seahorse/scalable/seahorse.svg
%%DATADIR%%/glade/seahorse-add-keyring.glade
%%DATADIR%%/glade/seahorse-add-keyserver.glade
%%DATADIR%%/glade/seahorse-add-subkey.glade
%%DATADIR%%/glade/seahorse-add-uid.glade
-%%DATADIR%%/glade/seahorse-agent-cache.glade
-%%APPLET%%%%DATADIR%%/glade/seahorse-applet-preferences.glade
%%DATADIR%%/glade/seahorse-change-passphrase.glade
%%DATADIR%%/glade/seahorse-expires.glade
%%DATADIR%%/glade/seahorse-generate-select.glade
@@ -321,7 +270,6 @@ share/pixmaps/seahorse/scalable/seahorse.svg
%%DATADIR%%/glade/seahorse-keyserver-results.ui
%%DATADIR%%/glade/seahorse-keyserver-search.glade
%%DATADIR%%/glade/seahorse-keyserver-sync.glade
-%%DATADIR%%/glade/seahorse-multi-encrypt.glade
%%DATADIR%%/glade/seahorse-notify.glade
%%DATADIR%%/glade/seahorse-pgp-generate.glade
%%DATADIR%%/glade/seahorse-pgp-private-key-properties.glade
@@ -340,7 +288,6 @@ share/pixmaps/seahorse/scalable/seahorse.svg
@dirrm share/pixmaps/seahorse/48x48
@dirrm share/pixmaps/seahorse/22x22
@dirrm share/pixmaps/seahorse
-%%APPLET%%@dirrm share/omf/seahorse-applet
@dirrm share/omf/seahorse
@dirrm share/gnome/help/seahorse/vi/figures
@dirrm share/gnome/help/seahorse/vi
@@ -358,32 +305,20 @@ share/pixmaps/seahorse/scalable/seahorse.svg
@dirrm share/gnome/help/seahorse/es
@dirrm share/gnome/help/seahorse/en_GB/figures
@dirrm share/gnome/help/seahorse/en_GB
+@dirrm share/gnome/help/seahorse/de/figures
+@dirrm share/gnome/help/seahorse/de
@dirrm share/gnome/help/seahorse/C/figures
@dirrm share/gnome/help/seahorse/C
-%%APPLET%%@dirrm share/gnome/help/seahorse-applet/vi
-%%APPLET%%@dirrm share/gnome/help/seahorse-applet/sv
-%%APPLET%%@dirrm share/gnome/help/seahorse-applet/ru
-%%APPLET%%@dirrm share/gnome/help/seahorse-applet/oc
-%%APPLET%%@dirrm share/gnome/help/seahorse-applet/it
-%%APPLET%%@dirrm share/gnome/help/seahorse-applet/fr
-%%APPLET%%@dirrm share/gnome/help/seahorse-applet/es
-%%APPLET%%@dirrm share/gnome/help/seahorse-applet/C
-%%APPLET%%@dirrm share/gnome/help/seahorse-applet
@dirrm share/gnome/help/seahorse
+@dirrmtry share/applications
@dirrm lib/seahorse
-%%EPHY%%@dirrmtry lib/epiphany/%%EPHY_VERSION%%/extensions
-%%EPHY%%@dirrmtry lib/epiphany/%%EPHY_VERSION%%
-%%EPHY%%@dirrmtry lib/epiphany
@dirrm include/libcryptui
-@exec %%LOCALBASE%%/bin/update-mime-database %D/share/mime
-@unexec %%LOCALBASE%%/bin/update-mime-database %D/share/mime
-@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
-@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
-@dirrmtry share/applications
@dirrmtry share/locale/zh_HK/LC_MESSAGES
@dirrmtry share/locale/zh_HK
@dirrmtry share/locale/te/LC_MESSAGES
@dirrmtry share/locale/te
+@dirrmtry share/locale/sr@latin/LC_MESSAGES
+@dirrmtry share/locale/sr@latin
@dirrmtry share/locale/si/LC_MESSAGES
@dirrmtry share/locale/si
@dirrmtry share/locale/rw/LC_MESSAGES