aboutsummaryrefslogtreecommitdiffstats
path: root/security/seahorse
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2007-03-19 13:14:07 +0800
committermarcus <marcus@FreeBSD.org>2007-03-19 13:14:07 +0800
commite83248f2b323aa90dfea75471b86ccc444a80f88 (patch)
treef4fc2dbabf96cb67c502479d9fc13f40bf0d0108 /security/seahorse
parent52dd0c5de1d6a7165dc355ecf161f52bb7dbbfda (diff)
downloadfreebsd-ports-gnome-e83248f2b323aa90dfea75471b86ccc444a80f88.tar.gz
freebsd-ports-gnome-e83248f2b323aa90dfea75471b86ccc444a80f88.tar.zst
freebsd-ports-gnome-e83248f2b323aa90dfea75471b86ccc444a80f88.zip
Presenting GNOME 2.18 for FreeBSD. GNOME 2.18 is a departure from recent GNOME
releases in that it focuses more on stability and functionality than on new features. Not that it doesn't have its share of new and exciting items. See http://www.gnome.org/start/2.18/ for all the goodies in this release. GNOME 2.18 for FreeBSD would not have been possible without the hard work of the FreeBSD GNOME Team and our intrepid band of testers including J. W. Ballantine, Pawel Worach, Yasuda Keisuke, Pascal Hofstee, miwi, Yoshihiro Ota, Vladimir Grebenschikov, Jukka A. Ukkonen, Phillip Neumann, Franz Klammer, and Neal Delmonico.
Diffstat (limited to 'security/seahorse')
-rw-r--r--security/seahorse/Makefile69
-rw-r--r--security/seahorse/distinfo6
-rw-r--r--security/seahorse/files/patch-agent_seahorse-agent.c40
-rw-r--r--security/seahorse/files/patch-configure20
-rw-r--r--security/seahorse/files/patch-libseahorse_seahorse-key-store.c22
-rw-r--r--security/seahorse/files/patch-libseahorse_seahorse-server-source.c15
-rw-r--r--security/seahorse/files/patch-libseahorse_seahorse-ssh-operation.c10
-rw-r--r--security/seahorse/files/patch-src_seahorse-generate-druid.c13
-rw-r--r--security/seahorse/pkg-plist231
9 files changed, 304 insertions, 122 deletions
diff --git a/security/seahorse/Makefile b/security/seahorse/Makefile
index bf1c9556bb8e..31459f36b752 100644
--- a/security/seahorse/Makefile
+++ b/security/seahorse/Makefile
@@ -3,47 +3,56 @@
# Whom: Dave McKay <dave@mu.org>
#
# $FreeBSD$
-# $MCom: ports/security/seahorse/Makefile,v 1.18 2006/10/01 01:56:57 ahze Exp $
+# $MCom: ports/security/seahorse/Makefile,v 1.31 2007/03/15 16:34:55 marcus Exp $
#
PORTNAME= seahorse
-PORTVERSION= 0.8.2
-PORTREVISION= 3
-CATEGORIES= security
+PORTVERSION= 1.0
+PORTREVISION= 1
+CATEGORIES= security gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR=sources/${PORTNAME}/0.8
+MASTER_SITE_SUBDIR=sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= A front end for GnuPG
BUILD_DEPENDS= gpgv:${PORTSDIR}/security/gnupg1
-RUN_DEPENDS= ${BUILD_DEPENDS}
-LIB_DEPENDS= gpgme.17:${PORTSDIR}/security/gpgme
+RUN_DEPENDS= gpgv:${PORTSDIR}/security/gnupg1
+LIB_DEPENDS= gpgme.17:${PORTSDIR}/security/gpgme \
+ dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
USE_LDCONFIG= yes
USE_BZIP2= yes
USE_GETTEXT= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
+USE_GECKO= firefox xulrunner firefox-devel<->firefox
USE_GNOME= gnomehack intlhack gnomeprefix libgnomeui
GNU_CONFIGURE= yes
INSTALLS_OMF= yes
-CONFIGURE_ARGS= --disable-gpg-check
+INSTALLS_ICONS= yes
+CONFIGURE_ARGS= --with-gecko=${GECKO}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
GCONF_SCHEMAS= seahorse.schemas
+MAN1= seahorse-agent.1 seahorse-daemon.1 seahorse-tool.1
OPTIONS= NAUTILUS "Enable the Nautilus component" on \
LDAP "Enable LDAP support" on \
- HKP "Enable HKP keyserver interface" on
-# GEDIT "Enable GEdit plug-in support" on
+ HKP "Enable HKP keyserver interface" on \
+ GEDIT "Enable GEdit plug-in support" on \
+ NOTIFY "Enable libnotify support" on \
+ APPLET "Enable clipboard encryption applet" on \
+ KEYRING "Enable GNOME Keyring support" on \
+ MDNS "Enable mDNS key sharing" on
+# EPIPHANY "Enable Epiphany plug-in support" on
+## BROKEN
+WITHOUT_EPIPHANY= yes
.include <bsd.port.pre.mk>
-# Gedit not working right now..
-WITHOUT_GEDIT= yes
.if !defined(WITHOUT_GEDIT)
BUILD_DEPENDS+= gedit:${PORTSDIR}/editors/gedit
RUN_DEPENDS+= gedit:${PORTSDIR}/editors/gedit
@@ -74,7 +83,43 @@ LIB_DEPENDS+= soup-2.2.8:${PORTSDIR}/devel/libsoup
CONFIGURE_ARGS+=--disable-hkp
.endif
+.if !defined(WITHOUT_NOTIFY)
+LIB_DEPENDS+= notify.1:${PORTSDIR}/devel/libnotify
+.else
+CONFIGURE_ARGS+=--disable-libnotify
+.endif
+
+.if !defined(WITHOUT_EPIPHANY)
+BUILD_DEPENDS+= epiphany:${PORTSDIR}/www/epiphany
+RUN_DEPENDS+= epiphany:${PORTSDIR}/www/epiphany
+PLIST_SUB+= EPHY="" EPHY_VERSION="2.18"
+.else
+CONFIGURE_ARGS+=--disable-epiphany
+PLIST_SUB+= EPHY="@comment "
+.endif
+
+.if !defined(WITHOUT_APPLET)
+USE_GNOME+= gnomepanel
+PLIST_SUB+= APPLET=""
+.else
+CONFIGURE_ARGS+=--disable-applet
+PLIST_SUB+= APPLET="@comment "
+.endif
+
+.if !defined(WITHOUT_KEYRING)
+LIB_DEPENDS+= gnome-keyring:${PORTSDIR}/security/gnome-keyring
+.else
+CONFIGURE_ARGS+=--disable-gnome-keyring
+.endif
+
+.if !defined(WITHOUT_MDNS)
+LIB_DEPENDS+= avahi-client:${PORTSDIR}/net/avahi
+.else
+CONFIGURE_ARGS+=--disable-sharing
+.endif
+
post-install:
-@update-desktop-database
+.include "${PORTSDIR}/www/mozilla/bsd.gecko.mk"
.include <bsd.port.post.mk>
diff --git a/security/seahorse/distinfo b/security/seahorse/distinfo
index 13f59f87cacd..47541d93e334 100644
--- a/security/seahorse/distinfo
+++ b/security/seahorse/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/seahorse-0.8.2.tar.bz2) = 24d9a8c3564700d105847934020920bd
-SHA256 (gnome2/seahorse-0.8.2.tar.bz2) = 350f1a1cc5010bb81f08c6c124a24f2560a9dffea16c8a5a62e9cdeebb03c68e
-SIZE (gnome2/seahorse-0.8.2.tar.bz2) = 990284
+MD5 (gnome2/seahorse-1.0.tar.bz2) = 7afcb9b40aaa0c232ce8a9e0909fe757
+SHA256 (gnome2/seahorse-1.0.tar.bz2) = 76bcfeed3843b2357f5ecc1694a471fc45a810aa17fd0baed60f1d32142d0746
+SIZE (gnome2/seahorse-1.0.tar.bz2) = 1871080
diff --git a/security/seahorse/files/patch-agent_seahorse-agent.c b/security/seahorse/files/patch-agent_seahorse-agent.c
deleted file mode 100644
index 8ee1d8349d6b..000000000000
--- a/security/seahorse/files/patch-agent_seahorse-agent.c
+++ /dev/null
@@ -1,40 +0,0 @@
---- agent/seahorse-agent.c.orig Sun Aug 13 14:50:35 2006
-+++ agent/seahorse-agent.c Wed Aug 16 02:08:05 2006
-@@ -280,7 +280,6 @@ main (int argc, char **argv)
- GnomeProgram *program = NULL;
- GnomeClient *client = NULL;
-
-- secmem_init (65536);
-
- /* We need to drop privileges completely for security */
- #if defined(HAVE_SETRESUID) && defined(HAVE_SETRESGID)
-@@ -288,10 +287,12 @@ main (int argc, char **argv)
- /* Not in header files for all OSs, even where present */
- int setresuid(uid_t ruid, uid_t euid, uid_t suid);
- int setresgid(gid_t rgid, gid_t egid, gid_t sgid);
-+ secmem_init (65536);
-
- if (setresuid (getuid (), getuid (), getuid ()) == -1 ||
- setresgid (getgid (), getgid (), getgid ()) == -1)
- #else
-+ secmem_init (65536);
- if (setuid (getuid ()) == -1 || setgid (getgid ()) == -1)
- #endif
- err (1, _("couldn't drop privileges properly"));
-@@ -313,7 +314,6 @@ main (int argc, char **argv)
- * All functions after this point have to print messages
- * nicely and not just called exit()
- */
-- daemonize (sockname);
-
- /* Handle some signals */
- signal (SIGINT, on_quit);
-@@ -329,6 +329,8 @@ main (int argc, char **argv)
- /* Initialize our sub systems */
- seahorse_agent_actions_init ();
- seahorse_agent_cache_init ();
-+
-+ daemonize (sockname);
-
- if (seahorse_agent_io_init () == -1)
- return 1; /* message already printed */
diff --git a/security/seahorse/files/patch-configure b/security/seahorse/files/patch-configure
new file mode 100644
index 000000000000..b77fe2ddda83
--- /dev/null
+++ b/security/seahorse/files/patch-configure
@@ -0,0 +1,20 @@
+--- configure.orig Sun Dec 3 23:18:17 2006
++++ configure Sun Dec 3 23:18:57 2006
+@@ -30954,7 +30954,7 @@ fi
+
+
+
+-if test "$enable_ssh" == "yes"; then
++if test "$enable_ssh" = "yes"; then
+ WITH_SSH_TRUE=
+ WITH_SSH_FALSE='#'
+ else
+@@ -31014,7 +31014,7 @@ fi
+
+
+
+-if test "$enable_tests" == "yes"; then
++if test "$enable_tests" = "yes"; then
+ WITH_TESTS_TRUE=
+ WITH_TESTS_FALSE='#'
+ else
diff --git a/security/seahorse/files/patch-libseahorse_seahorse-key-store.c b/security/seahorse/files/patch-libseahorse_seahorse-key-store.c
deleted file mode 100644
index fc8b7af60033..000000000000
--- a/security/seahorse/files/patch-libseahorse_seahorse-key-store.c
+++ /dev/null
@@ -1,22 +0,0 @@
---- libseahorse/seahorse-key-store.c.orig Wed Dec 22 15:18:27 2004
-+++ libseahorse/seahorse-key-store.c Wed Dec 22 15:19:48 2004
-@@ -184,6 +184,8 @@
- {
- GObject* obj = G_OBJECT_CLASS (parent_class)->constructor (type, n_props, props);
- SeahorseKeyStore* skstore = SEAHORSE_KEY_STORE (obj);
-+ guint cols;
-+ GType* types;
-
- /* init private vars */
- skstore->priv = g_new0 (SeahorseKeyStorePriv, 1);
-@@ -191,8 +193,8 @@
- NULL, (GDestroyNotify)seahorse_key_row_free);
-
- /* Setup the store */
-- guint cols = SEAHORSE_KEY_STORE_GET_CLASS (skstore)->n_columns;
-- GType* types = (GType*)SEAHORSE_KEY_STORE_GET_CLASS (skstore)->col_types;
-+ cols = SEAHORSE_KEY_STORE_GET_CLASS (skstore)->n_columns;
-+ types = (GType*)SEAHORSE_KEY_STORE_GET_CLASS (skstore)->col_types;
- gtk_tree_store_set_column_types (GTK_TREE_STORE (obj), cols, types);
-
- /* Setup the sort and filter */
diff --git a/security/seahorse/files/patch-libseahorse_seahorse-server-source.c b/security/seahorse/files/patch-libseahorse_seahorse-server-source.c
deleted file mode 100644
index d7422de5ea50..000000000000
--- a/security/seahorse/files/patch-libseahorse_seahorse-server-source.c
+++ /dev/null
@@ -1,15 +0,0 @@
---- libseahorse/seahorse-server-source.c.orig Fri Mar 11 22:17:43 2005
-+++ libseahorse/seahorse-server-source.c Fri Mar 11 22:17:55 2005
-@@ -518,11 +518,11 @@
- seahorse_server_source_get_state (SeahorseKeySource *src)
- {
- SeahorseServerSource *ssrc;
-+ guint state = SEAHORSE_KEY_SOURCE_REMOTE;
-
- g_return_val_if_fail (SEAHORSE_IS_SERVER_SOURCE (src), 0);
- ssrc = SEAHORSE_SERVER_SOURCE (src);
-
-- guint state = SEAHORSE_KEY_SOURCE_REMOTE;
- if (!seahorse_operation_is_done (ssrc->priv->operation))
- state |= SEAHORSE_KEY_SOURCE_LOADING;
- return state;
diff --git a/security/seahorse/files/patch-libseahorse_seahorse-ssh-operation.c b/security/seahorse/files/patch-libseahorse_seahorse-ssh-operation.c
new file mode 100644
index 000000000000..e7a7e4f605a8
--- /dev/null
+++ b/security/seahorse/files/patch-libseahorse_seahorse-ssh-operation.c
@@ -0,0 +1,10 @@
+--- libseahorse/seahorse-ssh-operation.c.orig Sun Dec 3 23:21:01 2006
++++ libseahorse/seahorse-ssh-operation.c Sun Dec 3 23:21:10 2006
+@@ -24,6 +24,7 @@
+ #include <sys/socket.h>
+ #include <gnome.h>
+ #include <fcntl.h>
++#include <signal.h>
+
+ #include "seahorse-ssh-operation.h"
+ #include "seahorse-util.h"
diff --git a/security/seahorse/files/patch-src_seahorse-generate-druid.c b/security/seahorse/files/patch-src_seahorse-generate-druid.c
deleted file mode 100644
index 9e356ed1aac0..000000000000
--- a/security/seahorse/files/patch-src_seahorse-generate-druid.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/seahorse-generate-druid.c.orig Wed Dec 22 15:22:02 2004
-+++ src/seahorse-generate-druid.c Wed Dec 22 15:22:22 2004
-@@ -173,8 +173,9 @@
- gboolean
- on_druidpagestandard4_next (GnomeDruidPage *gnomedruidpage, GtkWidget *widget, SeahorseWidget *swidget)
- {
-+ GtkWidget *druidpage;
- g_print("go to finish\n");
-- GtkWidget *druidpage = glade_xml_get_widget (swidget->xml, "druidpagefinish1");
-+ druidpage = glade_xml_get_widget (swidget->xml, "druidpagefinish1");
-
- gnome_druid_page_prepare (GNOME_DRUID_PAGE(druidpage));
- gtk_widget_show (druidpage);
diff --git a/security/seahorse/pkg-plist b/security/seahorse/pkg-plist
index 363cf20d0408..46a2d2432ddc 100644
--- a/security/seahorse/pkg-plist
+++ b/security/seahorse/pkg-plist
@@ -1,24 +1,45 @@
bin/seahorse
bin/seahorse-agent
-bin/seahorse-pgp-preferences
+bin/seahorse-daemon
+bin/seahorse-preferences
+bin/seahorse-tool
+include/libcryptui/cryptui-key-chooser.h
+include/libcryptui/cryptui-key-combo.h
+include/libcryptui/cryptui-key-list.h
+include/libcryptui/cryptui-key-store.h
+include/libcryptui/cryptui-keyset.h
+include/libcryptui/cryptui.h
+%%EPHY%%lib/epiphany/%%EPHY_VERSION%%/extensions/libseahorseextension.a
+%%EPHY%%lib/epiphany/%%EPHY_VERSION%%/extensions/libseahorseextension.la
+%%EPHY%%lib/epiphany/%%EPHY_VERSION%%/extensions/libseahorseextension.so
+%%EPHY%%lib/epiphany/%%EPHY_VERSION%%/extensions/seahorse.ephy-extension
%%GEDIT%%lib/gedit-2/plugins/libseahorse-pgp.a
%%GEDIT%%lib/gedit-2/plugins/libseahorse-pgp.la
%%GEDIT%%lib/gedit-2/plugins/libseahorse-pgp.so
%%GEDIT%%lib/gedit-2/plugins/seahorse-pgp.gedit-plugin
-lib/libseahorse-internal.a
-lib/libseahorse-internal.la
-lib/libseahorse-internal.so
-lib/libseahorse-internal.so.0
+lib/libcryptui.a
+lib/libcryptui.la
+lib/libcryptui.so
+lib/libcryptui.so.0
%%NAUTILUS%%lib/nautilus/extensions-1.0/libnautilus-seahorse.a
%%NAUTILUS%%lib/nautilus/extensions-1.0/libnautilus-seahorse.la
%%NAUTILUS%%lib/nautilus/extensions-1.0/libnautilus-seahorse.so
+%%APPLET%%lib/seahorse/seahorse-applet
+lib/seahorse/seahorse-ssh-askpass
+lib/seahorse/xloadimage
+%%APPLET%%libdata/bonobo/servers/GNOME_SeahorseApplet.server
+libdata/pkgconfig/cryptui-0.0.pc
+share/dbus-1/services/org.gnome.seahorse.service
share/gnome/applications/seahorse-pgp-preferences.desktop
share/gnome/applications/seahorse.desktop
share/gnome/applications/seahorse-pgp-encrypted.desktop
share/gnome/applications/seahorse-pgp-keys.desktop
share/gnome/applications/seahorse-pgp-signature.desktop
share/gnome/control-center-2.0/capplets/seahorse-pgp-preferences.desktop
+%%APPLET%%share/gnome/gnome-2.0/ui/GNOME_SeahorseApplet.xml
@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+%%APPLET%%share/gnome/help/seahorse-applet/C/legal.xml
+%%APPLET%%share/gnome/help/seahorse-applet/C/seahorse-applet.xml
share/gnome/help/seahorse/C/figures/export.png
share/gnome/help/seahorse/C/figures/file-manager.png
share/gnome/help/seahorse/C/figures/generate.png
@@ -28,59 +49,197 @@ share/gnome/help/seahorse/C/figures/key-properties.png
share/gnome/help/seahorse/C/figures/passphrase.png
share/gnome/help/seahorse/C/figures/preferences.png
share/gnome/help/seahorse/C/figures/recipients.png
+share/gnome/help/seahorse/C/figures/seahorse-window.png
share/gnome/help/seahorse/C/figures/signature.png
share/gnome/help/seahorse/C/figures/text-editor.png
share/gnome/help/seahorse/C/legal.xml
share/gnome/help/seahorse/C/seahorse.xml
-share/gnome/mime-info/seahorse.keys
-share/gnome/mime-info/seahorse.mime
+share/gnome/help/seahorse/en_GB/figures/export.png
+share/gnome/help/seahorse/en_GB/figures/file-manager.png
+share/gnome/help/seahorse/en_GB/figures/generate.png
+share/gnome/help/seahorse/en_GB/figures/import.png
+share/gnome/help/seahorse/en_GB/figures/key-manager.png
+share/gnome/help/seahorse/en_GB/figures/key-properties.png
+share/gnome/help/seahorse/en_GB/figures/passphrase.png
+share/gnome/help/seahorse/en_GB/figures/preferences.png
+share/gnome/help/seahorse/en_GB/figures/recipients.png
+share/gnome/help/seahorse/en_GB/figures/seahorse-window.png
+share/gnome/help/seahorse/en_GB/figures/signature.png
+share/gnome/help/seahorse/en_GB/figures/text-editor.png
+share/gnome/help/seahorse/en_GB/seahorse.xml
+share/gnome/help/seahorse/es/figures/export.png
+share/gnome/help/seahorse/es/figures/file-manager.png
+share/gnome/help/seahorse/es/figures/generate.png
+share/gnome/help/seahorse/es/figures/import.png
+share/gnome/help/seahorse/es/figures/key-manager.png
+share/gnome/help/seahorse/es/figures/key-properties.png
+share/gnome/help/seahorse/es/figures/passphrase.png
+share/gnome/help/seahorse/es/figures/preferences.png
+share/gnome/help/seahorse/es/figures/recipients.png
+share/gnome/help/seahorse/es/figures/seahorse-window.png
+share/gnome/help/seahorse/es/figures/signature.png
+share/gnome/help/seahorse/es/figures/text-editor.png
+share/gnome/help/seahorse/es/seahorse.xml
+share/gnome/help/seahorse/fr/figures/export.png
+share/gnome/help/seahorse/fr/figures/file-manager.png
+share/gnome/help/seahorse/fr/figures/generate.png
+share/gnome/help/seahorse/fr/figures/import.png
+share/gnome/help/seahorse/fr/figures/key-manager.png
+share/gnome/help/seahorse/fr/figures/key-properties.png
+share/gnome/help/seahorse/fr/figures/passphrase.png
+share/gnome/help/seahorse/fr/figures/preferences.png
+share/gnome/help/seahorse/fr/figures/recipients.png
+share/gnome/help/seahorse/fr/figures/seahorse-window.png
+share/gnome/help/seahorse/fr/figures/signature.png
+share/gnome/help/seahorse/fr/figures/text-editor.png
+share/gnome/help/seahorse/fr/seahorse.xml
+share/gnome/help/seahorse/it/figures/export.png
+share/gnome/help/seahorse/it/figures/file-manager.png
+share/gnome/help/seahorse/it/figures/generate.png
+share/gnome/help/seahorse/it/figures/import.png
+share/gnome/help/seahorse/it/figures/key-manager.png
+share/gnome/help/seahorse/it/figures/key-properties.png
+share/gnome/help/seahorse/it/figures/passphrase.png
+share/gnome/help/seahorse/it/figures/preferences.png
+share/gnome/help/seahorse/it/figures/recipients.png
+share/gnome/help/seahorse/it/figures/seahorse-window.png
+share/gnome/help/seahorse/it/figures/signature.png
+share/gnome/help/seahorse/it/figures/text-editor.png
+share/gnome/help/seahorse/it/seahorse.xml
+share/gnome/help/seahorse/sv/figures/export.png
+share/gnome/help/seahorse/sv/figures/file-manager.png
+share/gnome/help/seahorse/sv/figures/generate.png
+share/gnome/help/seahorse/sv/figures/import.png
+share/gnome/help/seahorse/sv/figures/key-manager.png
+share/gnome/help/seahorse/sv/figures/key-properties.png
+share/gnome/help/seahorse/sv/figures/passphrase.png
+share/gnome/help/seahorse/sv/figures/preferences.png
+share/gnome/help/seahorse/sv/figures/recipients.png
+share/gnome/help/seahorse/sv/figures/seahorse-window.png
+share/gnome/help/seahorse/sv/figures/signature.png
+share/gnome/help/seahorse/sv/figures/text-editor.png
+share/gnome/help/seahorse/sv/seahorse.xml
+%%APPLET%%share/gnome/omf/seahorse-applet/seahorse-applet-C.omf
share/gnome/omf/seahorse/seahorse-C.omf
-share/gnome/pixmaps/seahorse-key.png
-share/gnome/pixmaps/seahorse-secret.png
+share/gnome/omf/seahorse/seahorse-en_GB.omf
+share/gnome/omf/seahorse/seahorse-es.omf
+share/gnome/omf/seahorse/seahorse-fr.omf
+share/gnome/omf/seahorse/seahorse-it.omf
+share/gnome/omf/seahorse/seahorse-sv.omf
+share/gnome/pixmaps/seahorse-applet.svg
+share/gnome/pixmaps/seahorse-preferences.png
share/gnome/pixmaps/seahorse.png
+share/gnome/pixmaps/seahorse/22x22/seahorse-applet-encrypted.png
+share/gnome/pixmaps/seahorse/22x22/seahorse-applet-key.png
+share/gnome/pixmaps/seahorse/22x22/seahorse-applet-signed.png
+share/gnome/pixmaps/seahorse/22x22/seahorse-applet-text.png
+share/gnome/pixmaps/seahorse/22x22/seahorse-applet-unknown.png
+share/gnome/pixmaps/seahorse/22x22/seahorse-key-personal.png
+share/gnome/pixmaps/seahorse/22x22/seahorse-key-ssh.png
+share/gnome/pixmaps/seahorse/22x22/seahorse-key.png
+share/gnome/pixmaps/seahorse/22x22/seahorse-preferences.png
+share/gnome/pixmaps/seahorse/22x22/seahorse-share-keys.png
+share/gnome/pixmaps/seahorse/22x22/seahorse-sign-bad.png
+share/gnome/pixmaps/seahorse/22x22/seahorse-sign-ok.png
+share/gnome/pixmaps/seahorse/22x22/seahorse.png
+share/gnome/pixmaps/seahorse/48x48/seahorse-applet-encrypted.png
+share/gnome/pixmaps/seahorse/48x48/seahorse-applet-key.png
+share/gnome/pixmaps/seahorse/48x48/seahorse-applet-signed.png
+share/gnome/pixmaps/seahorse/48x48/seahorse-applet-text.png
+share/gnome/pixmaps/seahorse/48x48/seahorse-applet-unknown.png
+share/gnome/pixmaps/seahorse/48x48/seahorse-applet.png
+share/gnome/pixmaps/seahorse/48x48/seahorse-key-personal.png
+share/gnome/pixmaps/seahorse/48x48/seahorse-key-ssh.png
+share/gnome/pixmaps/seahorse/48x48/seahorse-key.png
+share/gnome/pixmaps/seahorse/48x48/seahorse-person.png
+share/gnome/pixmaps/seahorse/48x48/seahorse-preferences.png
+share/gnome/pixmaps/seahorse/48x48/seahorse-share-keys.png
+share/gnome/pixmaps/seahorse/48x48/seahorse-sign-bad.png
+share/gnome/pixmaps/seahorse/48x48/seahorse-sign-ok.png
+share/gnome/pixmaps/seahorse/48x48/seahorse-sign-unknown.png
+share/gnome/pixmaps/seahorse/48x48/seahorse-sign.png
+share/gnome/pixmaps/seahorse/48x48/seahorse.png
+share/gnome/pixmaps/seahorse/scalable/seahorse-applet-encrypted.svg
+share/gnome/pixmaps/seahorse/scalable/seahorse-applet-key.svg
+share/gnome/pixmaps/seahorse/scalable/seahorse-applet-signed.svg
+share/gnome/pixmaps/seahorse/scalable/seahorse-applet-text.svg
+share/gnome/pixmaps/seahorse/scalable/seahorse-applet-unknown.svg
+share/gnome/pixmaps/seahorse/scalable/seahorse-applet.svg
+share/gnome/pixmaps/seahorse/scalable/seahorse-key-personal.svg
+share/gnome/pixmaps/seahorse/scalable/seahorse-key-ssh.svg
+share/gnome/pixmaps/seahorse/scalable/seahorse-key.svg
+share/gnome/pixmaps/seahorse/scalable/seahorse-person.svg
+share/gnome/pixmaps/seahorse/scalable/seahorse-preferences.svg
+share/gnome/pixmaps/seahorse/scalable/seahorse-share-keys.svg
+share/gnome/pixmaps/seahorse/scalable/seahorse-sign-bad.svg
+share/gnome/pixmaps/seahorse/scalable/seahorse-sign-ok.svg
+share/gnome/pixmaps/seahorse/scalable/seahorse-sign-unknown.svg
+share/gnome/pixmaps/seahorse/scalable/seahorse-sign.svg
+share/gnome/pixmaps/seahorse/scalable/seahorse.svg
share/gnome/seahorse/glade/seahorse-add-keyserver.glade
share/gnome/seahorse/glade/seahorse-add-subkey.glade
share/gnome/seahorse/glade/seahorse-add-uid.glade
share/gnome/seahorse/glade/seahorse-agent-cache.glade
+%%APPLET%%share/gnome/seahorse/glade/seahorse-applet-preferences.glade
share/gnome/seahorse/glade/seahorse-change-passphrase.glade
share/gnome/seahorse/glade/seahorse-expires.glade
-share/gnome/seahorse/glade/seahorse-generate-adv.glade
-share/gnome/seahorse/glade/seahorse-generate-druid.glade
share/gnome/seahorse/glade/seahorse-generate-select.glade
+share/gnome/seahorse/glade/seahorse-gkeyring-item-properties.glade
share/gnome/seahorse/glade/seahorse-key-manager.glade
share/gnome/seahorse/glade/seahorse-key-manager.ui
-share/gnome/seahorse/glade/seahorse-key-properties.glade
share/gnome/seahorse/glade/seahorse-keyserver-results.glade
share/gnome/seahorse/glade/seahorse-keyserver-results.ui
share/gnome/seahorse/glade/seahorse-keyserver-search.glade
share/gnome/seahorse/glade/seahorse-keyserver-sync.glade
share/gnome/seahorse/glade/seahorse-multi-encrypt.glade
-share/gnome/seahorse/glade/seahorse-passphrase.glade
+share/gnome/seahorse/glade/seahorse-notify.glade
+share/gnome/seahorse/glade/seahorse-pgp-generate.glade
+share/gnome/seahorse/glade/seahorse-pgp-private-key-properties.glade
+share/gnome/seahorse/glade/seahorse-pgp-public-key-properties.glade
share/gnome/seahorse/glade/seahorse-prefs.glade
-share/gnome/seahorse/glade/seahorse-preferences.glade
share/gnome/seahorse/glade/seahorse-progress.glade
-share/gnome/seahorse/glade/seahorse-recipients.glade
share/gnome/seahorse/glade/seahorse-revoke.glade
share/gnome/seahorse/glade/seahorse-sign.glade
-share/gnome/seahorse/glade/seahorse-signatures.glade
share/gnome/seahorse/glade/seahorse-signer.glade
+share/gnome/seahorse/glade/seahorse-ssh-generate.glade
+share/gnome/seahorse/glade/seahorse-ssh-key-properties.glade
+share/gnome/seahorse/glade/seahorse-ssh-upload.glade
+share/icons/hicolor/22x22/apps/seahorse-preferences.svg
+share/icons/hicolor/22x22/apps/seahorse.svg
+share/icons/hicolor/48x48/apps/seahorse-applet.png
+share/icons/hicolor/48x48/apps/seahorse-preferences.png
+share/icons/hicolor/48x48/apps/seahorse.png
+share/icons/hicolor/scalable/apps/seahorse-applet.svg
+share/icons/hicolor/scalable/apps/seahorse-preferences.svg
+share/icons/hicolor/scalable/apps/seahorse.svg
share/mime/packages/seahorse.xml
+share/locale/ar/LC_MESSAGES/seahorse.mo
share/locale/az/LC_MESSAGES/seahorse.mo
share/locale/bg/LC_MESSAGES/seahorse.mo
+share/locale/bn_IN/LC_MESSAGES/seahorse.mo
share/locale/ca/LC_MESSAGES/seahorse.mo
share/locale/cs/LC_MESSAGES/seahorse.mo
share/locale/da/LC_MESSAGES/seahorse.mo
share/locale/de/LC_MESSAGES/seahorse.mo
+share/locale/dz/LC_MESSAGES/seahorse.mo
+share/locale/el/LC_MESSAGES/seahorse.mo
share/locale/en_CA/LC_MESSAGES/seahorse.mo
share/locale/en_GB/LC_MESSAGES/seahorse.mo
share/locale/es/LC_MESSAGES/seahorse.mo
+share/locale/et/LC_MESSAGES/seahorse.mo
share/locale/eu/LC_MESSAGES/seahorse.mo
share/locale/fi/LC_MESSAGES/seahorse.mo
+share/locale/gl/LC_MESSAGES/seahorse.mo
+share/locale/gu/LC_MESSAGES/seahorse.mo
share/locale/fr/LC_MESSAGES/seahorse.mo
+share/locale/he/LC_MESSAGES/seahorse.mo
share/locale/hr/LC_MESSAGES/seahorse.mo
share/locale/hu/LC_MESSAGES/seahorse.mo
share/locale/it/LC_MESSAGES/seahorse.mo
share/locale/ja/LC_MESSAGES/seahorse.mo
+share/locale/ko/LC_MESSAGES/seahorse.mo
+share/locale/lt/LC_MESSAGES/seahorse.mo
+share/locale/mk/LC_MESSAGES/seahorse.mo
share/locale/ml/LC_MESSAGES/seahorse.mo
share/locale/ms/LC_MESSAGES/seahorse.mo
share/locale/nb/LC_MESSAGES/seahorse.mo
@@ -98,22 +257,48 @@ share/locale/sq/LC_MESSAGES/seahorse.mo
share/locale/sr/LC_MESSAGES/seahorse.mo
share/locale/sr@Latn/LC_MESSAGES/seahorse.mo
share/locale/sv/LC_MESSAGES/seahorse.mo
+share/locale/th/LC_MESSAGES/seahorse.mo
share/locale/tr/LC_MESSAGES/seahorse.mo
-share/locale/vi/LC_MESSAGES/seahorse.mo
share/locale/uk/LC_MESSAGES/seahorse.mo
+share/locale/vi/LC_MESSAGES/seahorse.mo
share/locale/zh_CN/LC_MESSAGES/seahorse.mo
+share/locale/zh_HK/LC_MESSAGES/seahorse.mo
share/locale/zh_TW/LC_MESSAGES/seahorse.mo
+@dirrm share/gnome/pixmaps/seahorse/scalable
+@dirrm share/gnome/pixmaps/seahorse/48x48
+@dirrm share/gnome/pixmaps/seahorse/22x22
+@dirrm share/gnome/pixmaps/seahorse
+%%APPLET%%@dirrm share/gnome/help/seahorse-applet/C
+%%APPLET%%@dirrm share/gnome/help/seahorse-applet
+@dirrm share/gnome/help/seahorse/sv/figures
+@dirrm share/gnome/help/seahorse/sv
+@dirrm share/gnome/help/seahorse/it/figures
+@dirrm share/gnome/help/seahorse/it
+@dirrm share/gnome/help/seahorse/fr/figures
+@dirrm share/gnome/help/seahorse/fr
+@dirrm share/gnome/help/seahorse/es/figures
+@dirrm share/gnome/help/seahorse/es
+@dirrm share/gnome/help/seahorse/en_GB/figures
+@dirrm share/gnome/help/seahorse/en_GB
@dirrm share/gnome/help/seahorse/C/figures
@dirrm share/gnome/help/seahorse/C
@dirrm share/gnome/help/seahorse
+%%APPLET%%@dirrm share/gnome/omf/seahorse-applet
@dirrm share/gnome/omf/seahorse
@dirrm share/gnome/seahorse/glade
@dirrm share/gnome/seahorse
+@dirrm lib/seahorse
+%%EPHY%%@dirrmtry lib/epiphany/%%EPHY_VERSION%%/extensions
+%%EPHY%%@dirrmtry lib/epiphany/%%EPHY_VERSION%%
+%%EPHY%%@dirrmtry lib/epiphany
+@dirrm include/libcryptui
@exec %%LOCALBASE%%/bin/update-mime-database %D/share/mime
@unexec %%LOCALBASE%%/bin/update-mime-database %D/share/mime
@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
@dirrmtry share/locale/zh_TW/LC_MESSAGES
@dirrmtry share/locale/zh_TW
+@dirrmtry share/locale/zh_HK/LC_MESSAGES
+@dirrmtry share/locale/zh_HK
@dirrmtry share/locale/zh_CN/LC_MESSAGES
@dirrmtry share/locale/zh_CN
@dirrmtry share/locale/uk/LC_MESSAGES
@@ -132,9 +317,21 @@ share/locale/zh_TW/LC_MESSAGES/seahorse.mo
@dirrmtry share/locale/pl
@dirrmtry share/locale/ne/LC_MESSAGES
@dirrmtry share/locale/ne
+@dirrmtry share/locale/ko/LC_MESSAGES
+@dirrmtry share/locale/ko
+@dirrmtry share/locale/gl/LC_MESSAGES
+@dirrmtry share/locale/gl
@dirrmtry share/locale/fi/LC_MESSAGES
@dirrmtry share/locale/fi
+@dirrmtry share/locale/et/LC_MESSAGES
+@dirrmtry share/locale/et
+@dirrmtry share/locale/el/LC_MESSAGES
+@dirrmtry share/locale/el
+@dirrmtry share/locale/dz/LC_MESSAGES
+@dirrmtry share/locale/dz
@dirrmtry share/locale/cs/LC_MESSAGES
@dirrmtry share/locale/cs
@dirrmtry share/locale/ca/LC_MESSAGES
@dirrmtry share/locale/ca
+@dirrmtry share/locale/bn_IN/LC_MESSAGES
+@dirrmtry share/locale/bn_IN