aboutsummaryrefslogtreecommitdiffstats
path: root/security/seccure
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2007-09-07 16:15:24 +0800
committeredwin <edwin@FreeBSD.org>2007-09-07 16:15:24 +0800
commit02d7714ebdb7c74e6b3ff0111a5c37025578e917 (patch)
tree5d6e2b4ae71f73211c7769774a99ec3697f8514e /security/seccure
parentdc1905c88a72a26be96a997fcce12bc2d34c1fc9 (diff)
downloadfreebsd-ports-gnome-02d7714ebdb7c74e6b3ff0111a5c37025578e917.tar.gz
freebsd-ports-gnome-02d7714ebdb7c74e6b3ff0111a5c37025578e917.tar.zst
freebsd-ports-gnome-02d7714ebdb7c74e6b3ff0111a5c37025578e917.zip
New port: security/seccure - SECCURE Elliptic Curve Crypto Utility for Reliable Encryption
The seccure toolset implements a selection of asymmetric algorithms based on elliptic curve cryptography (ECC). In particular it offers public key encryption / decryption, signature generation / verification and key establishment. ECC schemes offer a much better key size to security ratio than classical systems (RSA, DSA). Keys are short enough to make direct specification of keys on the command line possible (sometimes this is more convenient than the management of PGP-like key rings). seccure builds on this feature and therefore is the tool of choice whenever lightweight asymmetric cryptography -- independent of key servers, revocation certificates, the Web of Trust or even configuration files -- is required. PR: ports/115943 Submitted by: Lukasz Komsta <luke@novum.am.lublin.pl>
Diffstat (limited to 'security/seccure')
-rw-r--r--security/seccure/Makefile20
-rw-r--r--security/seccure/distinfo3
-rw-r--r--security/seccure/files/patch-Makefile36
-rw-r--r--security/seccure/pkg-descr6
-rw-r--r--security/seccure/pkg-plist8
5 files changed, 73 insertions, 0 deletions
diff --git a/security/seccure/Makefile b/security/seccure/Makefile
new file mode 100644
index 000000000000..040e40766679
--- /dev/null
+++ b/security/seccure/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: seccure
+# Date created: 30 August 2007
+# Whom: Lukasz Komsta
+#
+# $FreeBSD$
+#
+
+PORTNAME= seccure
+PORTVERSION= 0.3
+CATEGORIES= security
+MASTER_SITES= http://point-at-infinity.org/seccure/
+
+MAINTAINER= luke@REMOVE_IT.novum.am.lublin.pl
+COMMENT= SECCURE Elliptic Curve Crypto Utility for Reliable Encryption
+
+LIB_DEPENDS= gcrypt.13:${PORTSDIR}/security/libgcrypt
+
+MAN1= seccure.1
+
+.include <bsd.port.mk>
diff --git a/security/seccure/distinfo b/security/seccure/distinfo
new file mode 100644
index 000000000000..005d5a119176
--- /dev/null
+++ b/security/seccure/distinfo
@@ -0,0 +1,3 @@
+MD5 (seccure-0.3.tar.gz) = 01f2a24ef84743795b6be007e4ca4e5c
+SHA256 (seccure-0.3.tar.gz) = 8d9cadca8319b253ae24644c22958898babb67abafd2d90caadd97714d824a47
+SIZE (seccure-0.3.tar.gz) = 30376
diff --git a/security/seccure/files/patch-Makefile b/security/seccure/files/patch-Makefile
new file mode 100644
index 000000000000..12594ab5bf28
--- /dev/null
+++ b/security/seccure/files/patch-Makefile
@@ -0,0 +1,36 @@
+--- Makefile.orig Wed Aug 16 22:13:57 2006
++++ Makefile Thu Aug 30 13:33:58 2007
+@@ -1,4 +1,7 @@
+-CFLAGS = -O2 # -D NOBEEP # -D NOMEMLOCK
++CFLAGS = -L/usr/local/lib -I/usr/local/include -O2 -DNOBEEP -DNOMEMLOCK
++DESTDIR = /usr/local
++
++all: default
+
+ default: binaries # doc
+
+@@ -8,15 +11,15 @@
+ doc: seccure.1 seccure.1.html
+
+ install: default
+- install -m0755 seccure-key $(DESTDIR)/usr/bin
+- ln -f $(DESTDIR)/usr/bin/seccure-key $(DESTDIR)/usr/bin/seccure-encrypt
+- ln -f $(DESTDIR)/usr/bin/seccure-key $(DESTDIR)/usr/bin/seccure-decrypt
+- ln -f $(DESTDIR)/usr/bin/seccure-key $(DESTDIR)/usr/bin/seccure-sign
+- ln -f $(DESTDIR)/usr/bin/seccure-key $(DESTDIR)/usr/bin/seccure-verify
+- ln -f $(DESTDIR)/usr/bin/seccure-key $(DESTDIR)/usr/bin/seccure-signcrypt
+- ln -f $(DESTDIR)/usr/bin/seccure-key $(DESTDIR)/usr/bin/seccure-veridec
+- ln -f $(DESTDIR)/usr/bin/seccure-key $(DESTDIR)/usr/bin/seccure-dh
+- install -m0644 seccure.1 $(DESTDIR)/usr/share/man/man1
++ install -m0755 seccure-key $(DESTDIR)/bin
++ ln -f $(DESTDIR)/bin/seccure-key $(DESTDIR)/bin/seccure-encrypt
++ ln -f $(DESTDIR)/bin/seccure-key $(DESTDIR)/bin/seccure-decrypt
++ ln -f $(DESTDIR)/bin/seccure-key $(DESTDIR)/bin/seccure-sign
++ ln -f $(DESTDIR)/bin/seccure-key $(DESTDIR)/bin/seccure-verify
++ ln -f $(DESTDIR)/bin/seccure-key $(DESTDIR)/bin/seccure-signcrypt
++ ln -f $(DESTDIR)/bin/seccure-key $(DESTDIR)/bin/seccure-veridec
++ ln -f $(DESTDIR)/bin/seccure-key $(DESTDIR)/bin/seccure-dh
++ install -m0644 seccure.1 $(DESTDIR)/man/man1
+
+ clean:
+ rm -f *.o seccure-key seccure-encrypt seccure-decrypt seccure-sign \
diff --git a/security/seccure/pkg-descr b/security/seccure/pkg-descr
new file mode 100644
index 000000000000..51a9a6bce6fa
--- /dev/null
+++ b/security/seccure/pkg-descr
@@ -0,0 +1,6 @@
+The seccure toolset implements a selection of asymmetric algorithms based on elliptic curve cryptography (ECC). In particular it offers public key encryption / decryption, signature generation / verification and key establishment.
+
+ECC schemes offer a much better key size to security ratio than classical systems (RSA, DSA). Keys are short enough to make direct specification of keys on the command line possible (sometimes this is more convenient than the management of PGP-like key rings). seccure builds on this feature and therefore is the tool of choice whenever lightweight asymmetric cryptography -- independent of key servers, revocation certificates, the Web of Trust or even configuration files -- is required.
+
+WWW: http://point-at-infinity.org/seccure/
+Author: B. Poettering
diff --git a/security/seccure/pkg-plist b/security/seccure/pkg-plist
new file mode 100644
index 000000000000..ebfb477ceb5d
--- /dev/null
+++ b/security/seccure/pkg-plist
@@ -0,0 +1,8 @@
+bin/seccure-key
+bin/seccure-encrypt
+bin/seccure-decrypt
+bin/seccure-sign
+bin/seccure-verify
+bin/seccure-signcrypt
+bin/seccure-veridec
+bin/seccure-dh