aboutsummaryrefslogtreecommitdiffstats
path: root/security/secpanel/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-05-01 05:02:31 +0800
committerpav <pav@FreeBSD.org>2006-05-01 05:02:31 +0800
commit00d247dc0eb4d338298d7976fa386027bc141472 (patch)
treef789584ac9c2e18b4a587d30de7931186e76719f /security/secpanel/Makefile
parent7090b20b1b96f3bee3e9fedc4e4e6987c0f53509 (diff)
downloadfreebsd-ports-gnome-00d247dc0eb4d338298d7976fa386027bc141472.tar.gz
freebsd-ports-gnome-00d247dc0eb4d338298d7976fa386027bc141472.tar.zst
freebsd-ports-gnome-00d247dc0eb4d338298d7976fa386027bc141472.zip
- Update to 0.5.1
PR: ports/96533 Submitted by: Aleksander Fafula <alex@BSDGuru.org>
Diffstat (limited to 'security/secpanel/Makefile')
-rw-r--r--security/secpanel/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/security/secpanel/Makefile b/security/secpanel/Makefile
index 9296b75e3e69..c9eaa324b207 100644
--- a/security/secpanel/Makefile
+++ b/security/secpanel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= secpanel
-PORTVERSION= 0.4.3
+PORTVERSION= 0.5.1
PORTEPOCH= 1
CATEGORIES= security tcl84 tk84
MASTER_SITES= http://www.pingx.net/secpanel/
@@ -17,25 +17,24 @@ COMMENT= GUI for managing and running ssh and related utilities
RUN_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84 \
ssh-askpass:${PORTSDIR}/security/openssh-askpass
-USE_REINPLACE= yes
USE_X_PREFIX= yes
NO_BUILD= yes
post-patch:
@${REINPLACE_CMD} -e 's!^exec wish!exec wish8.4!' \
- -e 's!\[file dirname \[info script\]\]/../lib/secpanel!${PREFIX}/share/secpanel!' \
+ -e 's!\[file dirname \[info script\]\]/../lib/secpanel!${DATADIR}!' \
-e 's!askpassbin askpass!askpassbin ssh-askpass!' ${WRKSRC}/src/bin/secpanel
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/src/bin/secpanel ${PREFIX}/bin
- @${MKDIR} ${PREFIX}/share/secpanel
+ @${MKDIR} ${DATADIR}
.for file in convert_history.tcl default.config default.profile \
gui.tcl listserver.tcl secpanel.dist secpanel.wait
- ${INSTALL_SCRIPT} ${WRKSRC}/src/lib/secpanel/${file} ${PREFIX}/share/secpanel
+ ${INSTALL_SCRIPT} ${WRKSRC}/src/lib/secpanel/${file} ${DATADIR}
.endfor
- @${MKDIR} ${PREFIX}/share/secpanel/images
+ @${MKDIR} ${DATADIR}/images
${INSTALL_DATA} ${WRKSRC}/src/lib/secpanel/images/*.gif \
- ${PREFIX}/share/secpanel/images
+ ${DATADIR}/images
.include <bsd.port.mk>