aboutsummaryrefslogtreecommitdiffstats
path: root/security/secpanel/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2010-07-15 15:28:49 +0800
committermiwi <miwi@FreeBSD.org>2010-07-15 15:28:49 +0800
commit57446a7c5d9280d2af989137968775c326f9e98b (patch)
tree4d8e7368024d0961d7fa0135892bf9604ccf2737 /security/secpanel/Makefile
parent47d3da27210660a4f9e23dcea017ef779c0f7726 (diff)
downloadfreebsd-ports-gnome-57446a7c5d9280d2af989137968775c326f9e98b.tar.gz
freebsd-ports-gnome-57446a7c5d9280d2af989137968775c326f9e98b.tar.zst
freebsd-ports-gnome-57446a7c5d9280d2af989137968775c326f9e98b.zip
- Update to 0.6.1
PR: 148571 Submitted by: Ports Fury
Diffstat (limited to 'security/secpanel/Makefile')
-rw-r--r--security/secpanel/Makefile21
1 files changed, 9 insertions, 12 deletions
diff --git a/security/secpanel/Makefile b/security/secpanel/Makefile
index 5724aa6552fe..bc8afcd58b9f 100644
--- a/security/secpanel/Makefile
+++ b/security/secpanel/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= secpanel
-PORTVERSION= 0.6.0
+PORTVERSION= 0.6.1
PORTEPOCH= 1
CATEGORIES= security tcl tk
-MASTER_SITES= http://themediahost.de/secpanel/data/ CENKES
+MASTER_SITES= SF/${PORTNAME}
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
@@ -17,22 +17,19 @@ COMMENT= GUI for managing and running ssh and related utilities
RUN_DEPENDS= ssh-askpass:${PORTSDIR}/security/openssh-askpass
-USE_TK_RUN= 84
+WRKSRC= ${WRKDIR}/usr/local
NO_BUILD= yes
-post-extract:
- @${MV} ${WRKDIR}/usr ${WRKSRC}
- @${CHMOD} -R a+rX ${WRKSRC}/
- @${RM} -rf ${WRKSRC}/local/lib/secpanel/out/
+USE_TK_WRAPPER= yes
post-patch:
- @${REINPLACE_CMD} -e 's!^exec wish!exec ${WISH}!' \
+ @${REINPLACE_CMD} \
-e 's!\[file dirname \[info script\]\]/../lib/secpanel!${DATADIR}!' \
- -e 's!askpassbin askpass!askpassbin ssh-askpass!' \
- ${WRKSRC}/local/bin/secpanel
+ ${WRKSRC}/bin/secpanel
do-install:
- @${INSTALL_SCRIPT} ${WRKSRC}/local/bin/secpanel ${PREFIX}/bin/
- @cd ${WRKSRC}/local/lib/secpanel/&&${COPYTREE_SHARE} . ${DATADIR}/
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/secpanel ${PREFIX}/bin
+ @(cd ${WRKSRC}/lib/secpanel && ${COPYTREE_SHARE} . ${DATADIR})
+ @${CHMOD} u+rw ${DATADIR}/default.config
.include <bsd.port.mk>