aboutsummaryrefslogtreecommitdiffstats
path: root/security/secpanel/Makefile
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2012-12-02 21:11:25 +0800
committerrm <rm@FreeBSD.org>2012-12-02 21:11:25 +0800
commitfc7328baf9bfbd20ba6f36945063e3e48e25bbb9 (patch)
treedf306c4313f48cb90ae1fb75862e7bb35b9f23ce /security/secpanel/Makefile
parent7e2496d5f7bacbb430301aeb054259b591984c8d (diff)
downloadfreebsd-ports-gnome-fc7328baf9bfbd20ba6f36945063e3e48e25bbb9.tar.gz
freebsd-ports-gnome-fc7328baf9bfbd20ba6f36945063e3e48e25bbb9.tar.zst
freebsd-ports-gnome-fc7328baf9bfbd20ba6f36945063e3e48e25bbb9.zip
- pass maintainership to submitter
- add license (GPLv2) - add desktop icon and make .desktop file - update WWW while here: - trim Makefile header - remove Author filed from pkg-descr PR: 173978 Submitted by: nemysis <nemysis@gmx.ch> Feature safe: yes
Diffstat (limited to 'security/secpanel/Makefile')
-rw-r--r--security/secpanel/Makefile30
1 files changed, 19 insertions, 11 deletions
diff --git a/security/secpanel/Makefile b/security/secpanel/Makefile
index bc8afcd58b9f..f2b9594e6d47 100644
--- a/security/secpanel/Makefile
+++ b/security/secpanel/Makefile
@@ -1,20 +1,23 @@
-# New ports collection makefile for: secpanel
-# Date created: 11 June 2001
-# Whom: Pete Fritchman <petef@databits.net>
-#
+# Created by: Pete Fritchman <petef@databits.net>
# $FreeBSD$
-#
PORTNAME= secpanel
PORTVERSION= 0.6.1
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= security tcl tk
-MASTER_SITES= SF/${PORTNAME}
-EXTRACT_SUFX= .tgz
-
-MAINTAINER= ports@FreeBSD.org
+MASTER_SITES= SF/${PORTNAME} \
+ SF/nemysisfreebsdp/:icons
+DISTFILES= ${PORTNAME}-${PORTVERSION}.tgz \
+ ${PORTNAME}.png:icons
+DIST_SUBDIR= ${PORTNAME}
+EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}.tgz
+
+MAINTAINER= nemysis@gmx.ch
COMMENT= GUI for managing and running ssh and related utilities
+LICENSE= GPLv2
+
RUN_DEPENDS= ssh-askpass:${PORTSDIR}/security/openssh-askpass
WRKSRC= ${WRKDIR}/usr/local
@@ -22,14 +25,19 @@ NO_BUILD= yes
USE_TK_WRAPPER= yes
+DESKTOP_ENTRIES="SecPanel" "${COMMENT}" "${PORTNAME}" \
+ "${PORTNAME}" "Application;System;" ${FALSE}
+
post-patch:
@${REINPLACE_CMD} \
- -e 's!\[file dirname \[info script\]\]/../lib/secpanel!${DATADIR}!' \
+ -e 's|\[file dirname \[info script\]\]/../lib/secpanel|${DATADIR}|' \
${WRKSRC}/bin/secpanel
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/bin/secpanel ${PREFIX}/bin
- @(cd ${WRKSRC}/lib/secpanel && ${COPYTREE_SHARE} . ${DATADIR})
+ @(cd ${WRKSRC}/lib/secpanel && ${COPYTREE_SHARE} \* ${DATADIR})
@${CHMOD} u+rw ${DATADIR}/default.config
+ ${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/${PORTNAME}.png ${PREFIX}/share/pixmaps
+
.include <bsd.port.mk>