aboutsummaryrefslogtreecommitdiffstats
path: root/security/secpanel
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2017-04-09 02:00:04 +0800
committerpi <pi@FreeBSD.org>2017-04-09 02:00:04 +0800
commit812a7406515fff456dfed1f8fb764f704a3089d1 (patch)
tree1bbb601f4362dcd8d6485adc94f25557d1d7773a /security/secpanel
parent49ccf68badc05dcacc93824a3b39f9b62f657fdc (diff)
downloadfreebsd-ports-gnome-812a7406515fff456dfed1f8fb764f704a3089d1.tar.gz
freebsd-ports-gnome-812a7406515fff456dfed1f8fb764f704a3089d1.tar.zst
freebsd-ports-gnome-812a7406515fff456dfed1f8fb764f704a3089d1.zip
security/secpanel: add xfce4-terminal and Thunar support
PR: 213790 Submitted by: Rozhuk Ivan <rozhuk.im@gmail.com> Approved by: nemysis (maintainer timeout)
Diffstat (limited to 'security/secpanel')
-rw-r--r--security/secpanel/Makefile5
-rw-r--r--security/secpanel/files/patch-bin_secpanel47
-rw-r--r--security/secpanel/files/patch-lib_secpanel_termdefs.txt11
3 files changed, 60 insertions, 3 deletions
diff --git a/security/secpanel/Makefile b/security/secpanel/Makefile
index fe953d6da3d6..0746dfba3f92 100644
--- a/security/secpanel/Makefile
+++ b/security/secpanel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= secpanel
PORTVERSION= 0.6.1
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= security tcl tk
MASTER_SITES= SF/${PORTNAME} \
@@ -25,8 +25,7 @@ NO_BUILD= yes
USES= tk:wrapper
-DESKTOP_ENTRIES="SecPanel" "${COMMENT}" "${PORTNAME}" \
- "${PORTNAME}" "" "false"
+DESKTOP_ENTRIES="SecPanel" "${COMMENT}" "${PORTNAME}" "${PORTNAME}" "" false
post-patch:
@${REINPLACE_CMD} \
diff --git a/security/secpanel/files/patch-bin_secpanel b/security/secpanel/files/patch-bin_secpanel
new file mode 100644
index 000000000000..9b10100e4ada
--- /dev/null
+++ b/security/secpanel/files/patch-bin_secpanel
@@ -0,0 +1,47 @@
+--- bin/secpanel.orig 2017-04-08 17:52:46 UTC
++++ bin/secpanel
+@@ -29,7 +29,7 @@ exec wish "$0" "$@"
+
+ set spversion 0.6.0
+
+-set libdir "[file dirname [info script]]/../lib/secpanel"
++set libdir "/usr/local/share/secpanel"
+ # set libdir "$env(HOME)/secpanel_devel/secpanel-0x/lib"
+ set sshdir "$env(HOME)/.ssh"
+
+@@ -142,7 +142,7 @@ proc initconfigs {} {
+ global configs
+ foreach {bintag binprog} \
+ {sshbin ssh keygenbin ssh-keygen agentbin ssh-agent \
+- addbin ssh-add askpassbin ssh-askpass scpbin scp sftpbin Filezilla termver Xterm browserbin firefox \
++ addbin ssh-add askpassbin ssh-askpass scpbin scp sftpbin Filezilla Thunar termver Xterm browserbin firefox \
+ } {
+ if {! [info exists configs($bintag)]} {
+ set configs($bintag) $binprog
+@@ -1142,6 +1142,9 @@ proc connect_sftp {} {
+ "Filezilla" {
+ set runstring "filezilla -l interactive "
+ }
++ "Thunar" {
++ set runstring "thunar "
++ }
+ "GNOME-Nautilus" {
+ set runstring "nautilus "
+ }
+@@ -2439,6 +2442,7 @@ proc main {argc argv} {
+ foreach {sftptag sftpprog} {
+ "KDE-Konqueror" konqueror
+ "GNOME-Nautilus" nautilus
++ "Thunar" thunar
+ "Filezilla" filezilla
+ } {
+ if {! [catch {exec which "$sftpprog"}]} {
+@@ -2498,7 +2502,7 @@ proc main {argc argv} {
+ .mc1 add command -label "Multi Xterm (not found)" -command "multiconnect multixterm" -state "disabled"
+ }
+
+- if {[catch {exec which "filezilla"}] && [catch {exec which "nautilus"}] && [catch {exec which "konqueror"}]
++ if {[catch {exec which "filezilla"}] && [catch {exec which "thunar"}] && [catch {exec which "nautilus"}] && [catch {exec which "konqueror"}]
+ } {
+ .top17.fra46.fra26.fra29.fra36.but34 configure -state "disabled"
+ }
diff --git a/security/secpanel/files/patch-lib_secpanel_termdefs.txt b/security/secpanel/files/patch-lib_secpanel_termdefs.txt
new file mode 100644
index 000000000000..08b32c368779
--- /dev/null
+++ b/security/secpanel/files/patch-lib_secpanel_termdefs.txt
@@ -0,0 +1,11 @@
+--- lib/secpanel/termdefs.txt.orig 2017-04-08 17:52:46 UTC
++++ lib/secpanel/termdefs.txt
+@@ -56,7 +56,7 @@ set termtype(XFCE-Terminal_titlepar) "--title"
+ set termtype(XFCE-Terminal_quotepar) ""
+ set termtype(XFCE-Terminal_iconpar) ""
+ set termtype(XFCE-Terminal_execpar) "-x"
+-set termtype(XFCE-Terminal_path) "Terminal"
++set termtype(XFCE-Terminal_path) "xfce4-terminal"
+
+ set termtype(Putty's-Terminal_titlepar) "-title"
+ set termtype(Putty's-Terminal_quotepar) ""