aboutsummaryrefslogtreecommitdiffstats
path: root/security/secure_delete
diff options
context:
space:
mode:
authoraraujo <araujo@FreeBSD.org>2012-12-20 13:43:28 +0800
committeraraujo <araujo@FreeBSD.org>2012-12-20 13:43:28 +0800
commit204b88f19c073f59351e40c5ffabe0cdf702472d (patch)
tree184168b3377ff9575e1349956112d576bd589bff /security/secure_delete
parent3d2fe16564d7e8ea269e7a6a2f9321d2f316f6b5 (diff)
downloadfreebsd-ports-gnome-204b88f19c073f59351e40c5ffabe0cdf702472d.tar.gz
freebsd-ports-gnome-204b88f19c073f59351e40c5ffabe0cdf702472d.tar.zst
freebsd-ports-gnome-204b88f19c073f59351e40c5ffabe0cdf702472d.zip
- Update MASTER_SITES.
- Support CC/CFLAGS properly. - Support PLIST_FILES/PORTDOCS. - Add MAKE_JOBS_UNSAFE. - Trim header. PR: ports/172059 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Diffstat (limited to 'security/secure_delete')
-rw-r--r--security/secure_delete/Makefile47
-rw-r--r--security/secure_delete/pkg-plist12
2 files changed, 39 insertions, 20 deletions
diff --git a/security/secure_delete/Makefile b/security/secure_delete/Makefile
index 93d87dc96e26..c382ca5982eb 100644
--- a/security/secure_delete/Makefile
+++ b/security/secure_delete/Makefile
@@ -1,25 +1,56 @@
-# New ports collection makefile for: secure_delete
-# Date created: 24 Jul 2004
-# Whom: Vaida Bogdan <vaida.bogdan@gmail.com>
-#
+# Created by: Vaida Bogdan <vaida.bogdan@gmail.com>
# $FreeBSD$
-#
PORTNAME= secure_delete
PORTVERSION= 3.1
+PORTREVISION= 1
CATEGORIES= security
-MASTER_SITES= http://packetstormsecurity.org/groups/thc/
+MASTER_SITES= PACKETSTORM/group/thc
MAINTAINER= ports@FreeBSD.org
COMMENT= Secure data deletion toolkit
+OPTIONS_DEFINE= DOCS
+
CONFLICTS= srm-[0-9]*
-MANCOMPRESSED= no
-MAN1= srm.1 sfill.1 sswap.1 smem.1
+MAKE_JOBS_UNSAFE=yes
SUB_FILES= pkg-message
+MLINKS= srm.1 sdel.1
+MAN1= srm.1 sfill.1 sswap.1 smem.1
+PORTDOCS= CHANGES FILES README secure_delete.doc usenix6-gutmann.doc
+PLIST_FILES= ${BIN_PROGRAMS:S,^,bin/,} ${BIN_SCRIPTS:S,^,bin/,} bin/sdel
+
+BIN_PROGRAMS= srm sfill sswap smem
+BIN_SCRIPTS= the_cleaner.sh
+
+.include <bsd.port.options.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|^CC=|CC?=| ; \
+ s|-O2 |$$(CFLAGS) | ;\
+ /strip/s|^|#|' ${WRKSRC}/Makefile
+
+do-install:
+.for i in ${BIN_PROGRAMS}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${i} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${i}.1 ${MANPREFIX}/man/man1
+.endfor
+.for i in ${BIN_SCRIPTS}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${i} ${PREFIX}/bin
+.endfor
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+ ${LN} -sf srm ${PREFIX}/bin/sdel
+
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/security/secure_delete/pkg-plist b/security/secure_delete/pkg-plist
deleted file mode 100644
index 21a697f09046..000000000000
--- a/security/secure_delete/pkg-plist
+++ /dev/null
@@ -1,12 +0,0 @@
-bin/sdel
-bin/srm
-bin/sfill
-bin/sswap
-bin/smem
-bin/the_cleaner.sh
-%%DOCSDIR%%/CHANGES
-%%DOCSDIR%%/FILES
-%%DOCSDIR%%/README
-%%DOCSDIR%%/secure_delete.doc
-%%DOCSDIR%%/usenix6-gutmann.doc
-@dirrm %%DOCSDIR%%