aboutsummaryrefslogtreecommitdiffstats
path: root/security/sks
diff options
context:
space:
mode:
authorjohans <johans@FreeBSD.org>2014-01-25 20:10:59 +0800
committerjohans <johans@FreeBSD.org>2014-01-25 20:10:59 +0800
commitdad4969546b3347bc33768658fcb50919b376f91 (patch)
tree3d26cc7c134069aa1646a9ec51ae94272cba7a2b /security/sks
parent0b6a083d9ce351521e8d1aaf732145c9b225010f (diff)
downloadfreebsd-ports-gnome-dad4969546b3347bc33768658fcb50919b376f91.tar.gz
freebsd-ports-gnome-dad4969546b3347bc33768658fcb50919b376f91.tar.zst
freebsd-ports-gnome-dad4969546b3347bc33768658fcb50919b376f91.zip
Respect CC and CFLAGS
Diffstat (limited to 'security/sks')
-rw-r--r--security/sks/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/security/sks/Makefile b/security/sks/Makefile
index 77ad7cd267a1..9f8ead58da45 100644
--- a/security/sks/Makefile
+++ b/security/sks/Makefile
@@ -30,12 +30,16 @@ post-extract:
@${REINPLACE_CMD} 's/-ccopt -pg //' ${WRKSRC}/Makefile
@cd ${WRKSRC} && ${RM} -f .depend
+post-patch:
+ @${REINPLACE_CMD} '/^CC=/d; /^CFLAGS=/s/=/+=/' \
+ ${WRKSRC}/Makefile ${WRKSRC}/bdb/Makefile
+
pre-build:
@cd ${WRKSRC} && test -f .depend || ${GMAKE} dep
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- @cd ${WRKSRC} && ${INSTALL_DATA} BUGS README.md TODO UPGRADING \
+ cd ${WRKSRC} && ${INSTALL_DATA} BUGS README.md TODO UPGRADING \
${STAGEDIR}${DOCSDIR}
@cd ${STAGEDIR}${PREFIX}/bin && ${STRIP_CMD} sks sks_add_mail