aboutsummaryrefslogtreecommitdiffstats
path: root/security/slurpie/Makefile
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2000-02-14 11:24:01 +0800
committerobrien <obrien@FreeBSD.org>2000-02-14 11:24:01 +0800
commit657b4faad7c78ab0d5189e1711d216f0aadf99df (patch)
tree20f9d9b71fe6c92c8530de2fc269576b420209bf /security/slurpie/Makefile
parenta02e19e85f434571c79fa340fe24540548b8b927 (diff)
downloadfreebsd-ports-gnome-657b4faad7c78ab0d5189e1711d216f0aadf99df.tar.gz
freebsd-ports-gnome-657b4faad7c78ab0d5189e1711d216f0aadf99df.tar.zst
freebsd-ports-gnome-657b4faad7c78ab0d5189e1711d216f0aadf99df.zip
Slurpie is a passwd file cracker similar to CrackerJack and John the Ripper
except that it can be run in a distributed environment (multiple computers aka nodes).
Diffstat (limited to 'security/slurpie/Makefile')
-rw-r--r--security/slurpie/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/security/slurpie/Makefile b/security/slurpie/Makefile
new file mode 100644
index 000000000000..2629e748c56f
--- /dev/null
+++ b/security/slurpie/Makefile
@@ -0,0 +1,28 @@
+# ex:ts=8
+# Ports collection makefile for: slurpie
+# Version required: 2.0b
+# Date created: Sun Feb 12, 2000
+# Whom: David O'Brien (obrien@NUXI.com)
+#
+# $FreeBSD$
+#
+
+DISTNAME= slurpie
+PKGNAME= slurpie-2.0b
+CATEGORIES= security
+MASTER_SITES= http://www.jps.net/coati/archives/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= obrien@FreeBSD.org
+
+NO_PACKAGE= "links against crypt() [thus is crypto in package form]"
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/slurp ${PREFIX}/sbin
+ ${INSTALL_PROGRAM} ${WRKSRC}/slurpie ${PREFIX}/sbin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/slurpie
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/slurpie/README
+.endif
+
+.include <bsd.port.mk>