aboutsummaryrefslogtreecommitdiffstats
path: root/security/slush/Makefile
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>1999-05-10 01:50:07 +0800
committersteve <steve@FreeBSD.org>1999-05-10 01:50:07 +0800
commit88c25861ab4228c7341842e8979547e06bcf1292 (patch)
treee9e2e1ffd3a10ab57edc9c607a0cbc70343d0265 /security/slush/Makefile
parente9d0c9e7e5423402bb37e17711c1417425e4c464 (diff)
downloadfreebsd-ports-gnome-88c25861ab4228c7341842e8979547e06bcf1292.tar.gz
freebsd-ports-gnome-88c25861ab4228c7341842e8979547e06bcf1292.tar.zst
freebsd-ports-gnome-88c25861ab4228c7341842e8979547e06bcf1292.zip
Initial import of slush version 0.1.0.
A telnet-like application which uses a secure SSL channel. PR: 11557 Submitted by: Peter Shipley <shipley@dis.org>
Diffstat (limited to 'security/slush/Makefile')
-rw-r--r--security/slush/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/security/slush/Makefile b/security/slush/Makefile
new file mode 100644
index 000000000000..5cbfdfaaa112
--- /dev/null
+++ b/security/slush/Makefile
@@ -0,0 +1,48 @@
+# Ports collection makefile for: slush
+# Version required: 0.1.0
+# Date created: Sun May 3, 1999
+# Whom: shipley@dis.org
+#
+# $Id$
+#
+#DISTDIR= /var/tmp/ # for debuging
+
+DISTNAME= slush-0_1_0_tar
+PKGNAME= slush-0.1.0
+CATEGORIES= security net
+MASTER_SITES= ftp://www.dis.org/pub/Security/
+EXTRACT_SUFX= .gz
+
+MAINTAINER= shipley@dis.org
+
+BUILD_DEPENDS= openssl:${PORTSDIR}/security/openssl
+
+#MAN= slush.1
+
+GNU_CONFIGURE= yes
+
+#NOPROFILE= true
+
+.include <bsd.port.pre.mk>
+.if ${OSVERSION} <= 300000
+BROKEN= does not build
+.endif
+
+WRKSRC= ${WRKDIR}/slush-0.1.0
+.if defined(USA_RESIDENT) && ${USA_RESIDENT} == YES
+MAKE_ENV+= EXTRA_SSL_LIBS="-lRSAglue -lrsaref"
+.endif
+
+do-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/slush
+ ${INSTALL_MAN} ${WRKSRC}/control.txt ${PREFIX}/share/doc/slush
+ ${INSTALL_MAN} ${WRKSRC}/INSTALL ${PREFIX}/share/doc/slush
+ ${INSTALL_MAN} ${WRKSRC}/HISTORY ${PREFIX}/share/doc/slush
+ ${INSTALL_MAN} ${WRKSRC}/README ${PREFIX}/share/doc/slush
+ ${INSTALL_MAN} ${WRKSRC}/COPYING ${PREFIX}/share/doc/slush
+.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/slush ${PREFIX}/bin/slush
+ ${INSTALL_PROGRAM} ${WRKSRC}/slushd ${PREFIX}/sbin/slushd
+
+.include <bsd.port.post.mk>