aboutsummaryrefslogtreecommitdiffstats
path: root/security/smap/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2007-05-25 06:16:25 +0800
committeredwin <edwin@FreeBSD.org>2007-05-25 06:16:25 +0800
commit80d8c0c4c2651b4b5203e72c5470ae3df875ebea (patch)
tree2760805893d6545e2337d06ebad28ca9460dc61d /security/smap/Makefile
parente1a665f066e92fed406eaf8ed5feeda1855ca6b6 (diff)
downloadfreebsd-ports-gnome-80d8c0c4c2651b4b5203e72c5470ae3df875ebea.tar.gz
freebsd-ports-gnome-80d8c0c4c2651b4b5203e72c5470ae3df875ebea.tar.zst
freebsd-ports-gnome-80d8c0c4c2651b4b5203e72c5470ae3df875ebea.zip
New port: security/smap
smap is a simple scanner for SIP enabled devices smap sends off various SIP requests awaiting responses from SIP enabled DSL router, proxies and user agents. It could be considered a mashup of nmap and sipsak ;) WWW: http://www.wormulon.net/ Author: Hendrik Scholz <hscholz@raisdorf.net>
Diffstat (limited to 'security/smap/Makefile')
-rw-r--r--security/smap/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/security/smap/Makefile b/security/smap/Makefile
new file mode 100644
index 000000000000..2d7872d37d3f
--- /dev/null
+++ b/security/smap/Makefile
@@ -0,0 +1,27 @@
+# ex:ts=8
+# New ports collection makefile for: smap
+# Date created: May 25, 2007
+# Whom: Edwin Groothuis <edwin@mavetju.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= smap
+PORTVERSION= 0.5.0
+CATEGORIES= security net
+MASTER_SITES= http://www.wormulon.net/smap/
+
+MAINTAINER= edwin@mavetju.org
+COMMENT= SIP scanner and identifier
+
+PLIST_FILES= bin/smap share/smap/fingerprint.db
+PLIST_DIRS= share/map
+
+USE_GMAKE= yes
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/smap ${PREFIX}/bin
+ ${MKDIR} ${PREFIX}/share/smap
+ ${INSTALL_DATA} ${WRKSRC}/fingerprint.db ${PREFIX}/share/smap
+
+.include <bsd.port.mk>