aboutsummaryrefslogtreecommitdiffstats
path: root/security/smtpscan
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-04-04 17:19:28 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-04-04 17:19:28 +0800
commit27e19b255767a92c7f7cddd4a1199b06125ac643 (patch)
treec41faaad0eff0a8d48a1bed1639eae63dd9f3bda /security/smtpscan
parentb3820a0e1fe00914b9089287cd999e2109e8f349 (diff)
downloadfreebsd-ports-gnome-27e19b255767a92c7f7cddd4a1199b06125ac643.tar.gz
freebsd-ports-gnome-27e19b255767a92c7f7cddd4a1199b06125ac643.tar.zst
freebsd-ports-gnome-27e19b255767a92c7f7cddd4a1199b06125ac643.zip
Support staging
Diffstat (limited to 'security/smtpscan')
-rw-r--r--security/smtpscan/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/security/smtpscan/Makefile b/security/smtpscan/Makefile
index bd3b3408ffb0..0865a594789d 100644
--- a/security/smtpscan/Makefile
+++ b/security/smtpscan/Makefile
@@ -21,13 +21,12 @@ NO_BUILD= yes
USES= perl5
USE_PERL5= run
-MAN1= smtpscan.1
PLIST_FILES= bin/smtpscan \
+ man/man1/smtpscan.1.gz \
%%DATADIR%%/fingerprints \
%%DATADIR%%/tests
PLIST_DIRS= %%DATADIR%%
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e \
's|^#!.*|#!${PERL}| ; \
@@ -38,10 +37,10 @@ post-patch:
s|@prefix@|${PREFIX}/share|' ${WRKSRC}/docs/man/smtpscan.1
do-install:
- (cd ${WRKSRC}/src && ${INSTALL_SCRIPT} smtpscan ${PREFIX}/bin)
+ (cd ${WRKSRC}/src && ${INSTALL_SCRIPT} smtpscan ${STAGEDIR}${PREFIX}/bin)
(cd ${WRKSRC}/docs/man \
- && ${INSTALL_MAN} smtpscan.1 ${MANPREFIX}/man/man1)
- @${MKDIR} ${DATADIR}
- (cd ${WRKSRC}/src && ${INSTALL_SCRIPT} fingerprints tests ${DATADIR})
+ && ${INSTALL_MAN} smtpscan.1 ${STAGEDIR}${MANPREFIX}/man/man1)
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ (cd ${WRKSRC}/src && ${INSTALL_SCRIPT} fingerprints tests ${STAGEDIR}${DATADIR})
.include <bsd.port.mk>