aboutsummaryrefslogtreecommitdiffstats
path: root/security/snort/Makefile
diff options
context:
space:
mode:
authorsergei <sergei@FreeBSD.org>2005-02-07 17:35:32 +0800
committersergei <sergei@FreeBSD.org>2005-02-07 17:35:32 +0800
commite016d491f6df628175f97bd76c74830f7568a8a1 (patch)
tree90b8d421e4122fea5082f89c991f7ff6d1315b54 /security/snort/Makefile
parentd744d042d638a0404d85538b1d678b54667706fb (diff)
downloadfreebsd-ports-gnome-e016d491f6df628175f97bd76c74830f7568a8a1.tar.gz
freebsd-ports-gnome-e016d491f6df628175f97bd76c74830f7568a8a1.tar.zst
freebsd-ports-gnome-e016d491f6df628175f97bd76c74830f7568a8a1.zip
- Upgrade to 2.3.0 [1]
- Add WITH_PRELUDE knob to enable integration with Prelude IDS [2] PR: ports/76679 [1] Submitted by: Linh Pham <question+fbsdports@closedsrc.org> [1] Prompted by: Roberto Bosticardo <roberto.bosticardo@csp.it> [2]
Diffstat (limited to 'security/snort/Makefile')
-rw-r--r--security/snort/Makefile38
1 files changed, 34 insertions, 4 deletions
diff --git a/security/snort/Makefile b/security/snort/Makefile
index 36721fe26d28..047b0dbb4961 100644
--- a/security/snort/Makefile
+++ b/security/snort/Makefile
@@ -6,9 +6,10 @@
#
PORTNAME= snort
-PORTVERSION= 2.2.0
+PORTVERSION= 2.3.0
CATEGORIES= security
MASTER_SITES= http://www.snort.org/dl/
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= sergei@FreeBSD.org
COMMENT= Lightweight network intrusion detection system
@@ -18,7 +19,8 @@ LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
OPTIONS= FLEXRESP "Flexible response to events" off \
MYSQL "Enable MySQL support" off \
ODBC "Enable ODBC support" off \
- POSTGRESQL "Enable PostgreSQL support" off
+ POSTGRESQL "Enable PostgreSQL support" off \
+ PRELUDE "Enable patch for Prelude integration" off
USE_GPG= yes
SIG_SUFFIX= .asc
@@ -30,8 +32,8 @@ CONFIGURE_ENV= LDFLAGS="${LDFLAGS}"
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN8= snort.8
-DOCS= ChangeLog doc/AUTHORS doc/BUGS doc/CREDITS doc/FAQ doc/NEWS \
- doc/README* doc/TODO doc/USAGE doc/snort_manual.pdf
+DOCS= ChangeLog doc/AUTHORS doc/BUGS doc/CREDITS doc/NEWS \
+ doc/README* doc/TODO doc/USAGE doc/*.pdf
.include <bsd.port.pre.mk>
@@ -67,6 +69,27 @@ LDFLAGS+= -lssl -lcrypto
CONFIGURE_ARGS+= --with-postgresql=no
.endif
+.if defined(WITH_PRELUDE)
+#BROKEN= Prelude reporting patch have not been updated for Snort 2.2.0
+PRELUDE_PATCH= 0.3.6
+MASTER_SITES+= http://prelude-ids.org/download/releases/:prelude
+SIGNED_FILES= ${DISTNAME}${EXTRACT_SUFX}
+DISTFILES+= snort-prelude-reporting-patch-${PRELUDE_PATCH}.tar.gz:prelude
+EXTRA_PATCHES+= ${WRKDIR}/snort-2.2.0-prelude-${PRELUDE_PATCH}.diff
+USE_AUTOMAKE_VER= 19
+USE_AUTOCONF_VER= 259
+LIB_DEPENDS+= prelude.1:${PORTSDIR}/security/libprelude
+CONFIGURE_ARGS+= --with-prelude=yes
+PLIST_SUB+= PRELUDE=""
+
+pre-configure:
+ cd ${WRKSRC} && ${ACLOCAL} && ${AUTOMAKE} && ${AUTOCONF}
+ ${RM} ${WRKSRC}/doc/README.Prelude.orig
+.else
+CONFIGURE_ARGS+= --with-prelude=no
+PLIST_SUB+= PRELUDE="@comment "
+.endif
+
post-patch:
${REINPLACE_CMD} "s,%%PREFIX%%,${PREFIX}," ${WRKSRC}/src/snort.c
@${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
@@ -91,6 +114,13 @@ post-install:
[ -f ${PREFIX}/etc/${f} ] || \
${INSTALL_DATA} ${WRKSRC}/etc/${f} ${PREFIX}/etc/${f}
.endfor
+.if defined(WITH_PRELUDE)
+.for f in prelude-classification.config
+ ${INSTALL_DATA} ${WRKSRC}/etc/${f} ${PREFIX}/etc/${f}-sample
+ [ -f ${PREFIX}/etc/${f} ] || \
+ ${INSTALL_DATA} ${WRKSRC}/etc/${f} ${PREFIX}/etc/${f}
+.endfor
+.endif
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}