aboutsummaryrefslogtreecommitdiffstats
path: root/security/snort
diff options
context:
space:
mode:
authorsergei <sergei@FreeBSD.org>2004-01-03 06:54:17 +0800
committersergei <sergei@FreeBSD.org>2004-01-03 06:54:17 +0800
commit780b60d68c5619ee17ef7a3aac4d86a0620a403f (patch)
tree69d602745f418348396facdcfd1568d1b67715ef /security/snort
parent70091562d22a8ba152ffff7e29e4470ac1fddb6f (diff)
downloadfreebsd-ports-gnome-780b60d68c5619ee17ef7a3aac4d86a0620a403f.tar.gz
freebsd-ports-gnome-780b60d68c5619ee17ef7a3aac4d86a0620a403f.tar.zst
freebsd-ports-gnome-780b60d68c5619ee17ef7a3aac4d86a0620a403f.zip
- Install missing config files: unicode.map and threshold.conf
(snort fails to run without them present in ${PREFIX}/etc) - Bump PORTREVISION Noticed by: Kirby Kuehl <kkuehl@cisco.com>
Diffstat (limited to 'security/snort')
-rw-r--r--security/snort/Makefile43
-rw-r--r--security/snort/distinfo1
-rw-r--r--security/snort/pkg-plist8
3 files changed, 28 insertions, 24 deletions
diff --git a/security/snort/Makefile b/security/snort/Makefile
index f880c9216efb..64d137170a45 100644
--- a/security/snort/Makefile
+++ b/security/snort/Makefile
@@ -7,7 +7,7 @@
PORTNAME= snort
PORTVERSION= 2.1.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= http://www.snort.org/dl/
@@ -16,6 +16,8 @@ COMMENT= Lightweight network intrusion detection system
LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
+#USE_GPG= yes
+#SIG_SUFFIX= .asc
USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= LDFLAGS="${LDFLAGS}"
@@ -68,31 +70,26 @@ pre-configure:
@${ECHO} ""
post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
-.endif
@${MKDIR} ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/rules/*.rules ${DATADIR}; \
+ ${INSTALL_DATA} ${WRKSRC}/rules/*.rules ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/etc/classification.config \
- ${DATADIR}/classification.config-sample; \
- if [ ! -f ${DATADIR}/classification.config ]; then \
+ ${DATADIR}/classification.config-sample
+ [ -f ${DATADIR}/classification.config ] || \
${CP} ${DATADIR}/classification.config-sample \
- ${DATADIR}/classification.config; \
- fi; \
+ ${DATADIR}/classification.config
${INSTALL_DATA} ${WRKSRC}/etc/reference.config \
- ${DATADIR}/reference.config-sample; \
- if [ ! -f ${DATADIR}/reference.config ]; then \
- ${CP} ${DATADIR}/reference.config-sample \
- ${DATADIR}/reference.config; \
- fi; \
- ${INSTALL_DATA} ${FILESDIR}/snort.sh.sample \
- ${PREFIX}/etc/rc.d/snort.sh.sample; \
- ${INSTALL_DATA} ${WRKSRC}/etc/snort.conf \
- ${PREFIX}/etc/snort.conf-sample; \
- if [ ! -f ${PREFIX}/etc/snort.conf ]; then \
- ${CP} ${PREFIX}/etc/snort.conf-sample \
- ${PREFIX}/etc/snort.conf; \
- fi
+ ${DATADIR}/reference.config-sample
+ [ -f ${DATADIR}/reference.config ] || \
+ ${CP} ${DATADIR}/reference.config-sample ${DATADIR}/reference.config
+ ${INSTALL_DATA} ${FILESDIR}/snort.sh.sample ${PREFIX}/etc/rc.d
+.for f in snort.conf unicode.map threshold.conf
+ ${INSTALL_DATA} ${WRKSRC}/etc/${f} ${PREFIX}/etc/${f}-sample
+ [ -f ${PREFIX}/etc/${f} ] || \
+ ${INSTALL_DATA} ${WRKSRC}/etc/${f} ${PREFIX}/etc/${f}
+.endfor
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+.endif
.include <bsd.port.mk>
diff --git a/security/snort/distinfo b/security/snort/distinfo
index 3593002f1eed..da96eaba93f0 100644
--- a/security/snort/distinfo
+++ b/security/snort/distinfo
@@ -1 +1,2 @@
MD5 (snort-2.1.0.tar.gz) = 1da6d683d18b39a72a3c277e8deffc69
+MD5 (snort-2.1.0.tar.gz.asc) = ee10580ac52066bec04b7f8948ef5ecc
diff --git a/security/snort/pkg-plist b/security/snort/pkg-plist
index c51cca90bb3c..375c1c8825be 100644
--- a/security/snort/pkg-plist
+++ b/security/snort/pkg-plist
@@ -2,8 +2,14 @@
bin/snort
@unexec if [ -f %D/etc/snort.conf ] && cmp -s %D/etc/snort.conf %D/etc/snort.conf-sample; then rm -f %D/etc/snort.conf; fi
etc/snort.conf-sample
-etc/rc.d/snort.sh.sample
@exec [ -f %B/snort.conf ] || cp %B/%f %B/snort.conf
+@unexec if [ -f %D/etc/unicode.map ] && cmp -s %D/etc/unicode.map %D/etc/unicode.map-sample; then rm -f %D/etc/unicode.map; fi
+etc/unicode.map-sample
+@exec [ -f %B/unicode.map ] || cp %B/%f %B/unicode.map
+@unexec if [ -f %D/etc/threshold.conf ] && cmp -s %D/etc/threshold.conf %D/etc/threshold.conf-sample; then rm -f %D/etc/threshold.conf; fi
+etc/threshold.conf-sample
+@exec [ -f %B/threshold.conf ] || cp %B/%f %B/threshold.conf
+etc/rc.d/snort.sh.sample
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/BUGS
%%PORTDOCS%%%%DOCSDIR%%/CREDITS