aboutsummaryrefslogtreecommitdiffstats
path: root/security/squidclam/Makefile
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2005-07-21 01:43:59 +0800
committergarga <garga@FreeBSD.org>2005-07-21 01:43:59 +0800
commita7a6bdf6549aff102a11378c19d1df63e1bc45c2 (patch)
tree15b7abf07b44bd23232fd058bc509a3113a3ab12 /security/squidclam/Makefile
parent7e373194ab57d65697a23638919d34c1c1fb54fc (diff)
downloadfreebsd-ports-gnome-a7a6bdf6549aff102a11378c19d1df63e1bc45c2.tar.gz
freebsd-ports-gnome-a7a6bdf6549aff102a11378c19d1df63e1bc45c2.tar.zst
freebsd-ports-gnome-a7a6bdf6549aff102a11378c19d1df63e1bc45c2.zip
Bridge betwean ClamAV antivirus software and Squid caching proxy.
Squidclam is a replacement for SquidClamAV-Redirector.py written in C using libclamav and libcurl Author: squidclam@users.sourceforge.net WWW: http://sourceforge.net/projects/squidclam/ PR: ports/82652 Submitted by: Alexander Novitsky <alecn2002@yandex.ru> Approved by: flz (mentor)
Diffstat (limited to 'security/squidclam/Makefile')
-rw-r--r--security/squidclam/Makefile53
1 files changed, 53 insertions, 0 deletions
diff --git a/security/squidclam/Makefile b/security/squidclam/Makefile
new file mode 100644
index 000000000000..d1af0b3345b7
--- /dev/null
+++ b/security/squidclam/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: squidclam
+# Date created: 2005-06-26
+# Whom: Alexander Novitsky <alecn2002@yandex.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= squidclam
+PORTVERSION= 0.11
+CATEGORIES= security
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= alecn2002@yandex.ru
+COMMENT= Bridge betwean ClamAV antivirus software and Squid caching proxy
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/clamscan:${PORTSDIR}/security/clamav \
+ ${LOCALBASE}/bin/curl:${PORTSDIR}/ftp/curl
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+NO_INSTALL_MANPAGES= yes
+
+PORTDOCS= README Changelog
+
+SUB_FILES= pkg-message
+
+PLIST_FILES= bin/squidclam %%EXAMPLESDIR%%/squidclam.conf
+PLIST_DIRS= %%EXAMPLESDIR%%
+
+.include <bsd.port.pre.mk>
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
+ -e 's|%%PREFIX%%|${PREFIX}|g' \
+ ${WRKSRC}/configure
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/$f ${DOCSDIR}/$f
+.endfor
+.endif
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/sample.conf ${EXAMPLESDIR}/${PORTNAME}.conf
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>