aboutsummaryrefslogtreecommitdiffstats
path: root/security/ssh2/Makefile
diff options
context:
space:
mode:
authorpeter <peter@FreeBSD.org>1997-04-25 13:01:06 +0800
committerpeter <peter@FreeBSD.org>1997-04-25 13:01:06 +0800
commit41086c704391ae15bfb78fb30d1187f0c1433342 (patch)
tree9f56711a06d44fe6024fffc541b1303cb43f613f /security/ssh2/Makefile
parent49cc230a234daf65f3662bcc80bf1d951e338e8a (diff)
downloadfreebsd-ports-gnome-41086c704391ae15bfb78fb30d1187f0c1433342.tar.gz
freebsd-ports-gnome-41086c704391ae15bfb78fb30d1187f0c1433342.tar.zst
freebsd-ports-gnome-41086c704391ae15bfb78fb30d1187f0c1433342.zip
Update from ssh-1.2.19 to ssh-1.2.20. All patches applied still, I just
regenerated them to fix the line numbers. Also, I added two commented out options in Makefile, one to tell sshd that a group writeable homedir is OK because all users are in their own group, and the other is to allow an unencrypted connection (which is dangerous since it can lead to compromise of keys), but on a secure network it's damn useful for backups etc.
Diffstat (limited to 'security/ssh2/Makefile')
-rw-r--r--security/ssh2/Makefile17
1 files changed, 13 insertions, 4 deletions
diff --git a/security/ssh2/Makefile b/security/ssh2/Makefile
index f06d971948e9..d00ccc3401ba 100644
--- a/security/ssh2/Makefile
+++ b/security/ssh2/Makefile
@@ -1,16 +1,16 @@
# New ports collection makefile for: ssh
-# Version required: 1.2.19
+# Version required: 1.2.20
# Date created: 30 Jul 1995
# Whom: torstenb@FreeBSD.ORG
#
-# $Id: Makefile,v 1.38 1997/04/16 19:48:09 ache Exp $
+# $Id: Makefile,v 1.39 1997/04/20 13:53:01 wosch Exp $
#
# Maximal ssh package requires YES values for
# USE_PERL, USE_TCPWRAP
#
-DISTNAME= ssh-1.2.19
-CATEGORIES= security net perl5
+DISTNAME= ssh-1.2.20
+CATEGORIES= security net
MASTER_SITES= ftp://ftp.funet.fi/pub/unix/security/login/ssh/
MAINTAINER= torstenb@FreeBSD.ORG
@@ -35,6 +35,15 @@ GNU_CONFIGURE= YES
CONFIGURE_ARGS= --prefix=${PREFIX} --with-etcdir=${PREFIX}/etc
+#Uncomment if all your users are in their own group and their homedir
+#is writeable by that group. Beware the security implications!
+#CONFIGURE_ARGS+= --enable-group-writeability
+
+#Uncomment if you want to allow ssh to emulate an unencrypted rsh connection
+#over a secure medium. This is normally dangerous since it can lead to the
+#disclosure keys and passwords.
+#CONFIGURE_ARGS+= --with-none
+
.if defined(USA_RESIDENT) && ${USA_RESIDENT} == YES
CONFIGURE_ARGS+= --with-rsaref
.endif