aboutsummaryrefslogtreecommitdiffstats
path: root/security/ssh2/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2003-01-03 03:35:26 +0800
committerijliao <ijliao@FreeBSD.org>2003-01-03 03:35:26 +0800
commit5639d19272dfcb850e72b878432bd085a6ca7226 (patch)
tree68c958bf87692dce783da06c3ac5e7363d1433cb /security/ssh2/Makefile
parente5e2bd3ae519b4828d8be295d9342a9d0030804a (diff)
downloadfreebsd-ports-gnome-5639d19272dfcb850e72b878432bd085a6ca7226.tar.gz
freebsd-ports-gnome-5639d19272dfcb850e72b878432bd085a6ca7226.tar.zst
freebsd-ports-gnome-5639d19272dfcb850e72b878432bd085a6ca7226.zip
1.) If WITH_STATIC_SFTP is defined, ssh-chrootmgr works.
2.) If libX11.a exists and xauth not, the build of ssh2 fails. This patch fix this. 3.) ssh2/files/sshd.sh looks for the wrong pid file in /var/run. This patch fix this and adds 2> /dev/null to the sshd2 startup PR: 46012 Submitted by: maintainer
Diffstat (limited to 'security/ssh2/Makefile')
-rw-r--r--security/ssh2/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/security/ssh2/Makefile b/security/ssh2/Makefile
index d1dfe1689841..1af0638877fd 100644
--- a/security/ssh2/Makefile
+++ b/security/ssh2/Makefile
@@ -52,8 +52,14 @@ LIB_DEPENDS+= wrap.7:${PORTSDIR}/security/tcp_wrapper
.include <bsd.port.pre.mk>
+# This is necessary for a working ssh-chrootmgr. Added by mic@nethack.at
+#
+.if defined(WITH_STATIC_SFTP)
+CONFIGURE_ARGS+= --enable-static
+.endif
+
.if defined(WITH_X11) || (exists(${X11BASE}/lib/libX11.a) \
- && !defined(WITHOUT_X11))
+ && exists(${X11BASE}/bin/xauth) && !defined(WITHOUT_X11))
USE_XLIB= yes
PLIST_SUB= WITH_X11:=""
.else