aboutsummaryrefslogtreecommitdiffstats
path: root/security/ssh2/Makefile
diff options
context:
space:
mode:
authorpeter <peter@FreeBSD.org>1996-06-07 12:33:33 +0800
committerpeter <peter@FreeBSD.org>1996-06-07 12:33:33 +0800
commit60b44caac41ea5acae1fd8505f3159c0177c6940 (patch)
treecd035fbf68f49db5625a970bde1bcc3df56f90e2 /security/ssh2/Makefile
parentb68d37540ab94d36b35ca580f5f8219e9cb43c4f (diff)
downloadfreebsd-ports-gnome-60b44caac41ea5acae1fd8505f3159c0177c6940.tar.gz
freebsd-ports-gnome-60b44caac41ea5acae1fd8505f3159c0177c6940.tar.zst
freebsd-ports-gnome-60b44caac41ea5acae1fd8505f3159c0177c6940.zip
Update ssh-1.2.13 -> ssh-1.2.14
ssh-askpass no longer uses wish, so chop the make rules that attempt to locate it. Go further to try and protect the ssh_host_key, since it's critical to the operation and security of the machine.
Diffstat (limited to 'security/ssh2/Makefile')
-rw-r--r--security/ssh2/Makefile34
1 files changed, 11 insertions, 23 deletions
diff --git a/security/ssh2/Makefile b/security/ssh2/Makefile
index 6ec2039338ff..87f3c8ee2485 100644
--- a/security/ssh2/Makefile
+++ b/security/ssh2/Makefile
@@ -1,21 +1,23 @@
# New ports collection makefile for: ssh
-# Version required: 1.2.13
+# Version required: 1.2.14
# Date created: 30 Jul 1995
# Whom: torstenb@FreeBSD.ORG
#
-# $Id: Makefile,v 1.21 1996/04/17 01:07:04 asami Exp $
+# $Id: Makefile,v 1.22 1996/05/24 19:13:04 peter Exp $
#
# Maximal ssh package requires YES values for
-# USE_PERL, USE_WISH, USE_TCPWRAP
+# USE_PERL, USE_TCPWRAP
#
-DISTNAME= ssh-1.2.13
+DISTNAME= ssh-1.2.14
CATEGORIES= security net
-MASTER_SITES= ftp://ftp.cs.hut.fi/pub/ssh/snapshots/
+MASTER_SITES= ftp://ftp.cs.hut.fi/pub/ssh/
LIB_DEPENDS= z\\.1\\.:${PORTSDIR}/devel/libz
MAINTAINER= torstenb@FreeBSD.ORG
+# You can set USA_RESIDENT appropriately in /etc/make.conf if this bugs you..
+
.if defined(USA_RESIDENT) && ${USA_RESIDENT} == YES
DISTFILES= ${DISTNAME}.tar.gz rsaref2.tar.gz
MASTER_SITES= \
@@ -84,29 +86,15 @@ post-install:
${PREFIX}/man/man1/ssh-agent.1 ${PREFIX}/man/man1/ssh-keygen.1 \
${PREFIX}/man/man1/ssh.1 ${PREFIX}/man/man8/sshd.8 \
${PREFIX}/man/man1/make-ssh-known-hosts.1
+ @echo "---------------------------------------------------------------"
+ @echo "If you are installing for the first time, do not forget to run:"
+ @echo " ssh-keygen -b 1024 -f $(PREFIX)/etc/ssh_host_key -N '' "
+ @echo "---------------------------------------------------------------"
.include <bsd.port.mk>
# Following stuff must be after <bsd.port.mk> to expand exists() properly
-.if defined(USE_WISH) && ${USE_WISH} == YES || \
- (exists(${PREFIX}/bin/wish4.0) || exists(${PREFIX}/bin/wish4.1) || \
- exists(${PREFIX}/bin/wish)) && \
- (!defined(USE_WISH) || ${USE_WISH} != NO)
-.if exists(${PREFIX}/bin/wish4.1)
-BUILD_DEPENDS+= wish4.1:${PORTSDIR}/x11/tk41
-CONFIGURE_ENV+= WISH=${PREFIX}/bin/wish4.1
-.elif exists(${PREFIX}/bin/wish4.0)
-BUILD_DEPENDS+= wish4.0:${PORTSDIR}/x11/tk4
-CONFIGURE_ENV+= WISH=${PREFIX}/bin/wish4.0
-.else
-BUILD_DEPENDS+= wish:${PORTSDIR}/x11/tk
-CONFIGURE_ENV+= WISH=${PREFIX}/bin/wish
-.endif
-.else
-CONFIGURE_ENV+= WISH=/replace_it_with_WISH_path
-.endif
-
.if defined(USE_PERL) && ${USE_PERL} == YES || \
exists(${PREFIX}/bin/perl5.002) && \
(!defined(USE_PERL) || ${USE_PERL} != NO)