aboutsummaryrefslogtreecommitdiffstats
path: root/security/ssh2
diff options
context:
space:
mode:
authorpeter <peter@FreeBSD.org>1996-08-08 21:57:02 +0800
committerpeter <peter@FreeBSD.org>1996-08-08 21:57:02 +0800
commit08ab0626d58aeec4f55817723556d1c52d065600 (patch)
treee2931f6f194efd2cd86a8c38c0ac6616196981b8 /security/ssh2
parent78bef7ab7dcd3be8147b27f016d9b701b6026957 (diff)
downloadfreebsd-ports-gnome-08ab0626d58aeec4f55817723556d1c52d065600.tar.gz
freebsd-ports-gnome-08ab0626d58aeec4f55817723556d1c52d065600.tar.zst
freebsd-ports-gnome-08ab0626d58aeec4f55817723556d1c52d065600.zip
Several fixes/improvements :-
- protect the secret RSA etc/ssh_host_key. It is now generated on install (either by pkg_add or make install) if not already present and is not ever added to a package since it's your host's credentials. It should not be removed on pkg_delete, since you are in big trouble if you did this (for example) pkg_delete ssh-1.2.14; pkg_add ssh-1.2.15.tgz. - fix the broken manpage symlink when compressing man pages (slogin.1 has been causing /etc/weekly to generate cron messages) - zlib 1.0.4 is now "blessed" again, the ssh working sources now use this instead of v0.95. The decompression problem was fixed in either 1.0.3 or 1.0.4. Also, the current version of cvs uses zlib 1.0.4 as well.. - perl5.002 -> perl5.003 Reviewed by: torstenb
Diffstat (limited to 'security/ssh2')
-rw-r--r--security/ssh2/Makefile17
-rw-r--r--security/ssh2/pkg-plist2
2 files changed, 14 insertions, 5 deletions
diff --git a/security/ssh2/Makefile b/security/ssh2/Makefile
index d808f3964261..8a8202a42d5a 100644
--- a/security/ssh2/Makefile
+++ b/security/ssh2/Makefile
@@ -3,7 +3,7 @@
# Date created: 30 Jul 1995
# Whom: torstenb@FreeBSD.ORG
#
-# $Id: Makefile,v 1.30 1996/07/18 11:33:37 torstenb Exp $
+# $Id: Makefile,v 1.31 1996/07/22 23:06:08 pst Exp $
#
# Maximal ssh package requires YES values for
# USE_PERL, USE_TCPWRAP
@@ -12,6 +12,7 @@
DISTNAME= ssh-1.2.14
CATEGORIES= security net
MASTER_SITES= ftp://ftp.cs.hut.fi/pub/ssh/
+LIB_DEPENDS= z\\.1\\.:${PORTSDIR}/devel/libz
MAINTAINER= torstenb@FreeBSD.ORG
@@ -75,10 +76,18 @@ post-extract:
.endif
post-install:
+ @if [ ! -f ${PREFIX}/etc/ssh_host_key ]; then \
+ echo "Generating a secret host key..."; \
+ ${PREFIX}/bin/ssh-keygen -f ${PREFIX}/etc/ssh_host_key -N ""; \
+ fi
+.if !defined(NOMANCOMPRESS)
gzip -9nf ${PREFIX}/man/man1/scp.1 ${PREFIX}/man/man1/ssh-add.1 \
${PREFIX}/man/man1/ssh-agent.1 ${PREFIX}/man/man1/ssh-keygen.1 \
${PREFIX}/man/man1/ssh.1 ${PREFIX}/man/man8/sshd.8 \
${PREFIX}/man/man1/make-ssh-known-hosts.1
+ rm -f ${PREFIX}/man/man1/slogin.1
+ ln -sf ssh.1.gz ${PREFIX}/man/man1/slogin.1.gz
+.endif
@if [ ! -f ${PREFIX}/etc/rc.d/sshd.sh ]; then \
echo "Installing ${PREFIX}/etc/rc.d/sshd.sh startup file."; \
echo "#!/bin/sh" > ${PREFIX}/etc/rc.d/sshd.sh; \
@@ -91,10 +100,10 @@ post-install:
# Following stuff must be after <bsd.port.mk> to expand exists() properly
.if defined(USE_PERL) && ${USE_PERL} == YES || \
- exists(${PREFIX}/bin/perl5.002) && \
+ exists(${PREFIX}/bin/perl5.003) && \
(!defined(USE_PERL) || ${USE_PERL} != NO)
-BUILD_DEPENDS+= perl5.002:${PORTSDIR}/lang/perl5
-CONFIGURE_ENV+= PERL=${PREFIX}/bin/perl5.002
+BUILD_DEPENDS+= perl5.003:${PORTSDIR}/lang/perl5
+CONFIGURE_ENV+= PERL=${PREFIX}/bin/perl5.003
.else
CONFIGURE_ENV+= PERL=/replace_it_with_PERL_path
.endif
diff --git a/security/ssh2/pkg-plist b/security/ssh2/pkg-plist
index 5cf40f2c48f4..55844f393eeb 100644
--- a/security/ssh2/pkg-plist
+++ b/security/ssh2/pkg-plist
@@ -1,5 +1,4 @@
etc/rc.d/sshd.sh
-@unexec rm %D/etc/rc.d/sshd.sh
bin/scp
bin/slogin
bin/ssh
@@ -18,3 +17,4 @@ man/man1/ssh-keygen.1.gz
man/man1/ssh.1.gz
man/man8/sshd.8.gz
sbin/sshd
+@exec if [ ! -f %D/etc/ssh_host_key ]; then echo "Generating a secret host key.." ; %D/bin/ssh-keygen -N "" -f %D/etc/ssh_host_key; fi