aboutsummaryrefslogtreecommitdiffstats
path: root/security/ssh2
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1998-09-16 05:31:59 +0800
committerasami <asami@FreeBSD.org>1998-09-16 05:31:59 +0800
commite755ee1d47f4b0d9d4c8bd2a570d38555b88b607 (patch)
treef20c20390d0ae9c598fdaa1136e89fc9e48469ec /security/ssh2
parent60e211928723f70362d166bab5f76cadf2b57c7f (diff)
downloadfreebsd-ports-gnome-e755ee1d47f4b0d9d4c8bd2a570d38555b88b607.tar.gz
freebsd-ports-gnome-e755ee1d47f4b0d9d4c8bd2a570d38555b88b607.tar.zst
freebsd-ports-gnome-e755ee1d47f4b0d9d4c8bd2a570d38555b88b607.zip
Use ${PERL5} wherever appropriate. Largely untested; hope my eyeball
checks haven't missed anything. Submitted by: dima
Diffstat (limited to 'security/ssh2')
-rw-r--r--security/ssh2/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/security/ssh2/Makefile b/security/ssh2/Makefile
index d13628771ddb..9ea8172591cb 100644
--- a/security/ssh2/Makefile
+++ b/security/ssh2/Makefile
@@ -3,7 +3,7 @@
# Date created: 30 Jul 1995
# Whom: torstenb@FreeBSD.ORG
#
-# $Id: Makefile,v 1.61 1998/08/17 12:12:34 vanilla Exp $
+# $Id: Makefile,v 1.62 1998/08/19 19:51:10 hoek Exp $
#
# Maximal ssh package requires YES values for
# USE_PERL, USE_TCPWRAP
@@ -134,10 +134,9 @@ post-install:
# Following stuff must be after <bsd.port.mk> to expand exists() properly
.if defined(USE_PERL) && ${USE_PERL} == YES || \
- exists(${PREFIX}/bin/perl${PERL_VERSION}) && \
- (!defined(USE_PERL) || ${USE_PERL} != NO)
+ exists(${PERL5}) && (!defined(USE_PERL) || ${USE_PERL} != NO)
BUILD_DEPENDS+= perl${PERL_VERSION}:${PORTSDIR}/lang/perl5
-CONFIGURE_ENV+= PERL=${PREFIX}/bin/perl${PERL_VERSION}
+CONFIGURE_ENV+= PERL=${PERL5}
.else
CONFIGURE_ENV+= PERL=/replace_it_with_PERL_path
.endif