aboutsummaryrefslogtreecommitdiffstats
path: root/security/ssh2
diff options
context:
space:
mode:
authorache <ache@FreeBSD.org>1996-01-25 10:08:25 +0800
committerache <ache@FreeBSD.org>1996-01-25 10:08:25 +0800
commit91f4e76e575b3264a474bec39c00711088897387 (patch)
tree078d5b7b6e7496afd1cfa1bd128ffc5b1b381460 /security/ssh2
parent7a28853eea231ee1beebe0cf6476867879d4d690 (diff)
downloadfreebsd-ports-gnome-91f4e76e575b3264a474bec39c00711088897387.tar.gz
freebsd-ports-gnome-91f4e76e575b3264a474bec39c00711088897387.tar.zst
freebsd-ports-gnome-91f4e76e575b3264a474bec39c00711088897387.zip
Autopick any wish present even wish4.0
Autopick libwrap.a
Diffstat (limited to 'security/ssh2')
-rw-r--r--security/ssh2/Makefile32
1 files changed, 23 insertions, 9 deletions
diff --git a/security/ssh2/Makefile b/security/ssh2/Makefile
index 025e3ae8c82c..96f2cf7da421 100644
--- a/security/ssh2/Makefile
+++ b/security/ssh2/Makefile
@@ -3,14 +3,13 @@
# Date created: 30 Jul 1995
# Whom: torstenb@FreeBSD.ORG
#
-# $Id: Makefile,v 1.9 1996/01/21 00:49:39 ache Exp $
+# $Id: Makefile,v 1.10 1996/01/22 18:41:57 markm Exp $
#
DISTNAME= ssh-1.2.12a
CATEGORIES= security net
MASTER_SITES= ftp://ftp.cs.hut.fi/pub/ssh/snapshots/
LIB_DEPENDS= z\\.0\\.:${PORTSDIR}/devel/libz
-BUILD_DEPENDS+= wish:${PORTSDIR}/x11/tk
BUILD_DEPENDS+= perl5.001:${PORTSDIR}/lang/perl5
MAINTAINER= torstenb@FreeBSD.ORG
@@ -43,13 +42,6 @@ CONFIGURE_ARGS+= --with-rsaref
CONFIGURE_ARGS+= --with-socks
.endif
-# Include tcp-wrapper support (call remote identd)
-.if defined(USE_TCPWRAP) && ${USE_TCPWRAP} == YES
-CONFIGURE_ENV= LDFLAGS=-L${PREFIX}/lib CFLAGS="${CFLAGS} -I${PREFIX}/include"
-BUILD_DEPENDS+= safe_finger:${PORTSDIR}/security/tcp_wrapper
-CONFIGURE_ARGS+= --with-libwrap
-.endif
-
# Include support for the SecureID card
# Warning: untested !
.if defined(USE_SECUREID) && ${USE_SECUREID} == YES
@@ -92,3 +84,25 @@ post-install:
${PREFIX}/man/man1/make-ssh-known-hosts.1
.include <bsd.port.mk>
+
+# Following stuff must be after <bsd.port.mk> to expand exists() properly
+
+.if exists(${X11BASE}/bin/xauth)
+.if exists(${PREFIX}/bin/wish4.0)
+BUILD_DEPENDS+= wish4.0:${PORTSDIR}/x11/tk4
+CONFIGURE_ENV+= WISH=${PREFIX}/bin/wish4.0
+.else
+BUILD_DEPENDS+= wish:${PORTSDIR}/x11/tk
+.endif
+.else
+CONFIGURE_ENV+= WISH=/replace_it_with_WISH_path
+.endif
+
+# Include tcp-wrapper support (call remote identd)
+.if defined(USE_TCPWRAP) && ${USE_TCPWRAP} == YES || \
+ exists(${PREFIX}/lib/libwrap.a) && \
+ (!defined(USE_TCPWRAP) || ${USE_TCPWRAP} != NO)
+BUILD_DEPENDS+= ${PREFIX}/lib/libwrap.a:${PORTSDIR}/security/tcp_wrapper
+CONFIGURE_ARGS+= --with-libwrap
+.endif
+