aboutsummaryrefslogtreecommitdiffstats
path: root/security/sst/files
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2000-12-31 18:37:43 +0800
committerwill <will@FreeBSD.org>2000-12-31 18:37:43 +0800
commitd625062cbd992240127b12c3aca9426a1db0f7bc (patch)
treed292737e7f304fb31ea868b8512de25e87f73dc5 /security/sst/files
parent2d89e2c79e3a3d756bd4b907f79e5c56c342fa38 (diff)
downloadfreebsd-ports-gnome-d625062cbd992240127b12c3aca9426a1db0f7bc.tar.gz
freebsd-ports-gnome-d625062cbd992240127b12c3aca9426a1db0f7bc.tar.zst
freebsd-ports-gnome-d625062cbd992240127b12c3aca9426a1db0f7bc.zip
Add sst 1.0, a simple SSL tunneling tool that uses netcat.
PR: 22671 Submitted by: Mikhail Teterin <mi@aldan.algebra.com>
Diffstat (limited to 'security/sst/files')
-rw-r--r--security/sst/files/Makefile13
-rw-r--r--security/sst/files/patch-sst.c24
2 files changed, 37 insertions, 0 deletions
diff --git a/security/sst/files/Makefile b/security/sst/files/Makefile
new file mode 100644
index 000000000000..be39899e366f
--- /dev/null
+++ b/security/sst/files/Makefile
@@ -0,0 +1,13 @@
+# $FreeBSD$
+
+PROG=sst
+
+BINDIR=${PREFIX}/sbin
+MANDIR=${PREFIX}/man/man
+
+CFLAGS+= -DCONFDIR='"${OPENSSLDIR}"' -DCERTF='"certs/sst.pem"' \
+ -DNETCAT='"${PREFIX}/bin/nc"' -I${OPENSSLINC}
+
+LDADD+= -L${OPENSSLLIB} -lssl -lcrypto
+
+.include <bsd.prog.mk>
diff --git a/security/sst/files/patch-sst.c b/security/sst/files/patch-sst.c
new file mode 100644
index 000000000000..c42f282ca577
--- /dev/null
+++ b/security/sst/files/patch-sst.c
@@ -0,0 +1,24 @@
+--- sst.c Thu May 4 14:47:28 2000
++++ sst.c.new Sun Dec 31 04:49:43 2000
+@@ -609,8 +609,8 @@
+ SHOW_info1("client cert subject: %s", subj);
+ SHOW_info1("client cert issuer: %s", issu);
+
+- Free(subj);
+- Free(issu);
++ free(subj);
++ free(issu);
+
+ /*
+ * XXX ...
+@@ -699,8 +699,8 @@
+ SHOW_info1("server cert subject: %s", subj);
+ SHOW_info1("server cert issuer: %s", issu);
+
+- Free(subj);
+- Free(issu);
++ free(subj);
++ free(issu);
+
+ /*
+ * XXX ...