aboutsummaryrefslogtreecommitdiffstats
path: root/security/stunnel/Makefile
diff options
context:
space:
mode:
authorroam <roam@FreeBSD.org>2002-09-20 17:29:11 +0800
committerroam <roam@FreeBSD.org>2002-09-20 17:29:11 +0800
commite502aa642e6439b704f87ccda70ed4243e975ce9 (patch)
tree1bded807ebf0386437121307a17d7af2f93db1e1 /security/stunnel/Makefile
parent234c622424b37f70b2402bf42a8a378e5ef19658 (diff)
downloadfreebsd-ports-gnome-e502aa642e6439b704f87ccda70ed4243e975ce9.tar.gz
freebsd-ports-gnome-e502aa642e6439b704f87ccda70ed4243e975ce9.tar.zst
freebsd-ports-gnome-e502aa642e6439b704f87ccda70ed4243e975ce9.zip
Update to stunnel-4.00.
*** WARNING WARNING WARNING *** The stunnel invocation has changed! The program no longer accepts command-line options, but is controlled by a config file instead. Please refer to the stunnel(8) manual page for more information. PR: 42249 Submitted by: Dan Langille <dan@langille.org>, lioux
Diffstat (limited to 'security/stunnel/Makefile')
-rw-r--r--security/stunnel/Makefile23
1 files changed, 20 insertions, 3 deletions
diff --git a/security/stunnel/Makefile b/security/stunnel/Makefile
index e8cc4f97721d..df0b8be5ecd7 100644
--- a/security/stunnel/Makefile
+++ b/security/stunnel/Makefile
@@ -6,28 +6,45 @@
#
PORTNAME= stunnel
-PORTVERSION= 3.22
+PORTVERSION= 4.00
CATEGORIES= security
MASTER_SITES= http://www.stunnel.org/download/stunnel/src/ \
ftp://stunnel.mirt.net/stunnel/ \
ftp://opensores.thebunker.net/pub/mirrors/stunnel/ \
ftp://ftp.cryptoarchive.net/pub/cryptoarchive/mirrors/opensores.thebunker.net/pub/mirrors/stunnel/
-MAINTAINER= roam@freebsd.org
+MAINTAINER= roam@FreeBSD.org
USE_OPENSSL= YES
+USE_REINPLACE= YES
+IS_INTERACTIVE= YES # prompts for information while generating certificate
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --localstatedir=/var/run --with-pem-dir=${PEM_DIR}
+CONFIGURE_ARGS= --localstatedir=/var/tmp --with-pem-dir=${PEM_DIR}
MAN8= stunnel.8
PEM_DIR?= ${PREFIX}/etc
+post-patch:
+# place files under /var/tmp so that this can be run by an unprivileged user
+# user stunnel and group stunnel
+ @${REINPLACE_CMD} -E -e 's|\@prefix\@/var/run/stunnel/|/var/tmp/stunnel|; \
+ s|nobody|stunnel|;s|nogroup|stunnel|' \
+ ${WRKSRC}/tools/stunnel.conf-sample.in
+ @${REINPLACE_CMD} -E -e 's|localstatedir/run/stunnel.pid|localstatedir/stunnel.pid|' \
+ ${WRKSRC}/configure.ac ${WRKSRC}/configure
+.ifdef(NOPORTDOCS)
+ @${REINPLACE_CMD} -E -e 's/ install-docDATA/ /; s/^(SUBDIRS.+)doc/\1/' \
+ ${WRKSRC}/Makefile.in
+.endif
+
post-install:
@${SED} "s+!!PREFIX!!+${PREFIX}+g" < ${FILESDIR}/stunnel.sh \
> ${PREFIX}/etc/rc.d/stunnel.sh.sample
@${CHMOD} 755 ${PREFIX}/etc/rc.d/stunnel.sh.sample
+ @${SETENV} PKG_PREFIX=${PREFIX} ${SH} \
+ ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${ECHO} ""
@${ECHO} "**************************************************************************"
@${ECHO} "To create and install a new certificate, type \"make cert\""