aboutsummaryrefslogtreecommitdiffstats
path: root/security/stunnel/Makefile
diff options
context:
space:
mode:
authorroam <roam@FreeBSD.org>2004-09-02 23:46:15 +0800
committerroam <roam@FreeBSD.org>2004-09-02 23:46:15 +0800
commitcdca321745a1c2cf449607cb178b46282b7ab822 (patch)
treece7be18f3eb5a9f58782a3c4de894bc824d144b2 /security/stunnel/Makefile
parent13988c988e105e954f80074fdd9ff0069aa19c4f (diff)
downloadfreebsd-ports-gnome-cdca321745a1c2cf449607cb178b46282b7ab822.tar.gz
freebsd-ports-gnome-cdca321745a1c2cf449607cb178b46282b7ab822.tar.zst
freebsd-ports-gnome-cdca321745a1c2cf449607cb178b46282b7ab822.zip
Fix the bus error on startup in -CURRENT and 5.x-BETA. It turns out
that the OpenSSL ENGINE code is, well, somewhat less than stellar, especially in combo with malloc's 'j' option. Even without it, though, there are some problems that I don't have time to look into right now. So, disable the OpenSSL ENGINE activation on FreeBSD 5.x, unless the WITH_STUNNEL_SSL_ENGINE knob is turned on. Also, while I'm here, fix the CONFIGURE_TARGET so the GNU configure script does not complain quite so loudly. Bump PORTREVISION for the functionality change (well, I guess you could say "not working" -> "working" is a functionality change ;)
Diffstat (limited to 'security/stunnel/Makefile')
-rw-r--r--security/stunnel/Makefile22
1 files changed, 21 insertions, 1 deletions
diff --git a/security/stunnel/Makefile b/security/stunnel/Makefile
index 5a8790755df7..0db9946c0da3 100644
--- a/security/stunnel/Makefile
+++ b/security/stunnel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= stunnel
PORTVERSION= 4.05
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://www.stunnel.org/download/stunnel/src/ \
ftp://stunnel.mirt.net/stunnel/OBSOLETE/ \
@@ -17,8 +18,10 @@ COMMENT= SSL encryption wrapper for standard network daemons
USE_OPENSSL= YES
USE_REINPLACE= YES
+USE_INC_LIBTOOL_VER= 13
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --localstatedir=/var/tmp --with-pem-dir=${PEM_DIR} \
--enable-static
@@ -68,7 +71,24 @@ cert:
.include <bsd.port.pre.mk>
.if ${OSVERSION} > 500000
-IGNORE= Bus error with OpenSSL in -CURRENT, under investigation
+.if !defined(WITH_STUNNEL_SSL_ENGINE)
+EXTRA_PATCHES= ${FILESDIR}/ssl-noengine.patch
+pre-patch:
+ @${ECHO} "*************************************************************************"
+ @${ECHO} "Note: you have to explicitly define WITH_STUNNEL_SSL_ENGINE to activate"
+ @${ECHO} "the OpenSSL ENGINE code on FreeBSD 5.x."
+ @${ECHO} "There are known reliability issues with stunnel and the OpenSSL ENGINE"
+ @${ECHO} "code, so you are advised not to enable it."
+ @${ECHO} "*************************************************************************"
+.else
+pre-patch:
+ @${ECHO} "*************************************************************************"
+ @${ECHO} "Note: you have defined WITH_STUNNEL_SSL_ENGINE. Now stunnel will activate"
+ @${ECHO} "the OpenSSL ENGINE code even on FreeBSD 5.x."
+ @${ECHO} "There are known reliability issues with stunnel and the OpenSSL ENGINE"
+ @${ECHO} "code. You have enabled it at your own risk."
+ @${ECHO} "*************************************************************************"
+.endif
.endif
.include <bsd.port.post.mk>