aboutsummaryrefslogtreecommitdiffstats
path: root/security/sudo
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2012-09-27 10:57:50 +0800
committerwxs <wxs@FreeBSD.org>2012-09-27 10:57:50 +0800
commitc1036d6080c1241a90bff90b33071c4925558150 (patch)
tree014fa8c04d898dfe050f07eb41fe8e2e42280461 /security/sudo
parent35bd4a38e78d734a634dc6e2058f2bfa7bf941f1 (diff)
downloadfreebsd-ports-gnome-c1036d6080c1241a90bff90b33071c4925558150.tar.gz
freebsd-ports-gnome-c1036d6080c1241a90bff90b33071c4925558150.tar.zst
freebsd-ports-gnome-c1036d6080c1241a90bff90b33071c4925558150.zip
Fix build on i386 by disabling hardening measures. This is a temporary
fix until I can figure out what is really going on.
Diffstat (limited to 'security/sudo')
-rw-r--r--security/sudo/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/security/sudo/Makefile b/security/sudo/Makefile
index 95bd1ca29491..fb4df6a664f6 100644
--- a/security/sudo/Makefile
+++ b/security/sudo/Makefile
@@ -20,7 +20,7 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
MAKE_JOBS_SAFE= yes
GNU_CONFIGURE= yes
-LDFLAGS+= -lgcc
+LDFLAGS+= -lgcc
CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
--with-ignore-dot \
@@ -99,6 +99,14 @@ CONFIGURE_ARGS+=--with-bsm-audit
CONFIGURE_ARGS+=--with-opie
.endif
+.include <bsd.port.pre.mk>
+
+# Temporary workaround until I can figure out why the build fails on i386.
+# You can add --stack-protector to LDFLAGS but that doesn't work with clang.
+.if ${ARCH} == "i386"
+CONFIGURE_ARGS+= --disable-hardening
+.endif
+
MAN5+= sudoers.5
MAN8= sudo.8 visudo.8 sudoreplay.8 sudo_plugin.8
MLINKS= sudo.8 sudoedit.8
@@ -126,4 +134,4 @@ post-install:
fi
${TOUCH} ${PREFIX}/etc/sudoers.d/.keep-me
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>