aboutsummaryrefslogtreecommitdiffstats
path: root/security/sudo
diff options
context:
space:
mode:
authormharo <mharo@FreeBSD.org>2004-08-20 14:49:35 +0800
committermharo <mharo@FreeBSD.org>2004-08-20 14:49:35 +0800
commitb6478a2a53b2a7a00019603b34703b18444b261d (patch)
treeb739ce02be7f38fe701d3e1c66e0f93d66df67b6 /security/sudo
parent4451d6d472a109bbc7ad15255a59133727ee9587 (diff)
downloadfreebsd-ports-gnome-b6478a2a53b2a7a00019603b34703b18444b261d.tar.gz
freebsd-ports-gnome-b6478a2a53b2a7a00019603b34703b18444b261d.tar.zst
freebsd-ports-gnome-b6478a2a53b2a7a00019603b34703b18444b261d.zip
Update to 1.6.8
Diffstat (limited to 'security/sudo')
-rw-r--r--security/sudo/Makefile8
-rw-r--r--security/sudo/distinfo4
-rw-r--r--security/sudo/files/patch-auth::pam.c16
-rw-r--r--security/sudo/pkg-plist2
4 files changed, 9 insertions, 21 deletions
diff --git a/security/sudo/Makefile b/security/sudo/Makefile
index 704266ac447b..0c13f7d1150e 100644
--- a/security/sudo/Makefile
+++ b/security/sudo/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= sudo
-PORTVERSION= 1.6.7.5
-PORTREVISION= 2
+PORTVERSION= 1.6.8
+PORTREVISION= 0
CATEGORIES= security
MASTER_SITES= http://www.sudo.ws/sudo/dist/ \
http://probsd.org/sudoftp/ \
@@ -19,7 +19,7 @@ MASTER_SITES= http://www.sudo.ws/sudo/dist/ \
http://pluto.cdpa.nsysu.edu.tw/sudo/ \
ftp://ftp.cs.colorado.edu/pub/sysadmin/sudo/ \
ftp://ftp.stikman.com/pub/sudo/
-DISTNAME= ${PORTNAME}-1.6.7p5
+DISTNAME= ${PORTNAME}-1.6.8
MAINTAINER= mharo@FreeBSD.org
COMMENT= Allow others to run commands as root
@@ -50,11 +50,13 @@ CONFIGURE_ARGS+=--enable-shell-sets-home
MAN5= sudoers.5
MAN8= sudo.8 visudo.8
+MLINKS= sudo.8 sudoedit.8
post-patch:
@${REINPLACE_CMD} -e 's|^|#|g' ${WRKSRC}/sample.sudoers
post-install:
${INSTALL_DATA} ${WRKSRC}/sample.sudoers ${PREFIX}/etc/sudoers.sample
+ ${RM} ${PREFIX}/libexec/sudo_noexec.la
.include <bsd.port.post.mk>
diff --git a/security/sudo/distinfo b/security/sudo/distinfo
index a9188fdbdb57..fc7a311e8a6d 100644
--- a/security/sudo/distinfo
+++ b/security/sudo/distinfo
@@ -1,2 +1,2 @@
-MD5 (sudo-1.6.7p5.tar.gz) = 55d503e5c35bf1ea83d38244e0242aaf
-SIZE (sudo-1.6.7p5.tar.gz) = 349785
+MD5 (sudo-1.6.8.tar.gz) = 94e0657c46e129cf6f1fe7ee313d6636
+SIZE (sudo-1.6.8.tar.gz) = 577564
diff --git a/security/sudo/files/patch-auth::pam.c b/security/sudo/files/patch-auth::pam.c
deleted file mode 100644
index bed7753f8257..000000000000
--- a/security/sudo/files/patch-auth::pam.c
+++ /dev/null
@@ -1,16 +0,0 @@
---- auth/pam.c.orig Wed Apr 2 11:55:50 2003
-+++ auth/pam.c Wed Apr 2 11:57:32 2003
-@@ -224,11 +224,11 @@
- p = pm->msg;
- /* Read the password. */
- pass = tgetpass(p, def_ival(I_PASSWD_TIMEOUT) * 60, flags);
-- pr->resp = estrdup(pass ? pass : "");
-+ pr->resp = estrdup((const char *)pass ? (const char *)pass : "");
- if (*pr->resp == '\0')
- nil_pw = 1; /* empty password */
- else
-- memset(pass, 0, strlen(pass));
-+ memset((void *)pass, 0, strlen((const char *)pass));
- break;
- case PAM_TEXT_INFO:
- if (pm->msg)
diff --git a/security/sudo/pkg-plist b/security/sudo/pkg-plist
index e4ca595b134b..aac447565035 100644
--- a/security/sudo/pkg-plist
+++ b/security/sudo/pkg-plist
@@ -1,4 +1,6 @@
@unexec if cmp -s %D/etc/sudoers %D/etc/sudoers.sample; then rm -f %D/etc/sudoers; fi
bin/sudo
+bin/sudoedit
etc/sudoers.sample
+libexec/sudo_noexec.so
sbin/visudo