aboutsummaryrefslogtreecommitdiffstats
path: root/security/sudo
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2011-04-10 09:39:49 +0800
committerwxs <wxs@FreeBSD.org>2011-04-10 09:39:49 +0800
commitb5b529da349f127d8b10baa51a686e4ebc97d2da (patch)
tree0ff799d4a29fa80527bebf650c80bc90b4bb1b71 /security/sudo
parentfd1385e6df693e2fa36808eecdf4a739e131eb73 (diff)
downloadfreebsd-ports-gnome-b5b529da349f127d8b10baa51a686e4ebc97d2da.tar.gz
freebsd-ports-gnome-b5b529da349f127d8b10baa51a686e4ebc97d2da.tar.zst
freebsd-ports-gnome-b5b529da349f127d8b10baa51a686e4ebc97d2da.zip
Update to 1.8.1. There are a lot of behind-the-scenes changes in this port,
including a plugin system now. While here, do some whitespace fixes.
Diffstat (limited to 'security/sudo')
-rw-r--r--security/sudo/Makefile32
-rw-r--r--security/sudo/distinfo4
-rw-r--r--security/sudo/files/patch-Makefile.in14
-rw-r--r--security/sudo/files/patch-plugins__sudoers__Makefile.in23
-rw-r--r--security/sudo/files/patch-plugins__sudoers__sudoers.in (renamed from security/sudo/files/patch-sudoers)8
-rw-r--r--security/sudo/pkg-plist5
6 files changed, 48 insertions, 38 deletions
diff --git a/security/sudo/Makefile b/security/sudo/Makefile
index 64b49c168826..af53c84249f4 100644
--- a/security/sudo/Makefile
+++ b/security/sudo/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= sudo
-PORTVERSION= 1.7.4.6
+PORTVERSION= 1.8.1
CATEGORIES= security
MASTER_SITES= http://www.sudo.ws/sudo/dist/ \
http://www.signal42.com/mirrors/sudo_ftp/ \
@@ -42,7 +42,7 @@ MASTER_SITES= http://www.sudo.ws/sudo/dist/ \
ftp://sunsite.icm.edu.pl/packages/sudo/ \
ftp://mirror.cdmon.com/pub/sudo/ \
ftp://ftp.twaren.net/Unix/Security/Sudo/
-DISTNAME= ${PORTNAME}-1.7.4p6
+DISTNAME= ${PORTNAME}-1.8.1
MAINTAINER= wxs@FreeBSD.org
COMMENT= Allow others to run commands as root
@@ -65,26 +65,26 @@ OPTIONS= LDAP "With LDAP support" off \
NOARGS_SHELL "Enable no arguments shell" off
LOGFAC?= local2
-CONFIGURE_ARGS+=--with-logfac=${LOGFAC}
+CONFIGURE_ARGS+= --with-logfac=${LOGFAC}
.include <bsd.port.pre.mk>
# SUDO_SECURE_PATH is a PATH string that will override the user's PATH.
# ex: make SUDO_SECURE_PATH="/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin"
.if defined(SUDO_SECURE_PATH)
-CONFIGURE_ARGS+=--with-secure-path="${SUDO_SECURE_PATH}"
+CONFIGURE_ARGS+= --with-secure-path="${SUDO_SECURE_PATH}"
.endif
.if defined(WITH_INSULTS)
-CONFIGURE_ARGS+=--with-insults
-CONFIGURE_ARGS+=--with-all-insults
+CONFIGURE_ARGS+= --with-insults
+CONFIGURE_ARGS+= --with-all-insults
.endif
.if defined(WITH_LDAP)
-USE_OPENLDAP=yes
-CONFIGURE_ARGS+=--with-ldap=${PREFIX}
-SUDO_LDAP_CONF?=ldap.conf
-CONFIGURE_ARGS+=--with-ldap-conf-file=${PREFIX}/etc/${SUDO_LDAP_CONF}
+USE_OPENLDAP= yes
+CONFIGURE_ARGS+= --with-ldap=${PREFIX}
+SUDO_LDAP_CONF?= ldap.conf
+CONFIGURE_ARGS+= --with-ldap-conf-file=${PREFIX}/etc/${SUDO_LDAP_CONF}
PLIST_SUB+= LDAP=""
MAN5+= sudoers.ldap.5
.else
@@ -104,17 +104,18 @@ CONFIGURE_ARGS+=--enable-noargs-shell
.endif
MAN5+= sudoers.5
-MAN8= sudo.8 visudo.8 sudoreplay.8
+MAN8= sudo.8 visudo.8 sudoreplay.8 sudo_plugin.8
MLINKS= sudo.8 sudoedit.8
post-patch:
@${REINPLACE_CMD} -E '/install-(binaries|noexec):/,/^$$/ \
s/\$$\(INSTALL\)/& ${STRIP}/;s/-b\~/-b ~/' \
- ${WRKSRC}/Makefile.in
+ ${WRKSRC}/src/Makefile.in
.if defined(NOPORTDOCS)
- @${REINPLACE_CMD} -e 's/$$(DESTDIR)$$(sudoersdir) $$(DESTDIR)$$(docdir)/$$(DESTDIR)$$(sudoersdir)/' \
- ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e '/for f in ChangeLog/d' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's/mkinstalldirs $$(DESTDIR)$$(docdir)/mkinstalldirs/' \
+ ${WRKSRC}/doc/Makefile.in
+ @${REINPLACE_CMD} -e '/for f in $$(OTHER_DOCS); do/d;/@LDAP@for f in $$(OTHER_DOCS_LDAP); do/d' ${WRKSRC}/doc/Makefile.in
+ @${REINPLACE_CMD} -e 's/$$(DESTDIR)$$(sudoersdir) $$(DESTDIR)$$(docdir)/$$(DESTDIR)$$(sudoersdir)/' ${WRKSRC}/plugins/sudoers/Makefile.in
.endif
post-install:
@@ -126,6 +127,5 @@ post-install:
if [ ! -f ${PREFIX}/etc/sudoers ]; then \
${CP} -p ${PREFIX}/etc/sudoers.sample ${PREFIX}/etc/sudoers; \
fi
- ${TOUCH} ${PREFIX}/etc/sudoers.d/.keep-me
.include <bsd.port.post.mk>
diff --git a/security/sudo/distinfo b/security/sudo/distinfo
index 049a12b37a7c..50d2017bf313 100644
--- a/security/sudo/distinfo
+++ b/security/sudo/distinfo
@@ -1,2 +1,2 @@
-SHA256 (sudo-1.7.4p6.tar.gz) = 20091ef71018698c674c779f4b57178b2ecb4275fa34909b06219d2688ad14d5
-SIZE (sudo-1.7.4p6.tar.gz) = 966234
+SHA256 (sudo-1.8.1.tar.gz) = 87cfb9c06e69fc16bb8246554804452130a1202b046e069b0da3e3b3a633f0cb
+SIZE (sudo-1.8.1.tar.gz) = 1238495
diff --git a/security/sudo/files/patch-Makefile.in b/security/sudo/files/patch-Makefile.in
deleted file mode 100644
index 0bba1fb822cc..000000000000
--- a/security/sudo/files/patch-Makefile.in
+++ /dev/null
@@ -1,14 +0,0 @@
---- Makefile.in.orig 2010-09-04 05:43:57.000000000 +0800
-+++ Makefile.in 2010-09-08 11:19:29.000000000 +0800
-@@ -498,9 +498,8 @@
- install-sudoers: install-dirs
- $(INSTALL) -d -O $(sudoers_uid) -G $(sudoers_gid) -M 0750 \
- $(DESTDIR)$(sudoersdir)/sudoers.d
-- test -f $(DESTDIR)$(sudoersdir)/sudoers || \
-- $(INSTALL) -O $(sudoers_uid) -G $(sudoers_gid) -M $(sudoers_mode) \
-- sudoers $(DESTDIR)$(sudoersdir)/sudoers
-+ $(INSTALL) -O $(sudoers_uid) -G $(sudoers_gid) -M $(sudoers_mode) \
-+ sudoers $(DESTDIR)$(sudoersdir)/sudoers.sample
-
- install-doc: install-dirs ChangeLog
- (cd $(srcdir) && for f in ChangeLog HISTORY LICENSE NEWS README TROUBLESHOOTING UPGRADE sample.*; do $(INSTALL) -O $(install_uid) -G $(install_gid) -M 0444 $$f $(DESTDIR)$(docdir); done)
diff --git a/security/sudo/files/patch-plugins__sudoers__Makefile.in b/security/sudo/files/patch-plugins__sudoers__Makefile.in
new file mode 100644
index 000000000000..e7232c920b62
--- /dev/null
+++ b/security/sudo/files/patch-plugins__sudoers__Makefile.in
@@ -0,0 +1,23 @@
+--- ./plugins/sudoers/Makefile.in.orig 2011-04-06 10:59:31.000000000 -0400
++++ ./plugins/sudoers/Makefile.in 2011-04-09 21:26:23.120266452 -0400
+@@ -350,17 +350,15 @@
+ install-includes:
+
+ install-doc:
++ @LDAP@$(SHELL) $(top_srcdir)/mkinstalldirs $(DESTDIR)$(docdir)
+ @LDAP@$(INSTALL) -O $(install_uid) -G $(install_gid) -M 0555 $(srcdir)/sudoers2ldif $(DESTDIR)$(docdir)
+
+ install-plugin: sudoers.la install-dirs
+ $(INSTALL) -b~ -O $(install_uid) -G $(install_gid) -M 0755 .libs/sudoers$(soext) $(DESTDIR)$(plugindir)
+
+ install-sudoers: install-dirs
+- $(INSTALL) -d -O $(sudoers_uid) -G $(sudoers_gid) -M 0750 \
+- $(DESTDIR)$(sudoersdir)/sudoers.d
+- test -r $(DESTDIR)$(sudoersdir)/sudoers || \
+- $(INSTALL) -O $(sudoers_uid) -G $(sudoers_gid) -M $(sudoers_mode) \
+- sudoers $(DESTDIR)$(sudoersdir)/sudoers
++ $(INSTALL) -O $(sudoers_uid) -G $(sudoers_gid) -M $(sudoers_mode) \
++ sudoers $(DESTDIR)$(sudoersdir)/sudoers.sample
+
+ uninstall:
+ -rm -f $(DESTDIR)$(plugindir)/sudoers$(soext)
diff --git a/security/sudo/files/patch-sudoers b/security/sudo/files/patch-plugins__sudoers__sudoers.in
index adb81b144c7c..c987e3c1dcb5 100644
--- a/security/sudo/files/patch-sudoers
+++ b/security/sudo/files/patch-plugins__sudoers__sudoers.in
@@ -1,16 +1,16 @@
---- ./sudoers.in.orig 2010-07-30 11:58:54.000000000 -0400
-+++ ./sudoers.in 2010-08-15 21:31:54.000000000 -0400
+--- ./plugins/sudoers/sudoers.in.orig 2010-08-18 07:45:38.000000000 -0400
++++ ./plugins/sudoers/sudoers.in 2011-04-09 21:23:16.616272145 -0400
@@ -31,6 +31,14 @@
##
## Defaults specification
##
+## Uncomment if needed to preserve environmental variables related to the
+## FreeBSD pkg_* utilities and fetch.
-+# Defaults env_keep += "PKG_PATH PKG_DBDIR PKG_TMPDIR TMPDIR PACKAGEROOT PACKAGESITE PKGDIR FTP_PASSIVE_MODE"
++# Defaults env_keep += "PKG_PATH PKG_DBDIR PKG_TMPDIR TMPDIR PACKAGEROOT PACKAGESITE PKGDIR FTP_PASSIVE_MODE"
+##
+## Additionally uncomment if needed to preserve environmental variables
+## related to portupgrade
-+# Defaults env_keep += "PORTSDIR PORTS_INDEX PORTS_DBDIR PACKAGES PKGTOOLS_CONF"
++# Defaults env_keep += "PORTSDIR PORTS_INDEX PORTS_DBDIR PACKAGES PKGTOOLS_CONF"
+##
## You may wish to keep some of the following environment variables
## when running commands via sudo.
diff --git a/security/sudo/pkg-plist b/security/sudo/pkg-plist
index 3c119d160f42..fa8ef9a7d0a4 100644
--- a/security/sudo/pkg-plist
+++ b/security/sudo/pkg-plist
@@ -7,7 +7,9 @@ etc/sudoers.sample
@unexec if cmp -s %D/etc/pam.d/sudo.default %D/etc/pam.d/sudo; then rm -f %D/etc/pam.d/sudo ; fi
etc/pam.d/sudo.default
@exec if [ ! -f %D/etc/pam.d/sudo ] ; then cp -p %D/%F %B/sudo; fi
+include/sudo_plugin.h
libexec/sudo_noexec.so
+libexec/sudoers.so
sbin/visudo
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/HISTORY
@@ -17,6 +19,7 @@ sbin/visudo
%%PORTDOCS%%%%DOCSDIR%%/TROUBLESHOOTING
%%PORTDOCS%%%%DOCSDIR%%/UPGRADE
%%PORTDOCS%%%%DOCSDIR%%/sample.pam
+%%PORTDOCS%%%%DOCSDIR%%/sample.sudo.conf
%%PORTDOCS%%%%DOCSDIR%%/sample.sudoers
%%PORTDOCS%%%%DOCSDIR%%/sample.syslog.conf
%%LDAP%%%%PORTDOCS%%%%DOCSDIR%%/README.LDAP
@@ -25,5 +28,3 @@ sbin/visudo
%%LDAP%%%%PORTDOCS%%%%DOCSDIR%%/schema.ActiveDirectory
%%LDAP%%%%PORTDOCS%%%%DOCSDIR%%/sudoers2ldif
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-etc/sudoers.d/.keep-me
-@dirrmtry etc/sudoers.d