aboutsummaryrefslogtreecommitdiffstats
path: root/security/sudosh
diff options
context:
space:
mode:
authorcy <cy@FreeBSD.org>2007-01-07 06:42:50 +0800
committercy <cy@FreeBSD.org>2007-01-07 06:42:50 +0800
commit578c86e590079684063c0c964b652a243f4bae4f (patch)
tree121a26b71661e7d9eded6033e088719a229cede9 /security/sudosh
parent3f02bb065b2582174ea5c038dde08fdc99f8bb2a (diff)
downloadfreebsd-ports-gnome-578c86e590079684063c0c964b652a243f4bae4f.tar.gz
freebsd-ports-gnome-578c86e590079684063c0c964b652a243f4bae4f.tar.zst
freebsd-ports-gnome-578c86e590079684063c0c964b652a243f4bae4f.zip
Fix SIBGUS and SIGSEGV violations on amd64 platform.
Diffstat (limited to 'security/sudosh')
-rw-r--r--security/sudosh/Makefile2
-rw-r--r--security/sudosh/files/patch-src-parse.c12
2 files changed, 13 insertions, 1 deletions
diff --git a/security/sudosh/Makefile b/security/sudosh/Makefile
index 1ee670dc6228..e63bfdd9f01e 100644
--- a/security/sudosh/Makefile
+++ b/security/sudosh/Makefile
@@ -7,7 +7,7 @@
PORTNAME= sudosh
PORTVERSION= 1.8.2
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= ${PORTNAME:S/_/-/}
diff --git a/security/sudosh/files/patch-src-parse.c b/security/sudosh/files/patch-src-parse.c
new file mode 100644
index 000000000000..646cb65d3235
--- /dev/null
+++ b/security/sudosh/files/patch-src-parse.c
@@ -0,0 +1,12 @@
+--- src/parse.c.orig Sun Jun 12 16:22:42 2005
++++ src/parse.c Fri Jan 5 17:54:55 2007
+@@ -19,7 +19,8 @@
+ void parse(option * o, const char *file)
+ {
+ FILE *f = fopen(file, "r");
+- unsigned int line_number, i;
++ unsigned int line_number;
++ int i;
+ char line[BUFSIZ];
+ char *arg, *cmt, *opt;
+ config *scan;