aboutsummaryrefslogtreecommitdiffstats
path: root/security/super
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2004-09-04 01:55:00 +0800
committerobrien <obrien@FreeBSD.org>2004-09-04 01:55:00 +0800
commit97522ce104d74a4cc5bffe6683c4dce5b249373e (patch)
treea36df12add2874278136d7c40cbd130f03b56b47 /security/super
parent5c525a61fbc889a1ac70f48a856f5d193a2aabda (diff)
downloadfreebsd-ports-gnome-97522ce104d74a4cc5bffe6683c4dce5b249373e.tar.gz
freebsd-ports-gnome-97522ce104d74a4cc5bffe6683c4dce5b249373e.tar.zst
freebsd-ports-gnome-97522ce104d74a4cc5bffe6683c4dce5b249373e.zip
Update to 3.23.0. This release of super fixes a potential root exploit:
http://xforce.iss.net/xforce/xfdb/16458 PR: 71328 Submitted by: Piet Delport <pjd@point45.com>
Diffstat (limited to 'security/super')
-rw-r--r--security/super/Makefile2
-rw-r--r--security/super/distinfo4
-rw-r--r--security/super/files/patch-localsys.h9
-rw-r--r--security/super/files/patch-utils.c14
4 files changed, 12 insertions, 17 deletions
diff --git a/security/super/Makefile b/security/super/Makefile
index 494e4872c378..73543cb9071d 100644
--- a/security/super/Makefile
+++ b/security/super/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= super
-PORTVERSION= 3.20.1
+PORTVERSION= 3.23.0
CATEGORIES= security sysutils
MASTER_SITES= ftp://ftp.ucolick.org/pub/users/will/
EXTRACT_SUFX= -tar.gz
diff --git a/security/super/distinfo b/security/super/distinfo
index 0ffd9cc70677..26d0b57c7579 100644
--- a/security/super/distinfo
+++ b/security/super/distinfo
@@ -1,2 +1,2 @@
-MD5 (super-3.20.1-tar.gz) = 9d0466d57e85bd94d82c8f934c39c500
-SIZE (super-3.20.1-tar.gz) = 200982
+MD5 (super-3.23.0-tar.gz) = 01c7e6cae4622683452425985fef2e2b
+SIZE (super-3.23.0-tar.gz) = 222367
diff --git a/security/super/files/patch-localsys.h b/security/super/files/patch-localsys.h
new file mode 100644
index 000000000000..15bdac0317ab
--- /dev/null
+++ b/security/super/files/patch-localsys.h
@@ -0,0 +1,9 @@
+--- localsys.h.orig Fri Jun 18 09:22:22 2004
++++ localsys.h Fri Sep 3 10:52:44 2004
+@@ -295,4 +295,6 @@
+
++#ifndef __FreeBSD__ /* FBSD has a malloc.h that tells people to obey C89. */
+ #ifdef HAVE_MALLOC_H
+ #include <malloc.h>
++#endif
+ #endif
diff --git a/security/super/files/patch-utils.c b/security/super/files/patch-utils.c
deleted file mode 100644
index 827a2751bc00..000000000000
--- a/security/super/files/patch-utils.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- utils.c.orig Mon Jun 16 15:34:14 2003
-+++ utils.c Sun Jul 13 15:06:15 2003
-@@ -1272,9 +1272,10 @@
- if (add_variable("SI_SYSNAME", buf) == -1)
- return -1;
- }
-- return 0;
- #endif
- #endif
-+
-+ return 0;
- }
-
- #ifdef HAVE_UNAME