aboutsummaryrefslogtreecommitdiffstats
path: root/security/suricata
diff options
context:
space:
mode:
authorzi <zi@FreeBSD.org>2012-07-16 19:18:34 +0800
committerzi <zi@FreeBSD.org>2012-07-16 19:18:34 +0800
commita7ee439f233fb32bd81dddc1e2ecc1bfd236273f (patch)
tree88a4f0895ac19a43bbf933f0fe33fa3a97a8cea2 /security/suricata
parenta553b4a7184f8b5d4a3c6518cd40ee02c0b5643e (diff)
downloadfreebsd-ports-gnome-a7ee439f233fb32bd81dddc1e2ecc1bfd236273f.tar.gz
freebsd-ports-gnome-a7ee439f233fb32bd81dddc1e2ecc1bfd236273f.tar.zst
freebsd-ports-gnome-a7ee439f233fb32bd81dddc1e2ecc1bfd236273f.zip
- Mark BROKEN when compiling with clang
Diffstat (limited to 'security/suricata')
-rw-r--r--security/suricata/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/security/suricata/Makefile b/security/suricata/Makefile
index 8978362314e4..a504d8686554 100644
--- a/security/suricata/Makefile
+++ b/security/suricata/Makefile
@@ -63,6 +63,10 @@ LOGS_DIR= /var/log/suricata
BROKEN= Does not compile on ia64, powerpc, or sparc64
.endif
+.if ${CC} == "clang" || ${CXX} == "clang++"
+BROKEN= Does not build when compiled with clang
+.endif
+
.if ${PORT_OPTIONS:MPRELUDE}
LIB_DEPENDS+= prelude:${PORTSDIR}/security/libprelude
CONFIGURE_ARGS+= --enable-prelude \