aboutsummaryrefslogtreecommitdiffstats
path: root/security/tea-total
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2000-12-20 03:10:09 +0800
committerobrien <obrien@FreeBSD.org>2000-12-20 03:10:09 +0800
commit31e4e1046dcc6dca329d2459b1019d252f77f7fd (patch)
treec8c6fc1bf4bf1a8090b8fb7954289d75b54a53c9 /security/tea-total
parent2948fa481c3a075d6558cea3f88d334af2f28cfd (diff)
downloadfreebsd-ports-gnome-31e4e1046dcc6dca329d2459b1019d252f77f7fd.tar.gz
freebsd-ports-gnome-31e4e1046dcc6dca329d2459b1019d252f77f7fd.tar.zst
freebsd-ports-gnome-31e4e1046dcc6dca329d2459b1019d252f77f7fd.zip
TEA Total is an extremely small 128 bit private key based
encryption/decryption system which uses the new variant of TEA (Tiny Encryption Algorithm) by David Wheeler and Roger Needham of the Cambridge Computer Laboratory. TEA is said to be several times faster than DES, as well as being much smaller and more secure. It also isn't encumbered by any patents and the reference implementation is in the public domain.
Diffstat (limited to 'security/tea-total')
-rw-r--r--security/tea-total/Makefile23
-rw-r--r--security/tea-total/distinfo1
-rw-r--r--security/tea-total/files/patch-Makefile10
-rw-r--r--security/tea-total/pkg-comment1
-rw-r--r--security/tea-total/pkg-descr10
-rw-r--r--security/tea-total/pkg-plist3
6 files changed, 48 insertions, 0 deletions
diff --git a/security/tea-total/Makefile b/security/tea-total/Makefile
new file mode 100644
index 000000000000..03b921399965
--- /dev/null
+++ b/security/tea-total/Makefile
@@ -0,0 +1,23 @@
+# ex:ts=8
+# Ports collection makefile for: tea-total
+# Date created: Tue Dec 19, 2000
+# Whom: David O'Brien (obrien@NUXI.com)
+#
+# $FreeBSD$
+#
+
+PORTNAME= tea-total
+PORTVERSION= 0.1
+CATEGORIES= security
+MASTER_SITES= ftp://ftp.linuxhacker.org/pub/tea-total/ \
+ http://www.linuxhacker.org/tea-total/
+
+MAINTAINER= obrien@FreeBSD.org
+
+# code is not 64-bit clean...
+ONLY_FOR_ARCHS= i386
+
+post-install:
+ cd ${WRKSRC} ; ${INSTALL_PROGRAM} tea tea-keygen untea ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/security/tea-total/distinfo b/security/tea-total/distinfo
new file mode 100644
index 000000000000..753f942a9a09
--- /dev/null
+++ b/security/tea-total/distinfo
@@ -0,0 +1 @@
+MD5 (tea-total-0.1.tar.gz) = 9990cdd53a619cc1cc19b6afa16c38cc
diff --git a/security/tea-total/files/patch-Makefile b/security/tea-total/files/patch-Makefile
new file mode 100644
index 000000000000..8e7ace9edb6f
--- /dev/null
+++ b/security/tea-total/files/patch-Makefile
@@ -0,0 +1,10 @@
+--- Makefile.orig Thu Dec 14 14:40:37 2000
++++ Makefile Tue Dec 19 10:49:35 2000
+@@ -1 +1 @@
+-CC = gcc
++#CC = gcc
+@@ -5,2 +5,2 @@
+-MD5SUM = md5sum
+-CFLAGS = -O3 -Wall
++MD5SUM ?= /sbin/md5 -r
++CFLAGS += -Wall
diff --git a/security/tea-total/pkg-comment b/security/tea-total/pkg-comment
new file mode 100644
index 000000000000..9450d3f1024f
--- /dev/null
+++ b/security/tea-total/pkg-comment
@@ -0,0 +1 @@
+Extremely small 128 bit private key based encryption/decryption system
diff --git a/security/tea-total/pkg-descr b/security/tea-total/pkg-descr
new file mode 100644
index 000000000000..f9aa0c78a16d
--- /dev/null
+++ b/security/tea-total/pkg-descr
@@ -0,0 +1,10 @@
+TEA Total is an extremely small 128 bit private key based
+encryption/decryption system which uses the new variant of TEA (Tiny
+Encryption Algorithm) by David Wheeler and Roger Needham of the Cambridge
+Computer Laboratory.
+
+TEA is said to be several times faster than DES, as well as being much
+smaller and more secure. It also isn't encumbered by any patents and the
+reference implementation is in the public domain.
+
+WWW: http://www.linuxhacker.org/tea-total/
diff --git a/security/tea-total/pkg-plist b/security/tea-total/pkg-plist
new file mode 100644
index 000000000000..d69c2dc798fb
--- /dev/null
+++ b/security/tea-total/pkg-plist
@@ -0,0 +1,3 @@
+bin/tea
+bin/tea-keygen
+bin/untea