aboutsummaryrefslogtreecommitdiffstats
path: root/security/tinyca/Makefile
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2003-08-31 16:49:28 +0800
committerkrion <krion@FreeBSD.org>2003-08-31 16:49:28 +0800
commit518d448fd71db671f29e057228608348a2a6cad4 (patch)
treed3bb7bf5d85553520e8b3cac6efbf4b1390ce7ee /security/tinyca/Makefile
parent2b59e1d5001c97542eebc72c77802b8a6f9d7e6c (diff)
downloadfreebsd-ports-gnome-518d448fd71db671f29e057228608348a2a6cad4.tar.gz
freebsd-ports-gnome-518d448fd71db671f29e057228608348a2a6cad4.tar.zst
freebsd-ports-gnome-518d448fd71db671f29e057228608348a2a6cad4.zip
- New port: security/tinyca version 0.4.9
TinyCA is a simple graphical userinterface written in Perl/Tk to manage a small CA (Certification Authority). PR: 54571 Submitted by: Janos Mohacsi <janos.mohacsi@bsd.hu>
Diffstat (limited to 'security/tinyca/Makefile')
-rw-r--r--security/tinyca/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/security/tinyca/Makefile b/security/tinyca/Makefile
new file mode 100644
index 000000000000..624b76bcef96
--- /dev/null
+++ b/security/tinyca/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: tinyca
+# Date created: 17 July 2003
+# Whom: Janos.Mohacsi@bsd.hu
+#
+# $FreeBSD$
+#
+
+PORTNAME= tinyca
+PORTVERSION= 0.4.9
+CATEGORIES= security net
+MASTER_SITES= http://tinyca.sm-zone.net/
+
+MAINTAINER= Janos.Mohacsi@bsd.hu
+COMMENT= Simple graphical interface to manage a small Certification Authority
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Tk.pm:${PORTSDIR}/x11-toolkits/p5-Tk \
+ ${SITE_PERL}/${PERL_ARCH}/Locale/gettext.pm:${PORTSDIR}/devel/p5-Locale-gettext \
+ zip:${PORTSDIR}/archivers/zip
+
+WRKSRC= ${WRKDIR}/TinyCA
+USE_PERL5= yes
+USE_OPENSSL= yes
+NO_BUILD= yes
+DOC_FILES= INSTALL
+LIB_FILES= CA.pm CERT.pm GUI.pm KEY.pm OpenSSL.pm REQ.pm TCONFIG.pm
+
+do-install:
+ @${MKDIR} ${SITE_PERL}/${PORTNAME}/
+.for file in ${LIB_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/lib/${file} ${SITE_PERL}/${PORTNAME}
+.endfor
+ @${INSTALL_DATA} ${WRKSRC}/templates/openssl.cnf ${PREFIX}/etc/tinyca.cnf
+ @${SED} -e "s:%%PREFIX%%:${PREFIX}:g" -e "s:%%SITE_PERL%%:${SITE_PERL}:g" \
+ ${WRKSRC}/tinyca >${WRKSRC}/tinyca.new
+ @${INSTALL_SCRIPT} ${WRKSRC}/tinyca.new ${PREFIX}/bin/tinyca
+
+post-install:
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in ${DOC_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>