aboutsummaryrefslogtreecommitdiffstats
path: root/security/tor-devel
diff options
context:
space:
mode:
authorbf <bf@FreeBSD.org>2011-10-04 18:07:59 +0800
committerbf <bf@FreeBSD.org>2011-10-04 18:07:59 +0800
commitb23b76bb4b24ad0380811db8026d2130a07372fe (patch)
treed739a915af2d8b26e603a1de0cdb3ef4b266ce24 /security/tor-devel
parent942862981607e6cef752f5785ebf16fd6d67cb2e (diff)
downloadfreebsd-ports-gnome-b23b76bb4b24ad0380811db8026d2130a07372fe.tar.gz
freebsd-ports-gnome-b23b76bb4b24ad0380811db8026d2130a07372fe.tar.zst
freebsd-ports-gnome-b23b76bb4b24ad0380811db8026d2130a07372fe.zip
use a more common form of openssl handling
PR: 161011 Submitted by: crees
Diffstat (limited to 'security/tor-devel')
-rw-r--r--security/tor-devel/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/security/tor-devel/Makefile b/security/tor-devel/Makefile
index d5fa76959845..500350e65b35 100644
--- a/security/tor-devel/Makefile
+++ b/security/tor-devel/Makefile
@@ -62,6 +62,8 @@ OPTIONS= BUFFEREVENTS "use libevent's buffered IO" off \
THREADS "multi-threading support" on \
TRANSPARENT "transparent proxy support" on
+USE_OPENSSL= yes
+
USE_RC_SUBR= tor
SUB_FILES= pkg-message
@@ -73,7 +75,7 @@ CONFLICTS= tor-[0-9]*
MANCOMPRESSED= no
MAN1= tor.1 tor-resolve.1 torify.1 tor-gencert.1
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if defined(WITH_GMAKE)
USE_GMAKE= yes
@@ -92,7 +94,6 @@ CONFIGURE_ARGS+= --enable-gcc-hardening
(${OSVERSION} >= 900000 && ${OSVERSION} < 900027) )
WITH_OPENSSL_PORT= yes
.endif
-.include "${PORTSDIR}/Mk/bsd.openssl.mk"
.if defined(WITH_BUFFEREVENTS)
CONFIGURE_ARGS+= --enable-bufferevents
@@ -181,4 +182,4 @@ check regression-test test: build
@( cd ${BUILD_WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} \
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check )
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>