aboutsummaryrefslogtreecommitdiffstats
path: root/security/tor
diff options
context:
space:
mode:
authorbf <bf@FreeBSD.org>2011-09-24 03:58:35 +0800
committerbf <bf@FreeBSD.org>2011-09-24 03:58:35 +0800
commit5b28de9f0bff404f26a9185f6c5e7538362aa00f (patch)
tree6a2bd80a14a4916c5023ff052adc6ea84d68c5ef /security/tor
parenta15cd4574390c41c047c2522c7afa6cf7cb1636d (diff)
downloadfreebsd-ports-gnome-5b28de9f0bff404f26a9185f6c5e7538362aa00f.tar.gz
freebsd-ports-gnome-5b28de9f0bff404f26a9185f6c5e7538362aa00f.tar.zst
freebsd-ports-gnome-5b28de9f0bff404f26a9185f6c5e7538362aa00f.zip
add an option to use GNU make for those who wish
to perform parallel builds[1]; add a few mirrors to tor-devel Requested by: h.h. [1]
Diffstat (limited to 'security/tor')
-rw-r--r--security/tor/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/security/tor/Makefile b/security/tor/Makefile
index 90c1b43aad28..0de7cd1aaa78 100644
--- a/security/tor/Makefile
+++ b/security/tor/Makefile
@@ -7,6 +7,7 @@
PORTNAME= tor
DISTVERSION= 0.2.2.33
+PORTREVISION= 1
CATEGORIES= security net ipv6
MASTER_SITES= https://www.torproject.org/dist/ \
ftp://ftp.bit.nl/mirror/tor/ \
@@ -53,9 +54,8 @@ CONFIGURE_ENV= LDFLAGS="${LDFLAGS}" \
TOR_LDFLAGS_libevent="-L${LOCALBASE}/lib/event2" \
TOR_LIBEVENT_LIBS="-levent-2.0"
-MAKE_JOBS_UNSAFE= yes
-
OPTIONS= BUFFREELISTS "freelists for buffer RAM" on \
+ GMAKE "parallel build safety via GNU make" off \
INSTR_DOWNLOADS "instrument downloads for analysis" off \
TCMALLOC "use the tcmalloc memory allocation library" off \
THREADS "multi-threading support" on \
@@ -74,6 +74,12 @@ MAN1= tor.1 tor-resolve.1 torify.1 tor-gencert.1
.include <bsd.port.pre.mk>
+.if defined(WITH_GMAKE)
+USE_GMAKE= yes
+.else
+MAKE_JOBS_UNSAFE= yes
+.endif
+
.if ( (${OSVERSION} >= 703100 && ${OSVERSION} < 800000) || \
(${OSVERSION} >= 800500 && ${OSVERSION} < 900000) || \
(${OSVERSION} >= 900003) ) && !defined(USE_GCC) && empty(CC:M*gcc4*)