aboutsummaryrefslogtreecommitdiffstats
path: root/security/umit/Makefile
diff options
context:
space:
mode:
authoreadler <eadler@FreeBSD.org>2011-09-24 02:51:40 +0800
committereadler <eadler@FreeBSD.org>2011-09-24 02:51:40 +0800
commit01454e7686cc381e707570a2385bb8528799684e (patch)
tree746a131fa1a44ea9e27bb9378b5f167cf6d48cd0 /security/umit/Makefile
parentd0bb1bbf7efe0cb04423cbb33a7f76f6d8a8250e (diff)
downloadfreebsd-ports-gnome-01454e7686cc381e707570a2385bb8528799684e.tar.gz
freebsd-ports-gnome-01454e7686cc381e707570a2385bb8528799684e.tar.zst
freebsd-ports-gnome-01454e7686cc381e707570a2385bb8528799684e.zip
- update to version 1.0
- remove stale mastersite - bump USE_PYTHON to 2.5+ - use databases/py-sqlite3 instead of databases/py-pysqlite2x - set WITHOUT_PSYCO if python 2.6+ since py-psyco doesn't work with it - switch from custom do-build and do-install targets to USE_PYDISTUTILS - add INSTALLS_ICONS, remove INSTALLS_EGGINFO (pydistutils will handle it) - update WWW - update pkg-plist - patch out documentation build PR: ports/160072 Submitted by: Ruslan Mahmatkhanov <cvs-src@yandex.ru> Approved by: maintainer timeout (30 days) Approved by: bapt (mentor)
Diffstat (limited to 'security/umit/Makefile')
-rw-r--r--security/umit/Makefile25
1 files changed, 9 insertions, 16 deletions
diff --git a/security/umit/Makefile b/security/umit/Makefile
index 772562fb2893..0ff463df9720 100644
--- a/security/umit/Makefile
+++ b/security/umit/Makefile
@@ -6,30 +6,26 @@
#
PORTNAME= umit
-PORTVERSION= 0.9.3
-PORTREVISION= 7
+PORTVERSION= 1.0
CATEGORIES= security
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}-RC2 \
- http://bio3k.softboard.ru/uploads/arch/
-
+MASTER_SITES= SF
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= ayu@commun.jp
COMMENT= UMIT is the nmap frontend developed with Python and PyGTK
RUN_DEPENDS= ${LOCALBASE}/bin/nmap:${PORTSDIR}/security/nmap \
- ${PYTHON_SITELIBDIR}/pysqlite2/__init__.py:${PORTSDIR}/databases/py-pysqlite23
-
-BROKEN= leaves files behind on deinstallation
+ ${PYTHON_SITELIBDIR}/_sqlite3.so:${PORTSDIR}/databases/py-sqlite3
+INSTALLS_ICONS= yes
USE_BZIP2= yes
-USE_PYTHON= yes
USE_GNOME= pygtk2
-INSTALLS_EGGINFO= yes
+USE_PYTHON= 2.5+
+USE_PYDISTUTILS= yes
.include <bsd.port.pre.mk>
-.if ${ARCH} != "i386"
+.if ${ARCH} != "i386" || ${PYTHON_REL} > 260
WITHOUT_PSYCO= yes
.endif
@@ -42,10 +38,7 @@ pre-everything::
@${ECHO_MSG} '===> Define WITHOUT_PSYCO to disable devel/py-psyco optimization'
.endif
-do-build:
- cd ${WRKSRC} && ${PYTHON_CMD} setup.py build
-
-do-install:
- cd ${WRKSRC} && ${PYTHON_CMD} setup.py install --prefix ${PREFIX}
+post-patch:
+ ${REINPLACE_CMD} 's/self.build_html_doc()//' ${WRKSRC}/setup.py
.include <bsd.port.post.mk>