aboutsummaryrefslogtreecommitdiffstats
path: root/security/uvscan-dat/Makefile
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2000-09-03 07:35:10 +0800
committerkris <kris@FreeBSD.org>2000-09-03 07:35:10 +0800
commitc0ddc6c8d2d2bf60b537066d876028b68ae53030 (patch)
treebd4f60bdbc6f0447840d08cdbb04c84cd5a32673 /security/uvscan-dat/Makefile
parentfef803a0072515b2ca3e9e9014437e88662e931f (diff)
downloadfreebsd-ports-gnome-c0ddc6c8d2d2bf60b537066d876028b68ae53030.tar.gz
freebsd-ports-gnome-c0ddc6c8d2d2bf60b537066d876028b68ae53030.tar.zst
freebsd-ports-gnome-c0ddc6c8d2d2bf60b537066d876028b68ae53030.zip
This is a freebsd-native version of the McAfee virus scanner, for scanning
DOS/Windows files for viruses. This is trial software which may only be used for 30 days without purchasing a retail version. It includes a useful script (update_dat) for automatically downloading the latest .dat files should the port become out of date. Obtained from: NetBSD
Diffstat (limited to 'security/uvscan-dat/Makefile')
-rw-r--r--security/uvscan-dat/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/security/uvscan-dat/Makefile b/security/uvscan-dat/Makefile
new file mode 100644
index 000000000000..76fa2df72fa3
--- /dev/null
+++ b/security/uvscan-dat/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: uvscan_dat
+# Date created: 01 Sep 2000
+# Whom: Kris Kennaway <kris@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= uvscan_dat
+PORTVERSION= 4093
+CATEGORIES= security
+MASTER_SITES= http://download.nai.com/products/datfiles/4.x/nai/
+DISTNAME= dat-${PORTVERSION}
+EXTRACT_SUFX= .tar
+
+MAINTAINER= kris@FreeBSD.org
+
+NO_BUILD= YES
+NO_WRKSUBDIR= YES
+
+RESTRICTED= "Restricted to the license terms set for VirusScan"
+
+do-configure:
+ ${SED} -e 's:@PREFIX@:${PREFIX}:g' \
+ <${FILESDIR}/update_dat >${WRKDIR}/update_dat
+
+do-install:
+ ${MKDIR} ${PREFIX}/libexec/uvscan
+.for file in clean.dat internet.dat names.dat scan.dat
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/libexec/uvscan
+.endfor
+ ${MKDIR} ${PREFIX}/share/doc/uvscan
+.for file in reseller.txt readme.txt packing.lst
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/uvscan
+.endfor
+ ${INSTALL_SCRIPT} ${WRKDIR}/update_dat ${PREFIX}/sbin
+
+.include <bsd.port.mk>