aboutsummaryrefslogtreecommitdiffstats
path: root/security/vida
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2007-01-31 22:09:55 +0800
committerpav <pav@FreeBSD.org>2007-01-31 22:09:55 +0800
commitccd12ccd577604add511aad4ea4e71c32b3e2f06 (patch)
tree25b833c135dd7f2323045f819dc7121e621103fc /security/vida
parente2f15954f8960a944e8d5b2c28982257d8c6e91f (diff)
downloadfreebsd-ports-gnome-ccd12ccd577604add511aad4ea4e71c32b3e2f06.tar.gz
freebsd-ports-gnome-ccd12ccd577604add511aad4ea4e71c32b3e2f06.tar.zst
freebsd-ports-gnome-ccd12ccd577604add511aad4ea4e71c32b3e2f06.zip
- Patch net/libnet* to versioned libraries and header files, so they can
coexist PR: ports/103861 Submitted by: alepulver Tested by: pointyhat With hat: portmgr
Diffstat (limited to 'security/vida')
-rw-r--r--security/vida/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/security/vida/Makefile b/security/vida/Makefile
index 3e8635cd9308..059fa7514985 100644
--- a/security/vida/Makefile
+++ b/security/vida/Makefile
@@ -7,23 +7,25 @@
PORTNAME= vida
PORTVERSION= 0.7.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= http://vidatapipe.sourceforge.net/
MAINTAINER= mich@FreeBSD.org
COMMENT= Vida is a multi-datapipe handler
-BUILD_DEPENDS= libnet*<=1.1.0,1:${PORTSDIR}/net/libnet10
+BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet10
-LDFLAGS+= -pthread -lncurses -lpcap -lnet
+LDFLAGS+= ${PTHREAD_LIBS} -lncurses -lpcap `${LIBNET_CONFIG} --libs`
WRKSRC= ${WRKDIR}/${PORTNAME}
+LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet10-config
+
do-build:
cd ${WRKSRC} && \
- ${CC} -I${LOCALBASE}/include -L${LOCALBASE}/lib ${CFLAGS} vida.c funz.c dnshijacking.c \
- ${LDFLAGS} `libnet-config --defines` -o ${PORTNAME}
+ ${CC} `${LIBNET_CONFIG} --defines --cflags` ${CFLAGS} \
+ vida.c funz.c dnshijacking.c ${LDFLAGS} -o ${PORTNAME}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin