aboutsummaryrefslogtreecommitdiffstats
path: root/security/vscan
diff options
context:
space:
mode:
authorjeh <jeh@FreeBSD.org>2004-11-21 03:38:28 +0800
committerjeh <jeh@FreeBSD.org>2004-11-21 03:38:28 +0800
commitc0696335a2e05dcd1bc687b409f16141b8d0f495 (patch)
tree14694d70f86d2fae9dea3d4b7a0e2aaacd3d2e29 /security/vscan
parent02708ecc2ed5fe5ac9992207284636826f54224e (diff)
downloadfreebsd-ports-gnome-c0696335a2e05dcd1bc687b409f16141b8d0f495.tar.gz
freebsd-ports-gnome-c0696335a2e05dcd1bc687b409f16141b8d0f495.tar.zst
freebsd-ports-gnome-c0696335a2e05dcd1bc687b409f16141b8d0f495.zip
- uvscan depends on libm.so.2
- utilize PORTDOCS - add INSTALLS_SHLIB and makes portlint happier - bump PORTREVISION PR: 74146 Submitted by: leeym
Diffstat (limited to 'security/vscan')
-rw-r--r--security/vscan/Makefile24
-rw-r--r--security/vscan/pkg-plist2
2 files changed, 18 insertions, 8 deletions
diff --git a/security/vscan/Makefile b/security/vscan/Makefile
index 37b8034ea67e..554a0ccc7c03 100644
--- a/security/vscan/Makefile
+++ b/security/vscan/Makefile
@@ -7,7 +7,7 @@
PORTNAME= uvscan
PORTVERSION= 4.32e
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= http://download.nai.com/products/evaluation/virusscan/english/cmdline/bsd/v4.32/
DISTNAME= vbsd432e
@@ -23,13 +23,22 @@ RUN_DEPENDS+= ${LOCALBASE}/sbin/update_dat:${PORTSDIR}/security/uvscan-dat
LIB_DEPENDS+= c.3:${PORTSDIR}/misc/compat3x
.endif
-ONLY_FOR_ARCHS= i386
-NO_BUILD= YES
-NO_WRKSUBDIR= YES
+.if !defined(COMPAT4X)
+.if !exists(/usr/lib/libm.so.2) && !exists(/lib/libm.so.2)
+LIB_DEPENDS+= m.2:${PORTSDIR}/misc/compat4x
+.endif
+.endif
+
+ONLY_FOR_ARCHS= i386
+NO_BUILD= YES
+NO_WRKSUBDIR= YES
+INSTALLS_SHLIBS= YES
LICENSE= shareware
RESTRICTED= "restrictive 30 day evaluation license"
+PORTDOCS= e4320upg.pdf license.txt
+
do-configure:
${SED} <${FILESDIR}/uvscan.sh >${WRKSRC}/uvscan.sh \
-e 's:@@PREFIX@@:${PREFIX}:g'
@@ -45,8 +54,11 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/libexec/uvscan
.endfor
${MKDIR} ${PREFIX}/share/doc/uvscan
-.for file in e4320upg.pdf license.txt
- ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/uvscan
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for file in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
+.endif
.include <bsd.port.mk>
diff --git a/security/vscan/pkg-plist b/security/vscan/pkg-plist
index e3ba58445c09..17e5e8ed1513 100644
--- a/security/vscan/pkg-plist
+++ b/security/vscan/pkg-plist
@@ -6,5 +6,3 @@ lib/libbsdfv.so.4
libexec/uvscan/uvscan
libexec/uvscan/license.dat
libexec/uvscan/messages.dat
-share/doc/uvscan/e4320upg.pdf
-share/doc/uvscan/license.txt