aboutsummaryrefslogtreecommitdiffstats
path: root/security/vscan
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2007-04-19 01:18:41 +0800
committerrafan <rafan@FreeBSD.org>2007-04-19 01:18:41 +0800
commitf2b6878535cbd48505bb798f1392790f01d2d8ab (patch)
tree1b171dc444964ee115d1e9060c537e43d3aaafa9 /security/vscan
parent5c60d283ffe8cb6b56a6ea18cd8ed4aae3288055 (diff)
downloadfreebsd-ports-gnome-f2b6878535cbd48505bb798f1392790f01d2d8ab.tar.gz
freebsd-ports-gnome-f2b6878535cbd48505bb798f1392790f01d2d8ab.tar.zst
freebsd-ports-gnome-f2b6878535cbd48505bb798f1392790f01d2d8ab.zip
- Fix problem with fetching newer dat files (>= 5000)
- Replace deprecated variable PR: ports/111417 Submitted by: Larry Rosenman <ler at lerctr.org>
Diffstat (limited to 'security/vscan')
-rw-r--r--security/vscan/Makefile5
-rw-r--r--security/vscan/files/update_dat4
2 files changed, 5 insertions, 4 deletions
diff --git a/security/vscan/Makefile b/security/vscan/Makefile
index cefa2e30e81c..e5a3201bfdb6 100644
--- a/security/vscan/Makefile
+++ b/security/vscan/Makefile
@@ -7,7 +7,7 @@
PORTNAME= uvscan
PORTVERSION= 5.10e
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= http://download.nai.com/products/evaluation/virusscan/english/cmdline/bsd/v5.10/
DISTNAME= vbsd510e
@@ -28,7 +28,8 @@ USE_LDCONFIG32= ${PREFIX}/lib32
LDCONFIG= /sbin/ldconfig -32
.else
UVSCAN_LIB32=
-INSTALLS_SHLIB= YES
+USE_LDCONFIG= YES
+
.endif
.if defined(WITHOUT_COMPAT3)
diff --git a/security/vscan/files/update_dat b/security/vscan/files/update_dat
index 81edcf12841c..7539ed6e8f8c 100644
--- a/security/vscan/files/update_dat
+++ b/security/vscan/files/update_dat
@@ -7,12 +7,12 @@ cd @PREFIX@/libexec/uvscan/
# Force a low default and then get the current version's value
cur_AVVER="1"
if [ -f pkgdesc.ini ]; then
- cur_AVVER=`grep Version pkgdesc.ini | cut -f2 -d= |sed -e 's/^(\(4[0-9]+\)).*$/\1/'`
+ cur_AVVER=`grep Version pkgdesc.ini | cut -f2 -d= |sed -e 's/^(\([45][0-9]+\)).*$/\1/'`
fi
# Find what the website has for the current version
fetch -q http://download.nai.com/products/datfiles/4.x/nai/update.ini || exit 1
-AVVER="`grep DATVersion update.ini | head -1 | cut -f2 -d= | sed -e 's/^\(4[0-9]*\).$/\1/'`"
+AVVER="`grep DATVersion update.ini | head -1 | cut -f2 -d= | sed -e 's/^\([45][0-9]*\).$/\1/'`"
rm -f update.ini
# Check to make sure the requested version is "newer" then the current